Jump to content

D945GCLF2 - Snow Leopard installs won't boot after myHack 1.1

3 posts in this topic

Recommended Posts

Dear all


I recently built my first Hackintosh - hence my low number of posts. I was keen to do my own research and not just slink off and, like a n00b that I am ask the community to fix each and every one of my problems, but am at the end of my tether now so here goes...


My system is a Intel D945GCLF Board with the Atom 300 1.6 Ghz, some generic kingston RAM, and a Samsung HDD.


I used iATKOS S3 v2 and after 4 or 5 goes with the configuration I got a working installation using Starop's method here: http://www.insanelymac.com/forum/index.php?showtopic=183637&st=220 which installs Chameleon RC4 and EFI 10.6, followed his approach in the BIOS etc. All good.


A couple of Kexts later and I even had a decent screen resolution on the GMA 950. So I did the sensible thing and set up an external HDD and took a Time Machine backup of the system. I kept having to use the iATKOS SL DVD to boot though, selecting the install at the first screen. Although on a previous abortive attempt it worked fine with the bootloader options Starop suggested, I had to do a reinstall to take care of some gfx issues, but it was working from the DVD.


I installed myHack 1.0 and a result - SL now booted without the DVD. So i turned to cosmetic issues - the myHack 1.0 bootscreens look awful, so I looked to change versions to 1.01 which looked more vanilla. But for some reason I downloaded and installed myHack 1.1. Can't for the life of me work out why I did this. The proliferation of the number 1? Too much Whisky? Let's not dwell this...


Since then, my machine won't boot. In verbose it says ACPI not found: DSDT.aml.


So I did an erase of the HDD and fresh install from the DVD same as before. Same result - it won't boot and gives me the above message. So I tried a time machine restore from the install DVD - result successful, but exactly the same boot situation.


How can this be? I've erased the volume about 5 times, even as FAT32 before puting it back to GUID in case there was some boot partition or something that was still interfering with the install but nothing.


Anyone have any suggestions as to how I can fix this? I don't see why installation of SL working (to one degree or another) about 5 times previously but now it just can't create an OSX install that will boot from the HDD or the DVD.


Grateful for any insight you guys might have.



Link to comment
Share on other sites

Ok - that's maybe a bit too rambling.


Let's put it this way - what could cause an installation to refuse to boot and simply restart time after time, even if the hard disk is reformatted and a fresh install done every time?


The logical answer is that there is something wrong with my install method or bios settings, but these haven't changed from when I did get it working using Starop's method here: http://www.insanelymac.com/forum/index.php?showtopic=183637&st=220.


What am I missing? Does an erase of the HDD not remove boot modifications or something, so that might be what is causing the problem?

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...