Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Chimera 1.8.0 Not Loading on Lenovo ThinkPad T520

6 posts in this topic

Recommended Posts

I have a Lenovo ThinkPad T520. When I select to boot off of the USB drive, the underscore blinks once and then returns me to the boot selector menu.


The USB has OS 10.7.0 with Chimera 1.8.0 as the bootloader.


System Specs:

Motherboard: Intel® QM67

Processor: Intel® Core™ i7-2820QM (2.30GHz, 8MB L3, 1333MHz FSB)

Memory: 8GB DDR3 - 1333MHz (2 DIMM Slots)

Graphics: Discrete NVIDIA® NVS 4200M (1GB VRAM ) with Optimus™ Technology, Intel® Integrated HD Graphics

Share this post

Link to post
Share on other sites

I found the solution.


The problem isn't with Chimera, it's with the chipset and GUID partitioning. The chipset that ThinkPads only find MBR partitions using the BIOS bootloader.


On my computer I have the HDD adapter for the Ultrabay (CD/DVD drive slot), therefor giving me 2 hard drives. On the HDD in the Ultrabay I made it into 1 MBR partition and installed Chimera on it and installed Mac 10.7 on the internal hard drive using GUID. If you only have 1 hard drive, you'll have to format a USB device to MBR and install Chimera on it.


I hope that works for you.

Share this post

Link to post
Share on other sites

So how does it works on a T520? I have one and I'm thinking of installing it. Did you follow any guide/advise in particular? Thanks.

Share this post

Link to post
Share on other sites

I didn't follow any guide to do this, it was meerly trial and error on my part. I'll try my best to make a successful guide for you. It's going to take probably a week or so but I'm just letting you know I'm working on it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jojo2203
      habe versucht nach der Anleitung von http://x220.mcdonnelltech.com/  auf einen X220 i7 zu installieren, bisher leider erfolglos. kann mir jemand die angehangenen Log Meldungen interpretieren und einen Tip geben an welcher Stelle ich weiter probieren muss. Habe es schon mit den folgenden Bootparametern probiert
      -v -x -s -f cpus=1 maxmem=4096 GraphicsEnabler=No -no-zp
      Es war ein 8 GB Speicherriegel gesteckt und die "neue" WLAN Karte, außerdem ist zusätzlich zur MSATA eine weitere HDD installiert.

    • By bepferr
      Ciao a tutti! Ho un Lenovo y50-70 con schermo UHD e Intel hd4600.. vorrei installare High Sierra, ho letto che questo laptop è una delle configurazioni più compatibili in assoluto.. Solo che non ne ho le capacità Qualcuno sarebbe in grado di darmi una mano?
      grazie mille!
    • By giacomo.dessi2303
      Salve a tutti, ho un problema all'avvio di mac os che ho già provato a risolvere con foskvs ma senza risultati..
      Attualmente come smbios uso MacBookPro 12,1 (portatile in firma) mentre se uso imac 14,1 questo problema non si presenta.
      Dite che posso tenere iMac 14,1 magari rigenerando l'ssdt per il pm?
    • By bepferr
      Hello everyone! I installed OS Sierra 10.12.6  on a Lenovo y50-70 with 4k monitor following the tonymacx86 guide (this: https://www.tonymacx86.com/threads/guide-lenovo-y50-uhd-or-1080p-using-clover-uefi.232960/ ). All is OK (except the bluetooth but I consider that a secondary problem) except that I can not absolutely activate the monitor! For example, I can connect an external monitor via HDMI and so doing everything OK. I would like to understand how to do it, does anyone have any idea? I have already set up the DVMT prealloc to 128mb with modified bios and installed coredisplayfixup in L / E but nothing. If I boot up setting clover id-ig 0x12345678 the monitor works but the graphics card is recognized only as 31mb and everything is slow, the web pages for example are unusable. I have an integrated intel hd4600 card. I hope you can help me, thank you so much in advance!
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Release v2018.01.28 on GitHub Updated to Clover r4394 Updated apfs.efi to patched 10.13.3 version Updated Lilu and AppleALC kexts to v1.2.3 (supports both Sierra and High Sierra) Revised misc kexts (FakeSMC)  ​Various Tweaks over Last months
      The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: My system is a T460 with i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files

      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup

      Notes on Custom Kexts