Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
dellcorreo

Lion 1.7.3, nuevo driver nvidia, como funciona?

7 posts in this topic

Recommended Posts

Buenas,

 

Hace unas semanas nvidia lanzo los drivers 270.00.00, que logran aceptar cualquier tarjeta nvidia sobre los MAC PRO.

Ayer probe los nuevos drivers en el de la oficina con una tarjeta GTX460 y el MAC la reconocio perfectamente sin problemas, excepto por el arranque en negro hasta llegar a los usuarios.

 

Ahora bien, para los mortales como yo, que tenemos el hack en casa, tambien funcionan los drivers? Yo los he instalado pero no veo cambios de ningún tipo. actualmente tengo una GTX480 insertada por DSDT, pero en 3D funciona como una ATI4870 en cuanto a potencia. No puedo quitar el inserto en el DSDT, porque me quedo pegado en PCI Begin....

 

Alguien me regala un link o comenta como le ha ido con el tema...

Share this post


Link to post
Share on other sites

ni lo había visto... que mal.. ajaja

 

lo baje he instale

http://www.nvidia.com/object/macosx-270.00.00f01-driver.html

 

y los cuda tambien

http://www.nvidia.com/object/cuda-mac-driver.html

 

he hice de nuevo el parche de fermi, y no veo ninguna diferencia....

 

no tengo macpro ya... no te puedo decir aquí si va bien, pero en el foro de netkas hay varios resultados.

http://netkas.org/?p=1059

 

en tu dsdt quitaste o corregiste

Device (PCI0)

{

Name (_HID, EisaId ("PNP0A08")) // HID = Hardware ID. Es la referencia de búsqueda.

Name (_CID, EisaId ("PNP0A03")) // CID = Compatible ID. Es opcional, a veces no aparece.

Name (_ADR, 0x00) // ADR = Adress, o dirección del dispositivo. En mi caso no es necesario lo borre.

Name (_UID, 0x00) // UID = Unit ID, la parte escencial del fix (también puede ser 0x01).

juanerson

Share this post


Link to post
Share on other sites

Derty, donde bajo lo ultimo de mac para nvidia, drivers o parches nuevos? q a pasado, me aleje jeje

Share this post


Link to post
Share on other sites

delcorreo prueba cambiar este archivo en system/extra/extensions

 

http://www.mediafire...dykt5hbmd4laobb

 

 

normalmente si funciona en todas las nvidia, pero no veras cambios importantes.

 

Me acabo de dar cuenta "sroprendentemente" que he estado usando el DSDT, sin el arreglo de la GTX480, he colocado la correción pero igualmente no hay mejoras.

 

Una pregunta, la correcíon que yo aplico nunca toco el Device (PCI0), crees que deberia? igual me acabo de dar cuenta que sin arreglo funciona igual.

 

Device (GFX0)

{

Name (_ADR, Zero)

Name (_SUN, One)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x16)

{

"@0,compatible",

Buffer (0x0B)

{

"NVDA,NVMac"

},

 

"@0,device_type",

Buffer (0x08)

{

"display"

},

 

"@0,name",

Buffer (0x0F)

{

"NVDA,Display-A"

},

 

"@1,compatible",

Buffer (0x0B)

{

"NVDA,NVMac"

},

 

"@1,device_type",

Buffer (0x08)

{

"display"

},

 

"@1,name",

Buffer (0x0F)

{

"NVDA,Display-B"

},

 

"NVCAP",

Buffer (0x18)

{

/* 0000 */ 0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00,

/* 0008 */ 0x1C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0A,

/* 0010 */ 0x00, 0x00, 0x00, 0x00

},

 

"VRAM,totalsize",

Buffer (0x04)

{

0x00, 0x00, 0x00, 0x60

},

 

"device_type",

Buffer (0x0D)

{

"NVDA,GeForce"

},

 

"model",

Buffer (0x17)

{

"nVidia GeForce GTX 480"

},

 

"rom-revision",

Buffer (0x25)

{

"nVidia GeForce GTX 480 OpenGL Engine"

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

}

 

saludos

Share this post


Link to post
Share on other sites

Derty, donde bajo lo ultimo de mac para nvidia, drivers o parches nuevos? q a pasado, me aleje jeje

 

el post 2 los drivers y cuda

 

el post 4 el parche.

 

 

delcorreo, a mi solo me funciona bien como macpro 4.1. prueba a ver... puedes borrar el kext, AppleTyMCEDriver, algunos dicen que es parte de la solución.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×