Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
khris801822

Problemi con audio alc889

14 posts in this topic

Recommended Posts

Salve a tutti ho un problema che non riesco a risolvere con l' audio alc889 su Lion 10.7.3 .Praticamente ogni volta che parte una traccia audio viene sempre preceduta da una forte scarica fastidiosa... Utilizzo applehda.kext patchato con layout per alc889 e patch hdef nel dsdt. Premetto che ho fatto diverse prove con svariati kext come alc8xx ma il risultato è sempre lo stesso..Con i vodoo mi va in kernel panic... Qualcuno sa darmi una soluzione a questo fastidioso problema?

Share this post


Link to post
Share on other sites

Fai un tentativo con l'AppleHDA che ho messo a punto per il mio ALC889

 

http://www.insanelym...dpost&p=1804684

Grazie per la celere risposta ma purtroppo non va con il tuo applehda. non funziona proprio. Ma anche la parte del dsdt devo copiare dal tuo o devo lasciare il mio?

Edit: Allora ho iniettato anche la parte del tuo hdef nel mio dsdt e ora l' audio funziona. Devo verificare se fa ancora le scariche poi faccio sapere. Per il momento mille grazie.

Share this post


Link to post
Share on other sites

Ciao zell grazie per l' interessamento ma a quanto pare nemmeno tu hai risolto se non con microfono collegato. Il mio però non è un problema di rumore o fruscio ma piuttosto un rumore simile a quello che si ha quando si inserisce uno spinotto nell' entrata della scheda audio con periferica accesa, una specie di scarica insomma. Questo avviene solo appena faccio partire la prima traccia audio poi se ascolto musica in sequenza non lo fa più. La cosa curiosa è che poi se smetto di utilizzare l' audio pare che la periferica vada a riposo e quando vi riaccedo dopo un pò con una traccia audio oppure su una pagina web con pubblicità che hanno audio ecc... ecco che mi rifà la scarica che in certi casi è molto fastidiosa...L' applehda di buoo ha un pò accentuato la cosa ma non è del tutto scomparsa. Prima o poi se qualcuno dice la sua idea risolverò... Nel tuo caso comunque proverei a usare l' applehda per alc889 più la patch hdef nel dsdt e secondo me risolvi. :smoke:

Share this post


Link to post
Share on other sites

Dopo tante ricerche e qualche imprecazione ho trovato una cosa interessante che a quanto pare risolve il problema di queste scariche o pop come dirsivoglia... Ho trovato questo paccheto che si chiama antipop 1.0.2 che a quanto pare impedisce alla periferica audio di dormire e far la scarica quando la risvegliamo se si riaccede con una traccia audio... A questo punto mi chiedo e chiedo anche a voi più esperti di me se non sia possibile implementare questa funzione direttamente nel dsdt o nel kext in modo da evitare l' installazione del pacchetto... Chiunque abbia idee e suggerimenti in merito è ben accetto ... Bye :thumbsup_anim:

Share this post


Link to post
Share on other sites

Prova questi

No questi non vanno Carbo. Non rileva la periferica. Grazie comunque per l' interessamento. Credo comunque che la soluzione sia nel provare ad inserire questo antipop o nel kext o nel dsdt ma io non ho idea di come fare. Continuo a sperimentare.

Share this post


Link to post
Share on other sites

Ho trovato questi, SEMBRA funzionino bene x la tua MB, all'interno trovi anche la parte di codice da iniettare nel DSDT...

Inutile raccomandarti di fare un backup del DSDT e dei kext originali...

ALC889.zip

Share this post


Link to post
Share on other sites

Ho trovato questi, SEMBRA funzionino bene x la tua MB, all'interno trovi anche la parte di codice da iniettare nel DSDT...

Inutile raccomandarti di fare un backup del DSDT e dei kext originali...

Ciao carbo questi funzionano ma la scarica non mi abbandona mai :worried_anim: ... E che ce vuoi fà... Mi dovrò rassergnare ad averlo così poi magari un dì si troverà una soluzione definitiva. Per orà andrò con l' antipop perchè questa cosa mi sta sfinendo e mi voglio dedicare ad altri problemi come trovare le cause dei rallentamenti al boot... Grazie per il supporto :thumbsup_anim: ...

Share this post


Link to post
Share on other sites

Avete fatto progressi...? Io ho una Gigabyte GA-Z68MA-D2H-B3 con 889, ho avuto dal'inizio questo problema poi risolto su segnalazione di carbo178 con antipop, ho visto che macpro3.1 evita come per il video che anche l'audio vada in risparmio ma ovviamente cercavo una soluzione più elegante... Dicono che l'antipop su Lion dopo due ore abbuia l'audio, ma non ho mai verificato.

 

Ciao...

Share this post


Link to post
Share on other sites

In che senso abbuia l' audio? Io ormai lo uso da tempo e sinceramente non ho cercato più soluzioni altrove perchè con antipop funziona bene e non vedo tracce su kernellog di problemi causati da esso... Mettere mac pro 3,1 non so, non ho mai provato, ma poi magari crea problemi in altri ambiti... Per ora la soluzione antipop è per me la migliore poi vedremo più in là...

Share this post


Link to post
Share on other sites

Avevo letto di non usare antipop su Lion perchè creava questo problema, dopo due ore l'audio spariva, meglio così...

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×