Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

[SOLVED] RAID UUID: booting from a restored backup

3 posts in this topic

Recommended Posts

[sOLVED] I solved this problem by reinstalling the Chameleon binaries to each RAID slice, and by placing a copy of the /Extra folder (with the new UUID) into the Boot OS X partition of each RAID Slice.




I screwed up my Hackintosh after attempting to upgrade from 10.7.2 to 10.7.3. So I decided to boot from an installation USB drive, and then restore via a time machine backup. This process wipes out the existing RAID 0 drive, and restores over it. When this happened, the UUID for the RAID logical drive changes. When i attempt to boot from the freshly restored backup, It stops at this message:


Rooting via boot-uuid from /chosen: xxxx-xxxxxxx-xxxxx-xxx-xxx(the old UUID)


I thought the answer was to simply change the UUID in org.chameleon.Boot.plist to the new logical drive's UUID. I did this, and it didn't fix it. the boot screen still tries to point to the old UUID. Does anyone know where else I can look to change the UUID?


Thank you.

Share this post

Link to post
Share on other sites

Thanks, but I'm not sure you read through my post. I know what the new UUID is. the problem is that the restored system is trying to boot from the previous logical drive's UUID. I'm not sure where else I can change this to point to the new UUID, instead of the old one. I've already added the new UUID to /Extra/


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.