Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Zman21295

Fixing the "boot0 error" on newer hard drives.

3 posts in this topic

Recommended Posts

********THIS IS FOR PEOPLE WHO ARE USING A HARD DRIVE WITH 4Kb sectors instead of 512byte sectors. What happens is Chimera will not install correctly and you will get a "boot0 error"************

 

To fix the Boot0 error you need to install the boot1h file manually to the boot partition, the procedure is as follows:

 

•Install lion (I used ###### as it was the only method that worked and is pretty much idiot proof)

 

•Before installing any bootloader, Boot into lion using the ######## stick and extract ####### (or a custom installer such as Andy's package) using pacifist and find the Chimera/usr/standalone/i386 folder and put the boot1h file into a folder called "Fix" on the root of your lion installer drive, ######. DON'T INSTALL THE ######## PACKAGE YET

 

•Boot back into the lion installer disk, don't worry we won't need to reinstall, and figure out the identifier of the partition you installed lion on. To do this, go to Utilities>Termanal and type "diskutil list" and find the identifier. Mine is rdisk0s2 the number 0 is the disk and the number 2 is the partition.

 

•Close Termanal and open Utilities>Disk Utility, select the partition you installed lion on and unmount it. THIS WILL NOT WORK WITH THE PARTITION MOUNTED. Close Disk Utility.

 

•Now in terminal Type "cd /Fix/" and hit enter. (cd stands for change directory.)

 

Then, if no error shows up, type: dd if=boot1h of=/dev/identifier

MAKE SURE YOU CHANGE IDENTIFIER TO THE ONE YOU WROTE DOWN FROM EARLIER. Mine is rdisk0s2 and hit enter.

 

•You should see a message telling you that so may bytes have been written.

 

•Reboot. Boot using the ####### drive again and this time select the lion partition. Once in lion install Chimera via ####### or a custom install package that you extracted the boot1h file from.

 

Reboot and take out the ###### drive and see if she boots. If so, it worked!!

 

Notes: This may work with Chameleon as they are pretty much the same. Just make sure that you extract the boot1h from the installer you intend to use.

 

Also: If you ever install again or restore from a backup you may need to do this again.

 

Sorry if the formatting is weird. I typed this guide on my iPhone when I was bored. I will fix tonight when I get "Back to my Mac" hehe.

Share this post


Link to post
Share on other sites

I tried a fix similar to this from another forum and it worked...

 

Glad to hear that! It is a weird error and I hope it will be fixed with future versions of Chameleon!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×