Jump to content
Trucker MK

AMD Radeon HD 6650M / Graphics Enabler / DSDT / HDMI Audio / Acer Aspire 7750G - 2674G50Mnkk [Gradients Fixed]

972 posts in this topic

Recommended Posts

ok, the dual link from pandora didnt change anything :/

 

tried with and without edie and with the pithecia and with the boot loader original fb. no changes at all in any case. just the gva acting like it was the lcd with his supported resolutions and stuff.

 

isnt the secret in the connectors? redirect the vga to the lcd in the kext with hex editor??

 

thanks

Share this post


Link to post
Share on other sites
Advertisement

Just tested this on Mavericks DP1 and its working, did you installed Enoch bootloader? i forgot to mention it. Boot with GraphicsEnabler=Yes AtiConfig=Pithecia and in org.chameleon.Boot.plist

 

post-423012-0-65204200-1375540362_thumb.png

 

Better start with clean installation. Create your bootable USB with Pandora, when finished installing boot into OS X and use the Post Installation options in Pandora's Box to install the bootloader and the dual link patch.

 

I will make another kext for you with encoder 01, this previous is with encoder 00.

 After that you can use the FixEDID app to inject your EDID and solve the color depth issue.

Share this post


Link to post
Share on other sites

This is the original Pithecia framebuffer in 10.8.4

Personality: Pithecia
ConnectorInfo count in decimal: 2
Disk offset in decimal 604736
0000000    00  04  00  00  04  03  00  00  00  01  00  00  21  03  02  04
0000010    04  00  00  00  14  02  00  00  00  01  00  00  00  00  04  03
0000020

This is the patched

02 00 00 00 40 00 00 00 09 01 00 00 10 01 02 01
04 00 00 00 14 02 00 00 00 01 00 00 00 00 04 03

I only patched the LVDS and left the other as is because your VGA was already working.

 

1. Copy ATI6000Conttroller.kext on your Desktop

2. Open HexEdit and go to File=>Open

post-423012-0-01981000-1375599868_thumb.png

3. In HexEDIT go to Find=>Find and Replace than a small window will pop up

post-423012-0-06484900-1375600344_thumb.png

4. In the "Find" field paste the original framebuffer (one line, first the LVDS etc.)

    In the "Replace With" field paste thhe modified framebuffer

   Make sure the  "Hex" radio button is checked and click "Find Next"

   In the HexEDIT window you will get this, which means the values you are searching for are found

post-423012-0-79057800-1375598650_thumb.png

5. Click Replace

6. Go to File=>Save

That's it

Share this post


Link to post
Share on other sites

You are welcome. If you share the kext and the fix with the enoch bootloader and dual link patch include links to my topic.

Share this post


Link to post
Share on other sites

hi i have a asus k54hr, second generation intel i3 and ati radeon 7470M(6470m). I installed iATKOS m3ul I would like to know how to get the maximum resolution in most qe / ci. I followed from page 17 to 20 because the video card is identical to mine but I can not figure out how to make it work please help me :)

Share this post


Link to post
Share on other sites

Can someone translate this,( I don't think that he is saying Thanks :D ) for some reason Google Translate it's not translating it.

 

"Afangul a ki te stra muort stu ricchion e merd"

 

Well I found the meaning of the word Fangul and its enough, i will report this to the mods

Share this post


Link to post
Share on other sites

do not worry about these words italian(sicilia) vulgar dialect is.

 

As for me I need your support, as mentioned in other posts my problem is to activate LVCD on my sony vaio

hdmi ok - vga ok 

 

I installed ML 10.8.3 - boot enouch (duallink) - ati6000 patchet previous post

you can kindly check my dsdt if is ok with all - ati 7650m 1002\6841

sending with and without ge and ioreg

send txt aida64 vbios (but I have  doubt is the one that needs)

look forward to your support thanks

no ge.zip

vga iponomea.zip

Report.txt

Share this post


Link to post
Share on other sites

send txt aida64 vbios (but I have  doubt is the one that needs)

 

You are right, whatch this video how to get the vbios VBIOS.zip

Right click on the lower left corner on AIDA64 window, than Video Debug => Video Bios Dump and save the file

Share this post


Link to post
Share on other sites

I managed to turn my video card according to the topic, my big problem is making it work switched or choose the video card to work alone. Here is operating as two monitors, one HD3000 card and another monitor to ati 6470M! The ati only works if mirrored. Follow the attached images.

Wow, interesting. Normally it shouldn't work this way I would say.. The reason is because on normal notebooks only integrated graphics card has connectors to display, while discrete card is connected to integrated one. On real Mac Books both cards are connected to display, thus switchable graphics works differently. There are some notebooks where switchable graphics works as on real Mac Books (fe. Dell Alienware series), but their price is almost identical to Mac Book Pro :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JoachimCraeye
      Hello, another struggling soul when it comes to AMD Radeon HD 6650M
      I got to the point where it looks as if i’m almost there, as the graphics are more or less stable.
      Also is my graphic card partly recognised, just wrong model and wrong videoram, should be AMD Radeon HD 6650M 2048 MB
      Also when for example, I’m opening Launchpad its pretty clear I’m not getting full acceleration
       
       
      In my clover config file in the tab kernel and kext patches  I’m having 
       


       
      SSDT-6.aml being the PEGP File
      DSDT.aml & SSSDT6.aml  are system files that i compiled.
      SSDT.aml was made by ssdtPRGen.sh 
      ioreg attached as well
      and my video bios
       
      DSDT SSDT SSDT6 IOREG VBIOS.zip
       
      i hope someone can tell me whats missing
       
      PS i realise I’m not there yet, i’m missing sound and such, but i just started on this machine , and wanted to sort this first
      At some point i tried the extraction of the dsdt code from the Vrom, but that resulted in me having a text file (sorta) with like 100’s and 100’s of short hexest thats where i lost it an was utterly lost. Please, teach me
       
    • By Trucker MK
      Those who followed my old thread about the AMD Radeon HD 6650M here already know that until now we were not able to inject custom EDID with Clover or with DSDT injection (needed for the gradients fix) . A while ago i finally solved the Gradients issue with the help from freeuser16 by using Andy Vandijck's FixEDID and DisplayMergeNUB.kext to inject custom EDID  but I always wondered what could be the problem and why Clover/DSDT EDID injection is not working for the 6650M. Few day ago i started to play around again with diferrent Transmitter, Encoder and SenseID values using Clover, of course using Custom EDID injection. Until now i always used Ipomoea or Pondweed patched framebuffer:
      02000000400000000901000010000003 00080000000200000001000011020101 10000000100000000001000000000205 based on the decoded VBIOS with radeon_bios_decoder
      PCI ID: 1002:6741 Connector at index 0 Type [@offset 44838]: LVDS (7) Encoder [@offset 44842]: INTERNAL_UNIPHY (0x1e) i2cid [@offset 44912]: 0x92, OSX senseid: 0x3 Connector at index 1 Type [@offset 44848]: HDMI-A (11) Encoder [@offset 44852]: INTERNAL_UNIPHY1 (0x20) i2cid [@offset 44935]: 0x90, OSX senseid: 0x1 Connector at index 2 Type [@offset 44858]: VGA (1) Encoder [@offset 44862]: INTERNAL_KLDSCP_DAC1 (0x15) i2cid [@offset 44962]: 0x94, OSX senseid: 0x5 and redsock_bios decoder:
      Connector Object Id [14] which is [LVDS] encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false Connector Object Id [12] which is [HDMI_TYPE_A] encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false Connector Object Id [5] which is [VGA] encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false This time i decided to test few other framebuffers with the same patched framebuffer values i used for Ipomoea and Pondweed. I made the changes in Clover's config.plist (this time i used Cattail) , rebooted (without DisplayMergeNUB.kext) and no suprise at all, when using transmitter/encoder 10/00 and EDID is not injected, i get this:

      I decided to go with Fanwort next but this time completly by accident/mistake i somehow used SenseID 0x5 instead of 0x3 (as you can see in the decoded VBIOS, LVDS uses SenseID 0x3), and guess what, finally the custom EDID was injected by Clover and everything was perfect. I opened the config.plist and i saw that i used wrong SenseID for LVDS but it was working perfect. To keep it short, out of curiousity i tried every framebuffer from the AMD6000Controller.kext with default values, and guess what,
      Cattail (4) @ 0x167920 LVDS, DP, DP, DP 02000000400000002905000000000005 00040000040300000001000011020101 00040000000100000009100021030202 00040000000100000009100012040303 and
      Fanwort (4) @ 0x1679f0 LVDS, DP, DP, DP 02000000400000002905000000000004 00040000040300000001000011020101 00040000000100000009100021030202 00040000000100000009100012040303 both work with wrong LVDS SenseID and custom  EDID is injected.
       
      The next thing i tried, it was using "wrong" SenseID in Ipomoea (i tried with 0x2, 0x4, 0x6, 0x7 and 0x8 - EDID is injected with all off these, except of course with 0x3, which is in the VBIOS. Why? I have no idea.
      Today i tried to inject the EDID with DSTD and it also works with this framebuffer: (SenseID 0x4 and probably others, 0x2, 0x5, 0x6, 0x7, 0x8)
      02000000400000000901000010000004 00080000000200000001000011020101 10000000100000000001000000000205 and this in your DSDT in Device (PEGP). This is my custom EDID, i have the 17" Display, DisplayProductID 0x289 and DisplayVendorID 0x30e4
      "AAPL00,override-no-connect", Buffer (0x80) { /* 0000 */ 0x00, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0x00, /* 0008 */ 0x06, 0x10, 0x14, 0xA0, 0x00, 0x00, 0x00, 0x00, /* 0010 */ 0x0A, 0x16, 0x01, 0x04, 0x90, 0x26, 0x15, 0x78, /* 0018 */ 0x0A, 0x6F, 0xB1, 0xA7, 0x55, 0x4C, 0x9E, 0x25, /* 0020 */ 0x0C, 0x50, 0x54, 0x00, 0x00, 0x00, 0x01, 0x01, /* 0028 */ 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, /* 0030 */ 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x2F, 0x26, /* 0038 */ 0x40, 0xB8, 0x60, 0x84, 0x0C, 0x30, 0x30, 0x30, /* 0040 */ 0x23, 0x00, 0x7E, 0xD7, 0x10, 0x00, 0x00, 0x19, /* 0048 */ 0x00, 0x00, 0x00, 0xFC, 0x00, 0x43, 0x6F, 0x6C, /* 0050 */ 0x6F, 0x72, 0x20, 0x4C, 0x43, 0x44, 0x0A, 0x20, /* 0058 */ 0x20, 0x20, 0x00, 0x00, 0x00, 0xFE, 0x00, 0x00, /* 0060 */ 0x00, 0x00, 0x4C, 0x47, 0x44, 0x69, 0x73, 0x70, /* 0068 */ 0x6C, 0x61, 0x79, 0x0A, 0x00, 0x00, 0x00, 0xFE, /* 0070 */ 0x00, 0x4C, 0x50, 0x31, 0x37, 0x33, 0x57, 0x44, /* 0078 */ 0x31, 0x2D, 0x54, 0x4C, 0x41, 0x33, 0x00, 0x66 }, custom EDID for Clover
      00FFFFFFFFFFFF00061014A0000000000A160104902615780A6FB1A7554C9E250C5054000000010101010101010101010101010101012F2640B860840C30303023007ED710000019000000FC00436F6C6F72204C43440A202020000000FE000000004C47446973706C61790A000000FE004C503137335744312D544C41330066 This could also work for others who have the gradients issue.
      I need someone (maybe you Basss) who uses Clover to test this with VGA, Plug in - Plug Out was not detected properly until now, but maybe with this SenseID we will have some changes.
×