Jump to content
InsanelyMac Forum
DragoonWraith

Enabling Intel HD 3000 in Lion — Gateway ID47H06u

Recommended Posts

OK, so I installed Lion with iATKOS L1, following the instructions here.

 

With AppleIntelHDGraphics.kext (and related files, see below*) installed, which I believe iATKOS did at my request, the computer could only boot in Safe Mode (and then, obviously, it was not getting graphics support).

 

If I remove these kext files and use the repair utility in Kext Wizard, the computer boots up fine, except again there is no graphics support. So now I want to fix this issue, and get these kexts working correctly.

 

Is it worthwhile to download AppleIntelHDGraphics.kext from the Internet and try to install that copy? I tend to assume that all copies of it are going to be the same thing, but I could be wrong. Or does something more involved have to be done?

 

 

For reference, the last few lines I get from the verbose printout when AppleIntelHDGraphics.kext is installed are as follows.

BSD root: disk0s2, major 14, minor 1
Kernel is LP64
com.apple.launchd 1	 com.apple.launchd 1	 *** launchd[1] has started up. ***
com.apple.launchd 1	 com.apple.launchd 1	 *** Verbose boot, will log to /dev/console. ***
Running fsck on the boot volume...
** /dev/rdisk0s2 (NO WRITE)
** Root file system
  Executing fsck_hfs (version diskdev_cmds-540.1~34)
BootCacheControl: Unable to open /var/db/BootCaches/PreheatedUser/Merged.playlist: 2 No such file or directory
BootCacheControl: Unable to open /var/db/BootCaches/PreheatedUser/Login.playlist: 2 No such file or directory
macx_swapon SUCCESS
Waiting for DSMOS...
nstat_lookup_entry failed: 2
nstat_lookup_entry failed: 2
Previous Shutdown Cause: 3
DSMOS has arrived
ACPI_SMC_PlatformPlugin::startForReal - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
Transcript Offline - Buffer Pool Allocate [181000] failed
█

At which point it hangs

 

 

Computer details:

  • Intel Core i3-2330M
  • Intel HD 3000 integrated graphics

(these are the things I know are useful information; if more is necessary I can provide, just let me know what's actually relevant)

 

 

* I also removed files from S/L/E that seemed related to the HD Graphics. A full list:

  • AppleIntelHDGraphicsGLDriver.bundle
  • AppleIntelHDGraphicsVADriver.bundle
  • AppleIntelHDGraphics.kext
  • AppleIntelHDGraphicsFB.kext
  • AppleIntelIntegratedFrameBuffer.kext
  • AppleIntelSNBGraphicsFB.kext
  • AppleIntelHDGraphicsGA.plugin

Also, I removed AppleIntelCPUPowerManagement.kext and AppleIntelCPUPowerManagementClient.kext, since those were giving that timed out message at the end of the verbose print-out. Fixing those would also be good, but that's another issue (and there are other similar things I want working, like the ethernet card. But first things first).

Share this post


Link to post
Share on other sites
Advertisement

i am not familiar with iATKOS but try this, edit your boot.apple.plist file (cant remember where it is maybe in library/... or system/...) and add something (off the top of my head) like

 

<key>GraphicsEnabler</key>

<string>Yes</string>

 

(if yours says 'yes' then try 'no')

Thats the main one,

 

or

 

<key>Graphics Mode</key>

<string>1280x1024x32 (your screen res here)</string>

 

If that dont work then im stumped!

Let me know if it works

Share this post


Link to post
Share on other sites

keep the files that was originally on the OS when u installed it. Intel's HD 3000 graphics is natively supported on Lion due to the Mac Minis using it. So if u deleted it then yes put it back on...

Share this post


Link to post
Share on other sites

OK, I tried using the GraphicsEnabler=Yes "Graphics Mode=1440x900x32" boot arguments (rather than modifying plist), and that didn't work.

 

I haven't tried modifying plist because there were some issues with the install, so I figured I'd start fresh and reinstall. Unfortunately, that failed for some reason and I don't have time to start from scratch right now (there was no boot loader on the USB stick because I'd had one on the HDD, but now I don't). Continuing this project will have to wait until the weekend.

Share this post


Link to post
Share on other sites

hello

 

intel hd 3000 only have full support in 10.7.2 or 10.7.3

 

see if the that 2, appleintelhd3000.kext and AppleIntelSNBGraphicsFB.kext have u device id

 

and should work

 

good hack

Share this post


Link to post
Share on other sites

Ah, that's very good to know; I'll double-check which version of Lion that iATKOS has. How do I determine the precise device ID for my computer? I've actually had a lot of trouble tracking down precisely which makes/models/versions of various components - I recently learned about lspci for the PCI components, which has helped, but the processor is not a PCI component...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×