Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Paul Gleeson

iPhone 4S Always Using WiFi

9 posts in this topic

Recommended Posts

I'm having a frustrating problem leading to battery life problems

 

My iPhone seems to remain permanently connected to my home Wifi and using data.

 

I have locations services off, push mail off, notifications off, no apps running, ask to join networks off, not sending diagnosis and usage info.

 

What can be causing this?

 

Regards, Paul

Share this post


Link to post
Share on other sites

How much data is it pushing through? You can check it from your routers homepage if it's specifc to showing data usage for every device on your network. Also if you aren't jailbroken then it is most likely some app that's eating away at your data.

Share this post


Link to post
Share on other sites

It seems to be connecting to push.apple.com almost continuously. Even though I have push off, and not photo stream / documents etc.

 

It does not use much data, but it is the continuous connection causing the issue.

 

What do I need to do to stop this behaviour?

Share this post


Link to post
Share on other sites

Siri has been off all the time. I have an iCloud account, but a while ago I deleted it, but had similar issues.

I use iCloud, so not having it would be an issue. Push is off, as are photo stream, documents, find my phone.

Share this post


Link to post
Share on other sites

What about the widgets that sit inside the notification bar? The weather and stocks to be exact because it has to be something apple based that's initiating the connection.

Share this post


Link to post
Share on other sites

After some digging around, this thread describes my problem exactly.

 

https://discussions.apple.com/thread/2785264?start=0&tstart=0

 

I have signed out of the store. Let's see if my WiFi connection is not being used continuously.

 

Since Apple have not yet merged Apple ID's I have some for my iCloud account and one for iTunes.

Maybe this is the problem. Or the order in which you enter them during setup?

 

Any thanks for taking an interest in this thread, and I will report my results

Share this post


Link to post
Share on other sites

Seems like the issue is beyond 4.3 if you're having it on iOS 5 or above. I'm assuming you tried monitoring the usage after downloading the net stat program correct? Did logging out from the store really solve the issue?

 

You're not the only one that the transition to iCloud is hurting its affecting me also because I'm yet to upgrade my ME account to iCloud because I actually do enjoy the features that iCloud will be missing out on. Sadly I don't think apple will be merging apple IDs although there has been talk about it I don't see I turning into an actual reality.

 

You're welcome with the help just glad to be of assistance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×