Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Snow Leopard 10.6.8 guest Ubuntu 11.10 host VMware 8 no sound

7 posts in this topic

Recommended Posts

I know that this topic has been addressed before, but I was not able to figure out how to comment on the existing posts. I am new to Mac and Ubuntu (Linux), so I apologize in advance for any newbie comments, questions, and mistakes.


I have Ubuntu 11.10 as the host OS and VMware 8 as the virtual software. My image is running Snow Leopard 10.6.8 everything seems to work fine except for the sound. The install was performed off a legal purchased copy of Snow Leopard from Apple. Original version was 10.6.3 and after install updated to 10.6.8.


I verified under VM settings that the sound card is connected. I've tried using auto detect and setting to ALSA: default sound card, but neither worked. I have installed all the drivers that I could find on the internet for this issue (AppleAC97Audio.kext with Kext Helper b7 and EsoniqAudioPCI_v1.0.2). Still no sound and "no output/input devices found" under system preferences.


I am not sure how to proceed from here. Any help would be greatly appreciated. If additional information is needed, I will try my best to provide.

Share this post

Link to post
Share on other sites



At first show your rig ,use (download)"system info" to see your devices ,and used kexts...


good lucky


Share this post

Link to post
Share on other sites

I'm assuming that u mean the system info from the Mac image. I tried to attach the .spx file, but I got a error message stating that I'm not permitted to upload this kind of file. Is there another way I can get you this information?

Share this post

Link to post
Share on other sites

Update: Althougth it seems as though no one has been able to help with this problem yet. I was able to get a list of devices in system preferences input/output. Now my problem is that whenever I tried to play anything with sound my sound card disconnects from vm settings with error: error in creating sound stream. sound is disconnecting. If I try to reconnect while the sound is still playing, i get the error: failed to connect virtual device. When I stop the playback, it will connect successfully and stayed connected until I try to play sound again.

Share this post

Link to post
Share on other sites

Has anyone been able to fix this problem? I'm getting exactly the same symptoms running Lion 10.7.3 in vmware ws 8 on a Ubuntu 11.10; I can see a list of devices in System Perferences -> Sound but the first time I try to play a sound the VM sound card disconnects with the vm message "Error in creating sound stream". I turned on "Gather debugging info" in the advanced options on VM Workstation. When the sound disconnects the following is logged:


2012-05-05T09:00:12.188+10:00| vcpu-0| I120: SoundAlsaSetHardwareParams: Failed to set Alsa hardware parameter (snd_pcm_hw_params): Invalid argument

2012-05-05T09:00:12.188+10:00| vcpu-0| I120: Msg_Post: Warning

2012-05-05T09:00:12.188+10:00| vcpu-0| I120: [msg.sound.ErrorCreateStream] Error in creating sound stream. Sound is disconnected.

2012-05-05T09:00:12.188+10:00| vcpu-0| I120: ----------------------------------------

Share this post

Link to post
Share on other sites

I got sound working by commenting out the line sound.virtualDev = "hdaudio" from my .vmx file. It's pretty choppy at the moment, but there are several posts about tuning parameters pciSound.DAC2InterruptsPerSec and pciSound.playBuffer. Will try tweaking these now.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sect0r5
      Hello guys I need help for tuning my system for better working possibilities.
      What works:
      Sleep/Wake Audio Ethernet App Store  
      CS:GO not working (other Steam games are OK) Bad GPU performance 40 fps on OSX Cinebench vs 85 fps on Windows Cinebench Big audio latency when using line input      //edit : problem is gone  Slow start of Viber Desktop, OBS and some web pages  //edit : OBS is slow on native MacBook too Sometime random mouse freezings            Huge lags on latest NVidiaWeb drivers(158, 159) Sometimes can't awake and stuck on black screen after restart   //edit : now is alright. magic! Sometimes sound start crackling when watching online video     //edit  : magically gone edit : she come again  
      It's happens on a both Kernel's :
      Shanee 13.3.3
      Clover 4392
      What info i can provide for better results?
      With best regards, Stan.
      Send me stanMacs-Pro.zip
    • By Antonio95
      Buonasera a tutti, ho installato con successo macOS High Sierra 10.13 su un notebook Toshiba C660 con le seguenti caratteristiche:
      Intel Core i5 2410M Ram 4 GB Chipset Intel HM65 Wi-Fi + BT Atheros AR5B195 (AR9285+ AR3011 Combo) Geforce NVIDIA 315M 1024MB Audio Realtek ALC269 Funziona più o meno tutto, o meglio funzionava poiché ho effettuato l'aggiornamento da macOS 10.3 a macOS 10.3.3 e non ha più funzionato l'audio. Fino alla versione 10.3 ero riuscito a farlo funzionare grazie ad AppleALC.kext cui dipende da Lilu.kext. Ovviamente entrambi i Kext sono aggiornati alle ultime versioni disponibili, ed inutile dire che ho provato più volte a reinstallarli. Si trovano sia in S/L/E che nella partizione EFI dedicata di Clover. Prima durante il boot in verbose vedevo qualcosa come "Sound assertion in AppleHDAController at line 451", cosa che non vedo più dopo l'aggiornamento. Una volta avviato, l'icona dell'audio è praticamente grigia, mentre dalle impostazioni dice "Non è stato trovato nessun dispositivo di uscita".
      Ringrazio chiunque voglia aiutarmi.
    • By giacomo.furlani
      Salve, il mio portatile ha la scheda audio  Realtek ALC3234, uso voodoo hda ma con questo Kext l'audio è più basso del normale.. cosa posso fare? Si sente più basso anche il microfono, infatti spesso siri non capisce cosa dico
    • By JoshuaBedford
      My name is Joshua Bedford, and I'm brand new to this community. It appears as though I have been missing out! I started over at hewhoshallnotbenamed's (from what I understand) website. I need some help!

      I built my first (and only so far) hackintosh a little over 2 years ago (I think. haven't looked at exact dates). It has worked phenomenally, and was running my dual 27" displays perfectly for web development and video editing. The problem now is USB3.0, audio, and iMessage no longer work. iMessage was always spotty, but I need audio and USB3.0! It recognizes USB2.0 devices plugged into 3.0 ports, but not 3.0 devices (such as my 3TB external drive and usb hub).

      My question is this: Based on the hardware below, would it be a good idea / compatible to wipe it and start over with high sierra and the newest bootloader powering it? The only data on the drive is the OS and a few programs. Nothing irreplaceable or difficult to replace. My main question is one of compatibility (I'm not very knowledgeable about this process).


      GPU: GTX960
      CPU: i7-4790k
      MB: UD5H-Bk
      RAM: Gigabyte 16GB
      WNA: TP-Link WDN4800

      PCPARTPICKER link: https://pcpartpicker.com/user/JrBedford/saved/#view=vpMLrH

      Everything except the monitor (I moved to 2 curved 27") is still true. Please view that for any specific part numbers!

      Let me know if more information is needed. I am willing to be helped in debugging the current system, but i wonder if installing high sierra would be easier.

      P.S. I bent a few of the pins in the USB3.0 header that connects the front panel of my case. That wouldn't cause the entire system to reject USB3.0 right? I'm plugging directly into the motherboard not through that plug.
    • By spectra
      Hi people, can someone help to put my HDMI sound working? I already tried different methods and I can't figure a way to fix this problem.   And another question, someone knows why the HDMI port just work if i use macbook pro 14,2 on smbios? Because my hardware is much more similar to 14,3.    
      thanks guys
      My system dump
      DarwinDumper_3.0.4_01.02_12.24.51_MacBookPro14,2_AMI_X64_4392_High Sierra_17D47.zip