Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Lion on Alienware M17X R2, how to make backlight and stop work?

1 post in this topic

Recommended Posts

Hello, i'm trying to set up Lion with iAtkos L2 on my Alienware M17X R2. Things seems to work quite well, my main problems are:

- backlight can't be changed, seems that the system don't even now it can be done (i don't see the slider). If i change it on Windows, it keeps the same level on Lion.

- Stop doesn't work at all, the screen goes black then i have to reboot the computer


Plus, the battery meter is wrong: it detects when the battery is charging, but when i disconnect it, it still show it as charging. If i boot the system without the charger, the % is wrong (but when i connect it, it detects the charger).



Last thing, this is a minor problem: the touchpad is "strange", does not work very well, i don't know how to explain it... It seems that it's too sensitive, or too less, i can't understand what's wrong (but that's not the main problem).


Any idea?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      Hi guys, I am creating this topic to discuss an idea I had about a way to force the Mac OS installer to not install using apfs.
      So we know that apfs does not runs well on drives not made by apple because it's designed to run on apple firmware, so error correcting features will not work and this will cause data corruption and data lose over the long period of time, so some people will like more to not use apfs and avoid all that problems, but apple has integrated an ssd detection mechanism that will force to upgrade to apfs if an ssd is detected, so my idea is to create a kext that is loaded before the system initializes sata devices and then forces the system to detect all sata and nvme devices as hard drives, I think that is possible, but I do not know iokit so much well to do it, so I am creating this thread, to ask if it's possible to create something like that using io kit and other system libraries to create a kext the could work with clover kext injection and force the system to see all the ssd as hard drives, and also other idea for the kext is that it will enable itself to run only when you are booting into a Mac OS installer, maybe that could be also done using a clover kext to patch string directly on the sata family kext, so what do you think about my idea? is there someone that could help me to create the kext or a clover patch?
      Thank you for checking out my thread, I hope that we will find a solution soon
      PS: I know that there re things like scripts and commands to install without apfs, but my aim is to create a method that lets the users to tone perform any special task inside the Mac OS installer
    • By fischietto
      Dopo che ho aggiornato Clover all'ultima versione,
      MacOs a 10.12.6 e i driver nvidia a WebDriver-378.05.05.25f01,
      ho fatto dei test per vedere se tutto funziona come prima e ho riscontrato i seguenti problemi:
      1. il pc si riavvia dopo che lo risveglio dallo stop, e talvolta mi corrompe il bios
      2. in un'occasione si è riavviato da solo e non mi è sembrato che mancasse la corrente
      Ho provato con definizione da 11.2 a 14.2 e non cambia nulla, anzi con 14.2 i moltiplicatore resta fisso a x9.
      Ho messo NullCPUPowerManagement e non cambia nulla.
      Cosa posso controllare?
      Grazie per l'aiuto
      Allego config.plist e kext in uso su clover

    • By malkabani
      I have my laptop, which it is dell Inspiron 3521. So is there any guide on how to install mac os 10.12 on my laptop dell 3521, because I try to install by making standard USB installation but not work.
      Can anyone help me, please? Thanks
    • By carbo178
      Salve a tutti,
      ho installato recentemente Mountain Lion aggiornato a 10.8.2 sul sistema in firma, con bios moddato per abilitare lo speedstep e fare a meno di NullCPUPM o AICPUPM patchato; il bios è impostato di default (ho provato diverse combinazioni di gestione energia ma non cambia nulla).
      Rimangono da risolvere alcuni problemi:
      Le USB3 sotto chip Z77 non supportano le periferiche USB2
      Le USB3 sotto chip ASmedia non funzionano (un grazie a Ermac per l’impegno sul DSDT)
      Lo stop non va, o meglio, il PC va in stop ma si risveglia immediatamente e con lo schermo nero (devo forzare lo spegnimento)
      Lo spegnimento e il riavvio sono alquanto lenti, quasi 1 minuto

      Per i primi 2 punti ho provvisoriamente risolto con USB2 in scheda PCI, sperando in un miglior supporto futuro per queste periferiche.
      Quello che più mi preme è ottimizzare i punti 3 e 4.
      Premetto di usare un DSDT estratto dal sistema al quale ho applicato le patch per il DTGP e l’ HDEF, avevo provato anche 2 tipi di Shutdown ma non cambiava nulla sullo spegnimento.
      Ora, se fosse possibile assegnare un livello al grado di conoscenza del DSDT e delle tabelle/codici da inserire, dove inserirli e perché, potrei considerarmi al livello scimpanzè, pertanto non so fare di più di quello che ho fatto finora.
      Allego il DSDT che uso in questo momento e IOreg del sistema, con la speranza che qualche Anima Pia possa aiutarmi ad ottimizzare il sistema.
      Grazie a tutti anticipatamente
    • By motionworks
      Hello All,
      I have been using my computer for a long time as an hackintosh. Yesterday i made a clean 10.8 install with my hack. It was the smoothest update i have ever seen before. Everything works great even without DSDT or usb fixes in com.apple...
      But i have a small problem. Everytime i starts my computer after apple logo it takes more time than usual and just before login screen and i hear my disks shutting sound. After password they starts again.
      Is it normal?
      Thanks in advance for help.
  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies