Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
berny_

[Risolto] Problemi audio ALC888

30 posts in this topic

Recommended Posts

Ciao a tutti,

ho appena installato un monitori/tv Samsung T27A550 al mio hackintosh che vedete in firma collegandolo tramite l'assposita uscita HDMI presente sulla mia scheda video.

Ora il problème è che il video funziona ma il segnale audio non viene trasmesso, ho provato tutti i vari collegamenti: con line out (un jack ad ambe due i lati del cavo, quello della televisione nell'uscita "Audio in" e l'altra estremità all'uscita delle cuffie del pc) - ho provato con l'aux jack ad ambe due le parti del cavo un estremità collegata all'uscita cuffie della televisione e l'altra estremità all'uscita cuffie del pc - per concludere ho provato con il cavo ottico (Digital Out) senza nessun risultato.

 

Come kext uso voodooHDA.kext ho provato anche con AppleHDA.kext ma niente, non ho un DSDT patchato, come posso far funzionare gli altoparlanti della mio monitor? Se collego all'uscita cuffie presente sui pc delle casse esterne (quelle classiche da pc) funzionano senza problemi.

 

Grazie a tutti per l'aiuto.

Share this post


Link to post
Share on other sites

Beh tecnicamente non hai bisogno di ulteriori cavi, poiché il cavo HDMI trasporta con sé sia i dati video che audio, un po' come accade con il predecessore "RGB o Scart". Quindi in linea teorica basta semplicemente attaccare l'HDMI senza ulteriori jack audio.

Share this post


Link to post
Share on other sites

Beh tecnicamente non hai bisogno di ulteriori cavi, poiché il cavo HDMI trasporta con sé sia i dati video che audio, un po' come accade con il predecessore "RGB o Scart". Quindi in linea teorica basta semplicemente attaccare l'HDMI senza ulteriori jack audio.

 

Ciao e grazie per l'aiuto, ho provato a collegare solo tramite il cavo HDMI sia nell'uscita HDMII/DVI che HDMI ma senza nessun risultato, l'audio non si sente.

Share this post


Link to post
Share on other sites

No beh, aspetta un momento. Se attacchi a questa uscita "HDMI/DVI" (per il quale accetterei dettagli) sicuramente il segnale audio non passa, perché non previsto per le connessione DVI e VGA, quindi devi semplicemente collegare il cavo HDMI sul monitor/tv, l'altro chiaramente all'uscita HDMI della tua scheda video. Dopo aver fatto questo controlla dalle impostazioni audio, e vedi dalle impostazione di out e in le varie scelte, magari postale qui con una foto dei menù a tendina, così da poter avere la situazione più chiara.

Share this post


Link to post
Share on other sites

No beh, aspetta un momento. Se attacchi a questa uscita "HDMI/DVI" (per il quale accetterei dettagli) sicuramente il segnale audio non passa, perché non previsto per le connessione DVI e VGA, quindi devi semplicemente collegare il cavo HDMI sul monitor/tv, l'altro chiaramente all'uscita HDMI della tua scheda video. Dopo aver fatto questo controlla dalle impostazioni audio, e vedi dalle impostazione di out e in le varie scelte, magari postale qui con una foto dei menù a tendina, così da poter avere la situazione più chiara.

 

Ho collegato tramite l'uscita HDMI non DVI e le impostazioni su preferenze di sistema sono le seguenti:

Share this post


Link to post
Share on other sites

Devi eliminare tutti i kext audio che hai in questo momento, e poi installare secondo i soliti metodi questo nuovo kext. Nel sito, in basso sotto ai dettagli, in ogni caso trovi le istruzioni.

Share this post


Link to post
Share on other sites

Devi eliminare tutti i kext audio che hai in questo momento, e poi installare secondo i soliti metodi questo nuovo kext. Nel sito, in basso sotto ai dettagli, in ogni caso trovi le istruzioni.

 

Questa è la situazione dopo aver aggiunto AplleHDA.kext. Grazie

Share this post


Link to post
Share on other sites

Hai controllato e verificato di avere fatto tutti i passaggi correttamente, e dato i permessi al kext?

 

Si i kext li installo con champ list e poi riparo con kext utility.

Ora ho provato una versione più recente di voodooHDA l'audio non si sente ma la situazione è la seguente.

 

Comunque se collego all'uscita cuffia presente sul pc delle casse esterne (quelle classiche) funzionano senza problemi.

Perché collegando dall'uscita cuffia del pc all'uscita "audio in" della tv non funziona? non è come se stessi collegando delle normali casse? Neanche con l'uscita ottica funziona. mha...

Share this post


Link to post
Share on other sites

Non funziona perché probabilmente la tv quando inserisci l'HDMI, di default stacca le altre connessioni audio, e quindi il jack cuffie è come se non ci fosse. Il punto è che comunque adesso l'impostazione audio è settata in modo corretto... Domanda banale, hai provato ad aumentare il volume della tv, e vedere se magari anche messo al massimo senti qualche suono?

 

E puoi fare lo screen anche della scheda delle connessioni audio in ingresso?

Share this post


Link to post
Share on other sites

Non funziona perché probabilmente la tv quando inserisci l'HDMI, di default stacca le altre connessioni audio, e quindi il jack cuffie è come se non ci fosse. Il punto è che comunque adesso l'impostazione audio è settata in modo corretto... Domanda banale, hai provato ad aumentare il volume della tv, e vedere se magari anche messo al massimo senti qualche suono?

 

E puoi fare lo screen anche della scheda delle connessioni audio in ingresso?

 

SI ho provato ma nessun suono si sente.

Hai fatto caso che se seleziono l'uscita Digital Out nelle impostazioni dice: "il dispositivo selezionato non dispone di controlli di uscita" si vede nell'ultima immagine.

 

E' normale?

 

Grazie ancora per l'aiuto

Share this post


Link to post
Share on other sites

Il problema sta chiaramente nei kext, dovresti fare qualche ricerca su google, o aspettare qualcuno che conosce già la soluzione, io credo che potresti provare anche qualche kext della scheda audio ALC889, insomma, tentare non nuoce, e almeno ti levi qualche dubbio.

Share this post


Link to post
Share on other sites

Prova a patchare il dsdt inserendo la parte di codice video hdmi

 

Ciao e grazie a tutti dell'aiuto.

 

potresti segnalarmi una guida, possibilmente in italiano, su come patchare il dsdt?

 

Il kext che sto usando (VodooHDA) va bene?

 

Se c'è un modo più semplice per far funzionare l'uscita ottica (Digital out) o il jack delle cuffie anziché la HDMI segnalatemelo.

 

Grazie ancora!

Share this post


Link to post
Share on other sites

Ma se l'uscita HDMI trasporta sia il segnale video che audio non è più compito del Codec ALC888 ma della scheda video dove c'è l'uscita HDMI? Corregetemi se sbaglio.

 

Non c'è un modo per far trasportate solo il video con l'HDMI e l'audio tramite jack (cuffie) o Digital out?

 

Grazie

Share this post


Link to post
Share on other sites

Effettivamente hai ragione, diventa a tutti gli effetti compito della scheda video. In ogni caso, sì puoi usare un jack audio, ma devi attaccare o le cuffie, o delle casse, senza utilizzare le casse del tv. Il problema fondamentalmente è che ci sono alcuni tv che permetto anche in HDMI di utilizzare il jack delle cuffie, mentre altri invece no. Ad esempio io a casa ho un esempio di questo fatto, dove un pannello mantiene il jack cuffie anche in HDMI, mentre l'altro lo disabilita.

Share this post


Link to post
Share on other sites

Effettivamente hai ragione, diventa a tutti gli effetti compito della scheda video. In ogni caso, sì puoi usare un jack audio, ma devi attaccare o le cuffie, o delle casse, senza utilizzare le casse del tv. Il problema fondamentalmente è che ci sono alcuni tv che permetto anche in HDMI di utilizzare il jack delle cuffie, mentre altri invece no. Ad esempio io a casa ho un esempio di questo fatto, dove un pannello mantiene il jack cuffie anche in HDMI, mentre l'altro lo disabilita.

 

Quindi devo controllare solo il kext per la scheda video o entrambi?

 

Non c'è un modo per disabilitare questa funzione nel Monitor?

 

Cosa mi dici invece per il collegamento tramite digital out?

 

Grazie mille!

 

Ciao e grazie a tutti dell'aiuto.

 

potresti segnalarmi una guida, possibilmente in italiano, su come patchare il dsdt?

 

Il kext che sto usando (VodooHDA) va bene?

 

Se c'è un modo più semplice per far funzionare l'uscita ottica (Digital out) o il jack delle cuffie anziché la HDMI segnalatemelo.

 

Grazie ancora!

 

up

Share this post


Link to post
Share on other sites

Ciao a tutti, ho appena installato un Monitor/Tv Samsung SM T27A550, se lo collego tramite VGA per il video e il jack delle cuffie per l'audio non ci sono problemi.

 

Ma collegandolo tramite HDMI, il segnale video viene trasmesso mentre quello audio no.

 

Ho provato anche tutti i vari collegamenti (juck, aux, Digital out) ma da quanto ho capito il monitor disattiva di default tutte le uscite audio dando per scontato che il segnale audio passa tramite HDMI. (correggetemi se sbaglio)

 

Il problema, dal momento che l'uscita HDMI si trova sulla scheda video del Pc, è della scheda video, della scheda audio, o di entrambe?

 

Come Kext per la scheda video uso: ATY_Init e ATI4600Controller (aggiungendo l'id del dispositivo)

Come Kext per la scheda audio uso: AppleHDA e ALC8xxHDA (situato in E/E)

(Per installare i kext uso champlist e riparo con kext utiliy)

 

ho provato senza risultato anche i seguenti kexts

VoodooHDA (svariate versioni)

AppleHDA e HDAEnabler

 

Qualche consiglio su come far funzionare l'audio?

 

 

 

Grazie a tutti.

 

 

 

Allego lo screenshot di ogni prova, allego anche il mio IOREG (se può essere utile).

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×