Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Asrock x58 Etreme6 - iBoot / SnowLeo Retail

1 post in this topic

Recommended Posts

Hello, and thanks to everyone here on this forum. I am not able to boot retail vanilla kernel on my machine and I have done what i believe to be everything needed to get it to work.


My Build :

Asrock x58 Extreme6 mobo with i7 quad core at 3ghz

8gb ( 2 x 4gb ) Patriot Sector 5 ddr3 1600mhz 9-9-9-24 <-- one module removed until install compleate

Zotac gts450 amp!edition 1gb 128bit ddr5

64gb patriot SSD

2tb WD caviar black

corsair tx950w power supply

Thermaltake DH 102 Home Theather Enclosure with 7.1 inch touch screen

M-Audio Delta 1010-lt Audio interface PCI




I am having some problems getting [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to load the retail dvd with mach_kernel. I can install with the nawcom cd and use the legacy_kernel to boot but it wont do the combo update. I can not ever get the mach_kernel to boot.


Does anyone out there have similar hardware or the ability to point me in the right direction. I am relatively new to osx86 projects but not to computers. I am trying again to get this to work this time I am installing two partitions one with the working legacy_kernel install that nawcom cd creates then I will try to tinker with a vanilla build with mach_kernel on second partition and be able to still boot. Does this seem right?


I got $20 paypal to anyone who will email me a dmg that i can restore to a drive and will patch over a legacy_kernel install to get mach_kernel working with all my hardware functional.

Any takers?

I can be reached at Humboldt421(at)gmail(.)com



Thanks again, I am excited to get any kernel working i guess but want vanilla retail with bios patched dsdt tables. I want to run protools on this machine. So i need all the hardware to work i guess. stability is a must.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jnthnleonardo
      Hi! Yesterday I downloaded Sierra and El Capitan retail and put it to my usb using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. (I have tried transmac also, same result). I booted to my clover but unable to reach the installer. But when I use distro (niresh yosemite) I can install it. But yosemite was laggy so I want to try another.
      Boot flags I have tried:
      npci=0x2000 and 0x3000
      My specs
      AMD Radeon 8180 HD Graphics @1GHz, 2GB RAM.
      The usb i used partitioned with GUID partition table. I tried on another laptop (amd and intel) and had the same result
      My verbose mode said in picture attached. After showing that it just shut down and booted again into clover.
      Sorry I haven't attached the photo

    • By skunks
      Hello community!
      I rarely use my old retail Leopard system installed on separate HD and removed all backups from Time Machine.
      But recently it stopped booting. When I'm trying to boot from that HD I get the following messages:
      boot0: GPT
      boot0: HFS+
      boot0: booting
      boot0: done
      boot1: startupfile
      I can still load the system the following way:
      boot from iDeneb DVD, press F8 and type rd=disk1s2.
      Then I tried to re-instal Chameleon (EFI v9 via UInstaller 1.2) as I always do when my system stops booting. But this time it didn't help, I still see the same message when trying to boot from my HD directly.
      I've repaired permissions and repaired disk with Disk Utility - it didn't help either.
      Please suggest. I would really miss my old system.
    • By WaldMeister
      - Where to start?:
      A nice guide on how to create your own USB installer is provided here: http://www.insanelym...-for-beginners/
      I do recommend using this method: http://www.insanelymac.com/forum/topic/302220-pandoras-box-20-candidate-3-roll-out/
      It's self-explanatory.

      If you only run Windows at the moment, install OS X into a virtual machine, and follow the guide from there.
      - What will not work?:
      - Wifi, you will have to replace the card, i switched mine with an Atheros 9285. Note: After replacing, your Bluetooth will not work anymore, so an USB Wifi device would be the better option perhaps.
      - Card reader, no solution for this at the moment.
      - Nvidia GT 650M, the card has been completely disabled in the DSDT. If this is not done it will make your system freeze on startup if the NVDA* and GeForce* kexts are not removed. Also, the system will overheat if it is not disabled. Since you can not use the card, it is best to disable it.
      - Wake from sleep, the display does not wake up. This has been fixed in the new DSDT attached to this post.
      - HDMI out. Requires patching of the AppleIntelFramebufferCapri to enable AAPL,ig-platform-id 0x03. On every update of OS X you will need to patch this file again before rebooting. Not patching or editing the DSDT before reboot will result in a black screen. ​New patch enables HDMI audio out and corrects the vram to 512mb.
      - What will partially work?:
      - Touchpad, recognized as trackpad, only basic input, no gestures like 2 finger scrolling.
      - Audio, LineIn and the subwoofer will not work.
      - FN keys, for Audio and Wifi  FN keys for brightness have been fixed.
      - USB 3.0, depends if you want compatibility with USB 2.0 flash drives. Both devices work. Booting with GenericUSBXHCI, have not tested without it.
      - Lan, only with specific settings. Official Realtek driver. Realtek Driver.
      - So...What does work?:
      - Speedstep
      - Sleep, patched IntelCPUPowerManagement or an unlocked bios.
      - Intel HD4000, DSDT injection, patched AGPM. (Need to explore)
      - Audio, line out, speakers, HDMI and internal mic, DSDT injection and a patched AppleHDA.
      - Battery status, ACPIBatteryManager and DSDT edit. Corrections have been made in the DSDT attached.
      - Webcam
      - Brightness control, in system preferences.
      - 1. Pre-Installation.
      - Download the EFI15022015.zip from this post and place it on your desktop. When you opened Pandora's Box, select bootloader > Clover UEFI, click start.
      I had some issues with Pandora installing the bootloader.
      - When Pandora is done download Clover configurator, select mount EFI, on the bottom right corner, Mount EFI partition, and select the USB s1 (disk2s1 in most cases).
      - Open folder, it will be empty, just copy the EFI folder to that partition.
      - 2. Installation.
      Boot from the USB installer, it will boot in verbose mode, if any error occurs, you can take a photo of it and attach it to a post here. 
      First you need to prepare the HDD to install Yosemite on. I recommend using and empty HDD, format it to GPT, with 1 partition formatted to Mac OS Extended (Journaled).
      Now go through the setup and select your newly created partition. Grab a cup of coffee or something.
      - 3. Installing a bootloader.
      After installation the system will reboot. Boot from the USB installer again. When you arrive at the Clover boot loader screen, select the partition you have just installed OS X to, and press enter. 
      OS X will load, go through the system setup.
      The first thing you want to do is install a bootloader to the HDD. I have attached the files needed for Clover. A guide on how to install Clover can be found at the bottom of this post, under the spoiler.
      You can also use Clover Configurator, makes things a lot easier. 
      - 4. Patching AppleHDA.kext
      A guide on how to do this can be found here: http://www.insanelymac.com/forum/topic/283754-patched-applehdakext-for-codecs-idt-92hd81b1x5-92hd91bxx-92hd87b13-92hd87b24-92hd87xx-etc/

      - 5. AppleIntelFramebufferCapri.kext
      It is no longer needed to change the device id in the DSDT. Former patch method can still be found in the old guide.
      I have included a file called: aifc09022015.sh, just drag and drop it in the Terminal window, type "y" to patch the kext.
      This patch will make the following changes in the AppleIntelFramebufferCapri:
      Original section:
      04 00 66 01 01 03 01 01 00 00 00 02 00 00 00 01 00 00 00 40 10 07 00 00 10 07 00 00 00 00 00 00 20 50 03 00 00 00 00 00 00 00 00 00 00 00 00 00 05 03 00 00 02 00 00 00 30 02 00 00 00 00 00 00 01 00 00 00 40 00 00 00 00 00 00 00 01 00 00 00 40 00 00 00 00 00 00 00 01 00 00 00 40 00 00 00 40 In the second line is the vram, 40 stands for 1024mb. We change this to 20 so that OS X will detect 512mb.
      05 03 00 etc is the display device, as you can see, only the internal LCD is defined, so we need to add the HDMI outputs. The default ones from device id 03006601 only detect the display output, no sound. I've taken the HDMI devices from device id 03006601 and added them corrected to 04006601. It looks like this: 
      04 00 66 01 01 02 04 02 00 00 00 04 00 00 00 01 00 00 00 20 10 07 00 00 10 07 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 05 03 00 00 02 00 00 00 30 02 00 00 02 05 00 00 00 08 00 00 07 04 00 00 03 04 00 00 00 08 00 00 81 00 00 00 04 06 00 00 00 08 00 00 81 00 00 00  More information about this subject can be found here: http://forum.osxlatitude.com/index.php?/topic/2945-guide-for-enabling-vga-and-hdmi-in-intel-hd4000-gpu/
      - 6. AppleGraphicsPowerManagement.
      Switched to a new model.
      To edit this kext, copy it from /System/Library/Extensions to ~/Desktop.
      Now right click on the kext, and show package contents. Open Contents and open the Info.plist with Plisteditor. Now search for the following: 
      Under this, you will find something like the following code (Select the whole IGPU section): 

      Replace it with the following:

      Save the file, and install the edited kext.
      - 6. AppleIntelCPUPowerManagement.kext.
      If you do not have an unlocked bios, or the patch option enabled in Clover, you need to patch this kext to prevent kernel panics. 
      To edit this kext, open Terminal and type the following:
      sudo -s *password* I have included a file called: aicpm.sh, just drag and drop it in the Terminal window, type "y" to patch the kext. You're done. 

      Old Guide:

      How to install Clover and add it to the UEFI Boot menu:
      - Be careful when replacing the current boot loader, your system may become unbootable if you skip a step, or do not pay attention! (Click show)

    • By faisalwin7
      So, i'm installing Yosemite via Clover bootloader, and after installing, i can into desktop after setup assistant, after reboot it, i got stuck on login after entering correct password. is there any step to resolve it? thanks
    • By LucasX64
      Hi people!
      Currently, i have:
      Desktop [AMD]
      - with Mountain Lion 10.8.3 (VMWare image by the SoulDevTeam)
      Notebook [intel]
      - with Mavericks 10.9.5 (VMWare Image by SoulDevTeam, updated from 10.9.1)
      Now the question is:
      since there are a few Mavericks kernel (like this or this ) that add support for AMD CPUs, it is possible to make a VMWare image of Mavericks retail that works on AMD system?
      Thank you for any reply
  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies