Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By vin047
      I have a Kingston HyperX Predator PCIE-SSD (model: SHPM2280P2H) matched with an X58 motherboard (legacy bios). The card has a Marvell 88SS9293 controller with an Option ROM which allows it to be detected on my motherboard as a bootable drive - listed as "IDE: Kingston SHPM". As my BIOS is non-UEFI, I assume the Option ROM presents it in IDE mode instead of AHCI.
       
      I use Clover legacy with BiosBlockIO to get around this, and it works well - Clover detects my drive and allows me to install macOS onto it and use it as a boot drive. macOS detects the drive correctly as a SATA AHCI drive. I guess Clover correctly detects (configures?) the Option ROM into AHCI mode and presents it as such to macOS - getting full speed read Read/Write performance. All is well.
       
      Except waking from sleep. When waking from sleep, depending on clover config options + dsdt, I either get an immediate reboot or hang on black screen that requires hard reset. I eventually realised that nothing after entering sleep mode is recorded in the logs, its completely empty until next boot up. This makes me think that on resume from sleep, macOS isn't seeing the drive anymore (hence can't even write to logs). My assumption here is that the Option ROM is presenting/configuring the card in IDE mode, which is not what macOS is expecting.
       
      This post describes the problem: 
       
      and also has a solution: in dsdt, simply write the correct values to 0x40, 0x41, 0x42 (which must be the BAR0 register?) to configure Option ROM to use AHCI mode. But I have no idea what address BAR0 is on the Marvell 88SS9293 - there appears to be no documentation whatsoever on this controller available online!
       
      I managed to dump the ROM using Linux sysfs, but don't have the skills to disassemble/decipher the binary to find the correct addresses. Anyone with such experience able to help?? I've attached the ROM dump and lspci output.
       
      Thanks in advance!
      rom.bin
      lspci_output.txt
    • By vin047
      Hi, have an old Asrock X58 Deluxe motherboard with an i7-920 Nehalem CPU (yes old board ) + AMD RX460 . As per the title, i've managed to get Mojave installed and running with Speed Step working too!
       
      Final issue i'm having is with sleep - it sleeps fine and even responds to keyboard/mouse event, but instead of waking up to the desktop it restarts and loads from BIOS boot screen. When finally booted into macos, it restores as if restored from unexpected shutdown (though no error is shown).
       
      I've tried for days to get it working, sometimes depending on clover config changes, I can get it to wake up without reboot, but it just remains at a black screen and is unresponsive. 
       
      I have no custom DSDT, i've tried writing one but don't know really know what i'm looking for? Currently relying on clover patches. I've uploaded my original DSDT (dumped from Clover, F4 option) + current config. Anyone have any ideas?
      dsdt original.zip
      config.plist.zip
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By manmo71
      I am a novice in the field of Hackintosh, and this is my first post here.
       
      I have managed to setup and install my hackintosh and it is perfectly working other than this one issue.
      I am unable to figure the exact cause of this issue. My Hackintosh is unable to go into sleep mode after the set time. This is what happens (see the attached video file).
       
       

      mojavesleep.mp4  
      You can see that the screen turns off, then I see the power on the graphics card and fans turn off.
      Immediately it comes back ON and the screen TURN's ON.
       
      I have followed various threads in several forums trying various options suggested for sleep related issue, but have been un-successful.
      If anyone is able to guide me through in resolving this issue, I would appreciate that.
       
      I am unsure what files need to be attached for you people to help me, feel free to ask and I shall upload the necessary files.
×