Jump to content

Poor graphics performance GTX580 3gb


4 posts in this topic

Recommended Posts



ive been trying to see if i can improve my graphics performance but i havent been lucky. I have tried the guide for applegraphicspowermanagement.kext with no luck. I have full resoultion and i think i have qe/ci enabled because i have the menu bar transparent. Here is what i have tried so far:


installed GTX 5XX ENABLER and CUDA pkg for 10.7.3

Switched my smbios.plist from macpro4,1 to Imac 12,2 with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

I made sure i had imac12,2 and device id 1080 with g state 1 in thresholds in applegraphicspowermanagement.kext


here is my org.chameleon.boot.plist info





<key>Kernel Flags</key>

<string>npci=0x2000 PCIRootUID=0 darkwake=0</string>





<key>Legacy Logo</key>









my smbios.plist














here are my specs


macosx 10.7.3

ASUS p8p67pro rev3

Evga GTX 580 3gb

corsair vengance at 1866

160gb HDD sata


Here are my NovaBench results



2012-02-22 22:57:25 +0000

Mac OS X 10.7.3

Intel Core i7 @ 3400 MHz

Graphics Card: GeForce GTX 580


8192 MB System RAM (Score: 181)

- RAM Speed: 9131 MB/s


CPU Tests (Score: 726)

- Floating Point Operations/Second: 274513632

- Integer Operations/Second: 588717184

- MD5 Hashes Calculated/Second: 1141672


Graphics Tests (Score: 102)

- 3D Frames Per Second: 268


Hardware Tests (Score: 23)

- Primary Partition Capacity: 120 GB

- Drive Write Speed: 76 MB/s


As you can see, the graphics test is nowhere near good. I should be getting around 1500 with 3d fps at around 2600


If anyone knows something else i am missing please let me know, i am a noob at this and i dont know if im screwing up. Also is there a way to see if applegraphicspowermanagement.kext is loaded? or if its loading at boot?


Thanks in advance.

Link to comment
Share on other sites

I get around 780 fps with 9600 GT in GPU Bench of Nova. So your score is indeed to low.

BUT: Nova GPU Bench computes very low GPU load , so it can be that your AGPM stays at lowest speed.

Try Cinebench - if also very low , you know that either gpu stays always at lowest Mhz OR some generell problem.

If Cinebench is OK then only the stepping (for low gpu loads) didnt work - perhaps change the .plist entries for the threshoud.

Check AGPM:

in terminal


....0 0xffffff7f81e95000 0xb000 0xb000 com.apple.driver.AGPM (100.12.42)

should be in the list kextstat displays.


EDIT: Youu can check AGPM really working (step up / down) iy sou enable the LogControl =

Its in the plist of the Mac....plist for the AGPM. Set that key from 0 to 1 and you can follow the stepping in the console.

Perhaps you must reboot to get the Logcontroll activated after editing.

Link to comment
Share on other sites



Thank you for replying,


I dont usually test with cinebench because the opencl test use processor and its not the best to test just graphics power. however i did run it and got a about 36fps.

I didnt find the kext loaded when i looked for it with the command kextstat which tells me its not being loaded at boot for some reason. i did more digging around on this and also tried adding string Graphics Mode and leaving it empty on my org.chameleon.boot.plist file but i am unable to boot. Either I get a "still waiting for root device" when i boot in verbose or i get some sort of white bar at the top left part of the screen and never goes forward.


I have no idea how i can get this thing to work properly. Any other ideas?.


Thanks in advance.

Link to comment
Share on other sites

I would take a look at this thread - ist the AGPM thread and that will be the problem for you.

1. Get AGPM loaded = smbios.plist settings for Mac Modell ID must maybe changed

2. together with 1. you may need to edit the AGPM (some .plist) to get the GTX 5xx working better

So it will be not only one step for you but it will be not so difficult if you look and ask at the AGPM thread:



Link to comment
Share on other sites


  • Create New...