Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Stormbringer

ALC888 + ICH 7

3 posts in this topic

Recommended Posts

Hi everyone!

I'v read a lot of topics, HCLs, guides, etc. on ALC888 + ICH7, tried dozens of kexts, DSDT patches, but... I haven't found any solution for ALC888 + ICH 7 except VoodooHDA. Then, I decided to find a more logical and clear way to solve this problem, that's why I'm starting this topic.

 

What do I have:

1. I've got MSI 945 Neo5-F mobo (i945GC) http://www.msi.com/p...ml#/?div=Detail.

2. All drivers are up-to-date (intel chipset inf, nvidia, realtek hda, realtek GBE). Windows 7 x32 fully functional, all items in Device Manager recognized and set up correctly.

3. Mac OS X 10.7.3 Lion fully functional almost "out-of-the-box" ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + Chameleon, no user DSDT), except sound (

 

What I've made:

1. I've extracted dsdt.dsl via AIDA64 under Windows 7 32-bit, files are attached (acpi_dsdt.zip).

2. There's no AZAL or HDEF section in my decompiled dsdt.dsl at all! But in windows my HDA codec works 100% fine with latest proprietary Realtek drivers (32bit_Vista_Win7_R267).

3. I checked AIDA64 and found that my HDA codec is placed on PCI-E bus (attanched AIDA64 Screen.png). But all other devices (except 8800GT, certainly) are using PCI bus.

 

So, right now I need some technical help to dig in into this. First of all, I'd like to find answers for these two questions:

1. Is there really any info about my HDA codec in dsdt.dsl file?

2. If not, why it isn't extracted by AIDA64?

3. What to do next?

 

I'm ready for any level of technical difficulties ) Advices are welcome )

acpi_dsdt.zip

post-970077-0-95108800-1329947532_thumb.png

Share this post


Link to post
Share on other sites

Solved, finally ) I got my ALC888 working on ICH7 (MSI-7236 aka MSI 945 Neo5-F based on i945GC + ICH7) using modified AppleAzaliaAudio.kext :weight_lift:

Pros:

+ Native Apple kext without any injectors or enablers.

+ Nice, stable and clear sound without any cracks or noise (especially comparing to VodooHDA)

+ Easy configuration and installaion (comparing to AppleHDA modding).

Cons:

- AppleAzaliaAudio.kext is an obsolete 32-bit driver, so you'll have to enable 32-bit (i386) kernel mode in Chameleon bootloader (actually, i haven't noticed any difference between LP86_64 (64-bit) and i386(32-bit) kernel modes - both work fine on my PC without any impact on RAM amount available or application performace).

- AppleAzaliaAudio.kext supports stereo output only, inputs not working at all (this is not a problem for me, because I've got a high-quality mic integrated in my USB-webcam, and it works fine).

- You'll need Windows + Realtek drivers installed for initial config (to get your audio device hardware IDs).

 

So, I suppose you've got Windows (XP, Vista, 7) installed with HDA audio drivers properly configured (sound working).

 

1. Login to Windows, right-click Computer (My Computer) and click "Manage".

2. On the left side, find Device Manager and click it.

3. On the right side, you'll see a list of your devices. We need two main audio devices - Realtek High Definition Auio (under Sound group) and Microsoft UAA Bus Driver for HDA (under System Devices group).

4. Double-click each of this devices, open Details tab and choose Hardware IDs in the drop-down list. Save to text file or write down these IDs. You'll get something like this:

 

Realtek High Definition Auio

------------------------------------------

HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A8C&REV_1001

HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A8C

 

Microsoft UAA Bus Driver for HDA

------------------------------------------

PCI\VEN_8086&DEV_27D8&SUBSYS_2A8C103C&REV_01

PCI\VEN_8086&DEV_27D8&SUBSYS_2A8C103C

PCI\VEN_8086&DEV_27D8&CC_040300

PCI\VEN_8086&DEV_27D8&CC_0403

 

5. Now we combine the bold figures above and get the following strings for each device:

 

Realtek High Definition Auio 0x10EC0888

Microsoft UAA Bus Driver for HDA 0x27D88086

 

6. Login to Mac OS X and download any AppleAzaliaAudio.kext you like from the internet - I just downloaded the original Apple kext version 1.0.0.0.

 

7. Right-click your downloaded AppleAzaliaAudio.kext and choose Show Contents. Open AppleAzaliaAudio.kext/Contents/Info.plist and find &--#60;key&--#62;IOHDAudioCodecVendorID&--#60;/key&--#62;. Add your codec string 0x10ec0888, then Save and Close the file.

 

8. Open AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist and find &--#60;key&--#62;IOPCIPrimaryMatch&--#60;/key&--#62;. Add your HDA bus string 0x27D88086, then Save and Close the file.

 

9. Remove all kexts with *HDA* in filename from Extra/Extensions and System/Library/Extensions (i suggest moving rather than deleting files).

10. Copy your modified AppleAzaliaAudio.kext to System/Library/Extensions.

11. Run Kext Utility to rebuild cache and repair permissions.

12. Launch Chameleon Wizard and tick "32-bit mode" for kernel (arch = i386).

13. Reboot

 

Sound working now!!!

 

Update: Now, when I've gained some Mac OS X configuration experience, I'm looking forward to making a more complicated solution using AppleHDA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×