Jump to content
InsanelyMac Forum
sselshamy

Still Waiting for root device

Recommended Posts

Anyone got a solution for this error please share with us, I see many of us facing this error.

 

Installation succeeded but error appeared when trying to boot from ML fresh installed partition.

 

I tried:

 

SATA set to AHCI

Boot in 32bit mode arch=i386

Added rd= ML partition to org.chameleon.Boot.plist

Chameleon 1820 & 1823

Sill using original dsdt.aml currently used for Lion

 

But still no hope

Share this post


Link to post
Share on other sites
Advertisement
Guest sincro77

well what type of chipeset kext do you use in lion?.. install that in ML. did you try that?

Share this post


Link to post
Share on other sites

my mobo chipset is Z68, but I really don't know what you advised us here, this kext should be like what, my Lion installed using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and compatible dsdt.aml noting more, could you advice me what kext I should look for in extensions folder on Lion?

It will be appreciated :)

Share this post


Link to post
Share on other sites

I tried UserKernalCache=No but no hope, I was facing same problem before after releasing Lion DP1&2 and solved in DP4 after releasing new release of chameleon, I hope to have it soooooooon

 

I tried new chameleon release 1824 and same problem still

Share this post


Link to post
Share on other sites

You mean orangeiconfix.kext? this kext makes orange icons to grey internal disk icons.

It is one of the injectors .only with plist.

It's not in real mac.

if your hard disk icon is grey. then you might have similar injector of different name.

Share this post


Link to post
Share on other sites

Boots on your OSX Lion partition, and installs chameleon, Extra, boot.plist, smbios.plist and your kexts on your Moutain Lion partition (just change the installation location). And then you should be able to start on Moutain Lion without the "Still waiting for root device..."

Share this post


Link to post
Share on other sites

i have seen and solved this many times this way. M/L must be installed on HD 0,2 if you have other hd's or partitions that have a bootloader installed it will conflick. sata drive should be from sata port 1 i f possible M/L should be installed on first patition then the drive will have the ID of HD 0,2 that is what the M/L bootloaders are looking for if its hd 1,2 or something else it will stall looking only for HD 0,2 rearange your HD'S and remove any extra usb or external drives

Share this post


Link to post
Share on other sites

Thanks for helping me but I tried that many times but still no fix

 

 

 

 

Have you tried delete PlatformSupport.plist in S/L/coreservices. !!!!!! :worried_anim:

Share this post


Link to post
Share on other sites

Indeed I have 4 HDs, 1 SSD and the rest are HDD, I will try to disconnect all except ML HD and will feed you back, thank for this advice

Share this post


Link to post
Share on other sites

You can't use arch=i386, boot 64 bit and remove DSDT for now, should not be needed to at least boot to desktop and can cause probs on dual boot setups, can re-add it later. Also keep in mind even the newest Chameleon versions do not support booting Mountain Lion, you have to use ErmaC's branch with ML support

Share this post


Link to post
Share on other sites

problem still exists after disconnecting other HDs

 

Hello!!!, try to reinstall the Folder Extra :moil: , and repair permissions

 

bash-3.2# chmod -R 755 /Extra

bash-3.2# chown -R root:wheel /Extra

bash-3.2# touch /Extra

bash-3.2# touch /

 

it works!!!

Good Luck!!! :P

Share this post


Link to post
Share on other sites

Try with: " GraphicsEnabler=No -x -v arch=i386"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By Protege 1st
      I've a old computer lying around..it's Dell OPTIPLEX 755 mini tower.......its specs are
      3 GB R.A.M (DDR2) 320 GB HDD (SATA-Windows) 160 GB HDD (SATA- Want to use for MAC OS X ML) Intel Core 2 Duo E6550 @2.33 GHz  I've been to more than a million websites for making a hackintosh but......
      I downloaded a .dmg Mac OS X Mountain Lion file from Mac Store (from my friend's Mac - he's abroad now ).. Used POWER ISO to convert it in into .iso file.....now I've got that ISO on my Win 8.1....... any suggestions on how to make
      A Mountain Lion Hackintosh on my Dell Optiplex 755

      P.S.......... I bought a factory-made P.C so I can't find any DSDT
×