Jump to content
ErmaC

[GUIDA] USB - Mountain Lion automatizzata

563 posts in this topic

Recommended Posts

Ciao a tutti!

Sono solo di passaggio...

volevo solo upparvi una versione aggiornata dell'AppleAHCIPort.kext per Mountain Lion 10.8.2 (2.4.1).

Ringrazio eep357 per l'idea.

Lo kext va installato con Kext Wizard riparati permessi e ricostruita la cache.

Questo Kext ha una "gamma" più ampia di controller rispetto alla precedente e rispetto allo kext base proposto da mamma "mela".

Per maggiori dettagli date una occhiata all'Info.plist dello kext per vedere che cosa ha in più...

AppleAHCIPort.kext.zip

Buon divertimento.

Fabio

Share this post


Link to post
Share on other sites
Advertisement

Ciao a tutti!

Sono solo di passaggio...

volevo solo upparvi una versione aggiornata dell'AppleAHCIPort.kext per Mountain Lion 10.8.2 (2.4.1).

Ringrazio eep357 per l'idea.

Lo kext va installato con Kext Wizard riparati permessi e ricostruita la cache.

Questo Kext ha una "gamma" più ampia di controller rispetto alla precedente e rispetto allo kext base proposto da mamma "mela".

Per maggiori dettagli date una occhiata all'Info.plist dello kext per vedere che cosa ha in più...

AppleAHCIPort.kext.zip

Buon divertimento.

Fabio

 

Scusate, con questo kext potrebbero funzionare anche le jmicron pata?

 

Francesco

Share this post


Link to post
Share on other sites

Ragazzi ma con lo script MLionize-DP1 in prima pagina posso installare la 10.8.2?

 

oppure devo prima installare la 10.8.0 e poi aggiornare alla 10.8.2?

 

grazie

Share this post


Link to post
Share on other sites

Ragazzi ma con lo script MLionize-DP1 in prima pagina posso installare la 10.8.2?

 

oppure devo prima installare la 10.8.0 e poi aggiornare alla 10.8.2?

 

grazie

 

Credo che la miglior risposta sia... provare per credere...

 

Fabio

Share this post


Link to post
Share on other sites

Provato adesso e MLionize.cmd funziona anche con la 10.8.2.. Sei un grande!

 

Ho installato tutto e riconosce tutte le periferiche ma ho dei problemi con l'audio che non funziona...

 

Sono andato su resoconto di sistema e vedo che riconosce la scheda audio integrata ma non mi compare l'altoparlante in alto a destra...

 

La mia scheda audio è la P6T

Share this post


Link to post
Share on other sites

Ciao a tutti, scrivo poco, ma vi seguo molto,

sto cercando testardamente di passare a Mountain Lion e speravo come con Lion di riuscirci da solo, ma dopo 3 giorni vi chiedo cortesemente una mano.

 

Premetto che ho 2 HD da 1TB, su uno c'è l'installazione di Windows7, sul 2 HD è istallato Lion 10.7.3 perfettamente funzionante da oltre 1 anno.

Su questo secondo HD (quello con Lion) ho creato una partizione da 135Gb per installare ML. Con il passaggio a ML volevo anche sostituire AMD 4870 da 1gb con la nuova GTX660 da 2GB. Ed una volta che il sistema è stabile vorrei portare tutto ad una singola partizione ML

ripristinando i miei dati con TimeCapsule.

 

 

Ho seguito procedimento di .:ErmaC lionizeML, tutto ok nell'istallazione, eseguito con successo comando finalize.

Installato FakeSMC nella S/L/E del disco di root.

Ricostruiti i permessi con Kext Wizard.

 

Al riavvio tolta la penna USB ed utilizzando -v il caricamento arriva alle ultime 10 prima di caricare il framework e poi si riavvia, senza darmi il tempo di vedere su quale riga salta.

 

Invece il caricamento da USB della partizione ML dell'HD è velocissimo ed il sistema tranne per l'Audio (che affronterò in seguito) funziona perfettamente.

 

allego mio cartella Extra zippata.

 

Grazie in anticipo per l'aiuto,

Extra.zip

Share this post


Link to post
Share on other sites

scusa ma dove hai preso il file FakeSMC? ho visto che fa parte dell'ultimo step d'installazione

 

come te anche a me nella mia P6T non funziona l'audio!!! Fabio vienici in aiuto!!!

 

p.s. avevo il tuo stesso problema del riavvio e ho risolto aggiornando chamaelon all'ultima versione... :wink2:

Share this post


Link to post
Share on other sites

Il FakeSMC lo trovi dentro la cartella System/Library/Extensions dentro la chiavietta Usb di installazione. Ho provato ad aggiornare Chameleon ma va sempre in crash durante il boot senza chiavetta.

Share this post


Link to post
Share on other sites

scusa ma dove hai preso il file FakeSMC? ho visto che fa parte dell'ultimo step d'installazione

 

come te anche a me nella mia P6T non funziona l'audio!!! Fabio vienici in aiuto!!!

 

p.s. avevo il tuo stesso problema del riavvio e ho risolto aggiornando chamaelon all'ultima versione... :wink2:

Avevi ragione, sbagliavo ad aggiornare soltanto la partizione di Mountain Lion, invece ho aggiornato anche la partizione di Lion originaria (in quanto ho un HD sia con Lion che con ML) ed ho risolto l'errore del crash. Ora mi carica perfettamente in un lampo.

Unico neo al boot chameleon mi da sulla partizione ML il semaforo rosso, ma poi parte tranquillo.

Ora provo a risolvere l'audio ed a installare la nuova scheda Palin GTX660, vediamo come va.

 

ps: chameleon della partizione LION l'ho aggiornato con Chameleon Wizard selezionando come sorgente Dropbox ver.2.2svn r2110 con il Boot0 in quanto su uno stesso HD ho 2 partizioni OSX.

Share this post


Link to post
Share on other sites

sono contento che hai risolto... anche io stavo uscendo pazzo.... per l'audio dimmi come fai perché ci sto provando anche io... bisogna modificare il DSDT

Share this post


Link to post
Share on other sites

ho letto sul forum inglese che ad alcuni funziona l'appleHDA.kext della 10.7.4 qui sto provando ad installarlo, riavvio e ti dico.

Ho letto anche io che bisogna modificare il DSDT, l'ho decompilato con Chameleon wizard ho trovato il Layout ID, ma poi non capisco se bisogna inserire il file HDEF in più o al posto del testo presente e comunque alla fine quando compilo mi da errore. Non sono abbastanza programmatore per rilevare gli errori...mannaggia.

 

sono contento che hai risolto... anche io stavo uscendo pazzo.... per l'audio dimmi come fai perché ci sto provando anche io... bisogna modificare il DSDT

ciao terzo33 ti confermo che se installi con Kext wizard l'appleHDA.kext sia della versione 10.7.3 o .4 l'audio di tutte le periferiche torna a funzionare, pure l'uscita digitale ottica.

Ti allego per praticità il kext che ho usato io.

Ricordati di correggere i permessi.

AppleHDA.kext.zip

Share this post


Link to post
Share on other sites

Ragazzi mi levate una curiosità?

 

nell'ultimo step è previsto installare in S/L/E FakeSMC.kext ma io non l'ho fatto e tutto funziona correttamente... come mai?

 

cosa cambia?

 

p.s. ho controllato il file fakeSMC dentro la pendrive in S/L/E e quello già situato sull'HD in S/L/E e mi sembrano gli stessi...

 

 

Posta il tuo dsdt

 

Fabio

 

Fabio eccolo...

 

 

grazie mille

DSDT.aml.zip

Share this post


Link to post
Share on other sites

@ terzo33

Sostituisci il dsdt

Apri Kext Wizard sostituisci AppleHDA.kext ( scaricalo dal link che ti ho postato )

Riavvia

 

Fabio

 

 

Fabio non trovo il link del kext AppleHDA ...

Share this post


Link to post
Share on other sites

Perfetto!!! funziona.... grazie

 

Fabio nell'ultimo step è previsto installare in S/L/E FakeSMC.kext ma io non l'ho fatto e tutto funziona correttamente... come mai?

 

cosa cambia?

 

p.s. ho controllato il file fakeSMC dentro la pendrive in S/L/E e quello già situato sull'HD in S/L/E e mi sembrano gli stessi...

Share this post


Link to post
Share on other sites

Bene :)

Se già è installato in S/L/E sei apposto.

 

Fabio

 

Sì praticamente facendo da terminale "finalize" come ultimo Step, installa anche il FakeSMC

Share this post


Link to post
Share on other sites

Per il discorso dell'audio ALC1200 si ha lo stesso risultato installando il kext alegato qualche post fa senza dover modificare il DSDT...

 

Tuttavia mi sembra che in entrambi i casi la scheda audio viene riconosciuta come stereo e non 7.1

Share this post


Link to post
Share on other sites

Per il discorso dell'audio ALC1200 si ha lo stesso risultato installando il kext alegato qualche post fa senza dover modificare il DSDT...

 

Tuttavia mi sembra che in entrambi i casi la scheda audio viene riconosciuta come stereo e non 7.1

Ciao terzo33, una curiosità come fai a riconoscere che l'uscita è a 2 canali invece che 7?

Se uso l'uscita ottica l'ampli me la riconosce come 5.1.

Invece ti segnalo che dopo aver installato i driver appena rilasciati da Nvidia (questo link:http://www.nvidia.com/object/macosx-304.00.05f02-driver.html) anche se non presente nella lista la Nvidia GTX 660 viene perfettamente riconosciuta. Sono anche riuscito ad avere l'accelerazione Hardware con la suite Adobe di CS6 allego per comodità la spiegazione su file zip tradotta con google translate dall'inglese.

Oggi vorrei provare l'uscita audio HDMI direttamente della scheda NVIDIA bypassando la Asus P6T, vediamo se funziona.

Ciao

Seb

 

ps: non sono ancora riuscito ad avere il semaforo verde sulla partizione ML da Chameleon, qualcuno ha qualche suggerimento?

ps2: consigli per il metodo corretto per migrare la partizione originale di LION (700GB) su ML(140GB) entrambe sullo stesso disco da 1TB, considerando che ho il backup su TimeCapsule senza magari dover ri-installare ML ex-novo?

attivare cuda su CS6 GTX660 NVIDIA.zip

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hornpipe2
      I have a Mac Mini 2006 (upgraded) with Intel GMA950 graphics, running MLPostFactor 10.8.5.  It is connected to an ASUS VS197 LCD panel using DVI-D.  This is natively a 1366x768 panel that is recognized and works fine.
       
      However, the other choices for resolution are 4:3 800x600 and 1024x768, and then the oddballs 832x624 and 1360x768.  None of these are useful as a low-resolution widescreen for gaming or watching DVD content.  Specifically I want to get access to 848x480 or 854x480, and also 1024x576.  SwitchResX makes these choices available, but it doesn't work with a "full screen" game, presumably because the game directly queries OSX Display to get a list of valid resolutions and SwitchResX is bypassing that system instead.
       
      So the solution is obvious: buy a new computer pull the monitor's EDID data, hack it to enable new resolutions, and then tell OSX to use this custom EDID instead of the one retrieved from the monitor.
       
      Following the steps of the EDID injection guide, here is where I am:
       
      * Retrieve EDID, DisplayVendorID etc from ioreg.
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 F1 * Use an EDID editor to enable new 848x477 and 1024x576 resolutions.  (Verify with an online EDID tool, and compare to the previous version)
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 4B C0 4B CA 4B CF 61 C0 61 CA 61 CF 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 47 * Create a new subfolder and plist within /System/Library/Overrides/Display/ containing the new EDID string and monitor name.
      * Reboot.
       
      Now the problems begin.  Even though the plist file is being read (which I know because the Monitor Name has changed in Displays), the custom EDID is not being used.  When I dig into IORegExplorer I am able to come up with AAPL00,EDID string and it is the unmodified one read from the monitor.  I even tried a plug-and-unplug while OSX is running, and also tried to reset the SMC and NVRAM, but no dice.
       
      Do I need to start digging into DSDT hacking?  Is the Intel driver pulling down EDID during boot and I need to override it somewhere else?  What am I missing here?
    • By DaniiSwan
      Hello,
       
      I've been attempting for the past few days to install OS X Mountain Lion on my Lenovo Thinkpad Edge E530 with little success. So much so that I've finally decided I'm probably out of ideas and created this forum post requesting help.
       
      My Laptop Specs are:
       
      Intel Core i3-2328m (Sandy Bridge CPU at 2.2GHZ with support for SSE2 , SSE3 and SSSE3)
      8GB RAM
      500GB Hitachi Z7K500 HDD
      Lenovo 627226G Motherboard (Intel HM77 Chipset)
      Intel HD Graphics 3000
       
      More Detailed Specs ---> https://drive.google.com/open?id=0B-GXUa1I8xyDZU1SdklDSlhER2c
       
      So far , I've attempted to install iAtkos ML2 and ML3U via USB and so far both have worked up until the first sighting of the apple logo then the laptop restarted. In both cases , I was using a separate USB with chameleon bootloader on but in the instance where I tried to use the onboard bootloader on ML3U , I hit enter and the screen simply remained black.
       
      Any help would be much appreciated
       
      Thank you for your time.
    • By VanekMedia
      Hey all,
       I built my first Hackintosh back in 2012 and its been runner amazing. Thank you again for the awesome guides and forums that made it all possible. I have however hit the end of this builds software limits. I am still running 10.8.2 mountain lion on the machine. I would like to update to Sierra and want to make sure I am clear on the procedures. Now that it seems like everything is could based and no longer get physical versions of OS.
      currently i am backing up the system using and external drive and "carbon copy cloner" as shown here: http://www.macbreaker.com/2012/06/backup-your-hackintosh-with-carbon-copy.html
       
      My question is should i follow the set via the App store updates, Wipe the system and start over or is there a better way to achieve running Sierra on my machine?
       
      Here are my build specs:
      Processor name: Intel Core i7
      Processor Speed: 3.50 GHZ
      # of cores: 4
      memory: 32gb
      Boot rom version: insanelymac.com
      Graphics Card: Nivda GeForce GTX 670
      System Version: OSX 10.8.2 (12c60)
      i have also attached screen shots of the spec to further help:
       
      Thank you for taking the time to help me out with my build. look forward to getting this bad boy updated.
       
       
      Mahalo,
       
      -VM




    • By OSXDev
      While most of the VMWare guest hardware is virtualized, the guest VM CPU reflects the same CPU features the physical host CPU has.
      This guide details the additional work that is needed to run OS X 10.8-10.12 with an AMD CPU under VMWare.
       
      If your AMD CPU supports SSE3 and SSSE3 (and SSE4.1 for OS X 10.12):
      The installation should be pretty simple:
      1. Install VMWare Workstation 8.0.6 / 9.0.4 / 10.0.4 / Player 6.0.4.
      2. Run VMWare Unlocker 1.3.0.
      3. Prepare an installation ISO from the untouched 10.8 (Mountain Lion) DMG using dmg2img.
      4. Create a new VM (select "Mac OS X 10.8" as the guest operating system).
      5. Set your 'number of cores per processor' to 1 (the number of processors can be set to more than one).
      6. A. For OS X 10.8-10.11:
      Open the .vmx file of the virtual machine and add the following lines:
      cpuid.0.eax="0000:0000:0000:0000:0000:0000:0000:1011" cpuid.0.ebx="0111:0101:0110:1110:0110:0101:0100:0111" cpuid.0.ecx="0110:1100:0110:0101:0111:0100:0110:1110" cpuid.0.edx="0100:1001:0110:0101:0110:1110:0110:1001" cpuid.1.eax="0000:0000:0000:0000:0000:0110:1111:0001" cpuid.1.ebx="0000:0010:0000:0001:0000:1000:0000:0000" cpuid.1.ecx="1000:0010:1001:1000:0010:0010:0000:0011" cpuid.1.edx="0000:1111:1010:1011:1111:1011:1111:1111" (this will identify the guest CPU as an Intel Core 2 Merom, and will help you avoid the 'The CPU has been disabled by the guest operating system. Power off or reset the virtual machine.' error)
       
      6. B. For OS X 10.12 Sierra:
      cpuid.0.eax="0000:0000:0000:0000:0000:0000:0000:1011" cpuid.0.ebx="0111:0101:0110:1110:0110:0101:0100:0111" cpuid.0.ecx="0110:1100:0110:0101:0111:0100:0110:1110" cpuid.0.edx="0100:1001:0110:0101:0110:1110:0110:1001" cpuid.1.eax="0000:0000:0000:0001:0000:0110:0111:0001" cpuid.1.ebx="0000:0010:0000:0001:0000:1000:0000:0000" cpuid.1.ecx="1000:0010:1001:1000:0010:0010:0000:0011" cpuid.1.edx="0000:1111:1010:1011:1111:1011:1111:1111" (this will identify the guest CPU as an Intel Core 2 Penryn which supports SSE4.1)
       
      7. If your Hardware compatibibility is set to Workstation 9.0 (virtualHW.version = "9") or 10, you must also add the following line:
      featureCompat.enable = "FALSE"

      8. You can now boot from the ISO and proceed with the installation.

      9. Even though I could complete the installation without a hitch with my A8-5600K, a few applications consistently crashed (e.g. Grapher), this was resolved by replacing the kernel with a modified kernel that emulates all missing SSE3 / SSSE3 instructions (see below).


      If your AMD CPU does not support SSSE3:
      You need to replace the kernel with one that has SSSE3 emulation (see below),
      the easiest way to do it is to use another computer that has SSSE3 to create the virtual disk and replace the kernel.
      1. After you have a working OS X machine, update to 10.8.5, make a copy of the virtual disk and attach it to the same VM.

      2. Change the os settings to show hidden files (see here), and delete the hidden 'mach_kernel' from the root folder of the attached disk.
      (alternatively, use the terminal to perform this, e.g. 'sudo chflags nohidden mach_kernel' or 'sudo rm mach_kernel')

      3. Put the modified kernel (see below) instead of the one you just deleted (use the same file name).

      4. Delete the old kernel cache by deleting the content of the '/System/Library/Caches/com.apple.kext.caches/' directory.

      5. Optionally: hide back the kernel (with 'sudo chflags hidden mach_kernel').

      6. Create a new VM, update the .vmx files to include the 8 cpuid.* lines from above.

      7. You can now use the attached disk to boot OS X 10.8.5 from a VM hosted with an older AMD CPU that does not support SSSE3.

      Tested With A8-5600K, A8-3850 and VMWare Workstation 8.0.6 / 9.0.4 / 10.0.4 / Player 6.0.4

      Modified Kernel:
      For your convenience, I have created a modified 10.8.5 kernel (a.k.a. xnu-2050.48.11) specifically to be used with VMWare, and attached it to this post.
      The only modification to this kernel is that it includes OpEmu3, the SSE3 and SSSE3 emulator created by Sinetek and AnV (thanks guys!).
      This emulator is only used when necessary (i.e. if your CPU support a specific instruction, the emulator will not be used to execute it).
      The source code to OpEmu3 is available here and my adaptaion to 10.8.5 is available here.
      10.8.5-OpEmu3.zip
    • By Haris Usmani
      M​A​C OSX Mountain Lion on a Lenovo x61
       
      Hello everyone this is my first post on this forums so I hope I will recieve help. I have a Lenovo x61.
       
      My specs are:-
       
      Intel 965 Express Chipset
      4Gb DDR2 Ram
      250 GB HDD Hard Drive
      Windows 10 Enterprise                  
      ----------------------------------------------
      I want to install Mac OSX Mountain Lion with sound and WiFi on my laptop. I know Mac OSX Mountain Lion cannot be installed on Intel 965 Express chipset but I read an article on the internet that says that I can install with the help of  MLPF hack. So can you please help me to install Mac OSX Mountain Lion.
      ----------------------------------------------
       
      Thank you
×