Jump to content
ErmaC

[GUIDA] USB - Mountain Lion automatizzata

563 posts in this topic

Recommended Posts

Grazie mille per le info :) scusa ti faccio una domanda forse un pò sciocca (purtroppo sono alle prime armi...) i file che mi hai allegato li devo mettere sulla chiavetta (ricostruendo la cache...) e poi procedere con l'installazione oppure li riporto a installazione terminata?

 

Grazie e scusa per il disturbo ;)

Si lo scritto, no?

 

Se non erro non riuscivi a fare l'istallazione e quei file ti dovrebbero servire per avviare, quindi sulla chiavetta. Poi se ci sono ulteriori problemi ci si dovrebbe ragionare dopo, ma prima l'istallazione.

 

Micky

Share this post


Link to post
Share on other sites
Advertisement

Si lo scritto, no?

 

Se non erro non riuscivi a fare l'istallazione e quei file ti dovrebbero servire per avviare, quindi sulla chiavetta. Poi se ci sono ulteriori problemi ci si dovrebbe ragionare dopo, ma prima l'istallazione.

 

Micky

 

Perfetto, grazie mille! nel week end se riesco provo ad installare e ti tengo informato! :)

 

Buona giornata

Share this post


Link to post
Share on other sites

Ciao a tutti, sono ritornato dopo un bel pò di tempo.

Ho installato ML sul mio pc con il sistema generico. Non so perché ma non mi riconosce le due schede di rete LAN e ho il problema di accedere all' Apple Store.

Per curiosità ho messo pure il mio "vecchio" DSDT per il mio processore, ma non li vede ancora.

Sapreste darmi un consiglio? Per la LAN dovrebbero essere 2 Marvell88E8056 (soprannominate Yukon2 ?)

 

Ciao A tutti qualcuno sa come configurare la ati 6870 su ml 1082? esistono i kext specifici per questa scheda video?

Ma non dovrebbe essere pienamente supportata? Al limite con il comando da boot GE=Yes ?

E' il file ATI6000Controller.Kext che la gestisce, ovviamente và tolta durante l'installazione e rimessa al suo posto dopo l'installazione.

Oppure intendi altra cosa?

Share this post


Link to post
Share on other sites

non mi riconosce le due schede di rete LAN e ho il problema di accedere all' Apple Store.

 

 

Risolto con kext Marvell apposito e iCloudFix

 

Ciao

Share this post


Link to post
Share on other sites

Un' informazione.

E' normale che riesca a far funzionare perfettamente il sistema senza l'aggiunta del DSDT specifico alla mia scheda madre?

Mi ricordo che con lo script Lionize il DSDT veniva installato in automatico, mentre con MountainLionize questo passaggio non è stato possibile, in quanto funziona la versione generica, e quindi non installa il DSDT specifico.

Però funziona bene ugualmente.

Ciao

Share this post


Link to post
Share on other sites

Ciao moreftp

 

Nella versione generica esatto non ti installa il DSDT specifico della tua scheda.

Ma anche se usi lo script Lionize non ti aggiorna con DSDT , kext ecc.

 

Mi rispose ErmaC qualche tempo fa quando testavo Lionize :

 

è un problema che affetta solo chi usa il finalize...
E non affetta l'installazione quindi, tempo permettendo cercherò di aggirare il problema,
Potete risolvere temporaneamente, completando la post-installazione da un altro sistema,
installando il FakeSMC e riparazioni permessi ecc...

 

Fabio

Share this post


Link to post
Share on other sites

Perfetto Fabio, questo lo comprendo.

Volevo solo capire se era indispensabile aggiungere il DSDT manualmente, in quanto anche senza mi sembra funzionante.

Una cosa che mi sono dimenticato prima: per la mia scheda madre, durante l'intallazione generica non mi riconosce le due schede Marwell di rete. Non è che dentro il DSDT ci sono o era lo script Finalize che le inseriva nei Kext?

Share this post


Link to post
Share on other sites

 

Ciao ho installato il tuo script su un Osx 10.6.0 che è installato su un HP7100

per creare la pennatta USB d' avvio che è una Cruzer Blade 8Gb Sandisk quelle rosse

sembra che fa tutto bene e la pennetta si avvia provata sullo stesso HP7100 ma mi da errore di legacy_kernel non trovato :(

 

Cosa ho sbagliato ?

 

Inoltre dovrei installarlo su un PC con scheda madre Asrock Z77 Extreme 4

Processore Intel I5 3550 3,3Ghz

Skvideo aggiuntiva Nividia Quadro 600

32Gb di RAM

 

Cosa devo selezionare nel tuo script come tipo pc e altre cose per andare bene ?

 

Come immagini OSX ho provato sia con "InstallESD.dmg" che "OS X Mountain Lion 10.8.2.dmg"

Nelle OSX86 WIKI nel dettaglio http://wiki.osx86pro...L_10.8.2#Asrock

leggendo le note per la mia schedaMadre leggo che si vede fare qualcosa al Bios ma non mi è chiaro cosa ?

La devo fare anche se uso questa procedura con installazione da pennetta USB ?

 

Aggiungo immagine dell errore erroreosxbootusb.jpg

 

Grazie

Share this post


Link to post
Share on other sites

Come mai pur avendo un 4GB di ram (2GBx2) mi dà:

RTC: Only single RAM bank (128 bytes)

quando provo a bootare ML e non va avanti? ho provato ad'avviarlo in verbose mode.

Share this post


Link to post
Share on other sites

ciao tutti

posso sapere se usb 3.0 funziona sulla mb asus x58

grazie

 

Ciao,

si la USB 3.0 sulla Sabertooth x58 funziona correttamente...

con i case usb3 economici alcune volte fatica a vederlo e mi costringe a staccare e riattaccare il disco....

Maurizio

 

Share this post


Link to post
Share on other sites

Ciao,

si la USB 3.0 sulla Sabertooth x58 funziona correttamente...

con i case usb3 economici alcune volte fatica a vederlo e mi costringe a staccare e riattaccare il disco....

Maurizio

 

ciao

ma hai installato quelche kext particolare x fare funzionare.xk da me non va.non va ne anche la porta usb 3.0

Share this post


Link to post
Share on other sites

CIAO FABIO

IO ANCORA NON RIESCO FARE FUNZIONARE USB 3.0.E ANCHE IL SSD CON ML SOPRA COLEGATO ALLA PORTA SATA3 SULLA SCHEDA MADRE NON FUNZIONA.

HAI QUELCHE SOLUZIONI...GRAZIE

Ciao christyfernando.

Ti si è bloccato il "caps look"? tutto maiuscolo equivale a "gridare", il quale non è gradito.

 

Tornando al discorso delle USB.

Premessa che non ho nessun dispositivo USB3.0 da poter provare,

su Lion (10.7.x) inserii uno kext patchato nel processo di creazione per le schede madri che necessitavano e montavano un controller USB3.0 non ho la minima idea se su Mountain Lion funzioni ancora.

Probabilemente hai effettuato una installazione "generica" con MLionize dove tale kext non viene installato.

 

Installa questo (è il medesimo di MLionize) con Kext Wizard ricostruisci cache e ripara permessi disco.

PXHCD.kext.zip

 

per l'altro problema:

A questo post #150 ho postato degli kext modificati per correggere e migliorare alcuni problemi,

AppleAHCIPort.kext e AppleRTC.kext fanno al caso tuo, come prima installali con Kext Wizard.

 

Fabio

Share this post


Link to post
Share on other sites

Ciao fabio, scusami puoi aiutarmi a risolvere l'errore che ho riportato nel post sopra? Scusami ma è da 4 giorni che ci stó sbattendo la testa

 

Come mai pur avendo un 4GB di ram (2GBx2) mi dà:

RTC: Only single RAM bank (128 bytes)

quando provo a bootare ML e non va avanti? ho provato ad'avviarlo in verbose mode.

per la creazione della pendrive ho usato in virtualbox la distro Niresh, non sono partito da un lion o altro quindi non ho nessun kext installato

Share this post


Link to post
Share on other sites

Ciao fabio, scusami puoi aiutarmi a risolvere l'errore che ho riportato nel post sopra? Scusami ma è da 4 giorni che ci stó sbattendo la testa

per la creazione della pendrive ho usato in virtualbox la distro Niresh, non sono partito da un lion o altro quindi non ho nessun kext installato

 

Ciao Askancy

 

Puoi postare una foto in verbose mode.

 

Fabio

Share this post


Link to post
Share on other sites

Eccolo Fabio: http://ipbseo.it/IMG_0425.gif

scusami ma l'ho dovuto caricare via FTP sul mio sito, perché ho una connessione veramente pietosa e mi dava fisso Timeout se provavo a metterlo come allegato. (ho una 640k :()

Durante il processo del wizard mi chiede di selezionare il mio mac preferito, questa scelta influisce? perché io da perfetto ghiozzo ho messo Mac pro 5.1 :$

Share this post


Link to post
Share on other sites

Durante il processo del wizard mi chiede di selezionare il mio mac preferito, questa scelta influisce? perché io da perfetto ghiozzo ho messo Mac pro 5.1 :$

Per la tua configurazione se è quella che vedo in firma sarebbe meglio settarlo al max come un MacPro3,1.

 

Fabio

Share this post


Link to post
Share on other sites

Ma l'intel e8400 è un 2duo non un 2quad... È uguale?

 

E quindi questo problema è un problema di configurazione sulla scelta del mac? io pensavo che quella fosse una scelta a piacere visto che nella guida, diceva "scegliete il vostro mac preferito"

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hornpipe2
      I have a Mac Mini 2006 (upgraded) with Intel GMA950 graphics, running MLPostFactor 10.8.5.  It is connected to an ASUS VS197 LCD panel using DVI-D.  This is natively a 1366x768 panel that is recognized and works fine.
       
      However, the other choices for resolution are 4:3 800x600 and 1024x768, and then the oddballs 832x624 and 1360x768.  None of these are useful as a low-resolution widescreen for gaming or watching DVD content.  Specifically I want to get access to 848x480 or 854x480, and also 1024x576.  SwitchResX makes these choices available, but it doesn't work with a "full screen" game, presumably because the game directly queries OSX Display to get a list of valid resolutions and SwitchResX is bypassing that system instead.
       
      So the solution is obvious: buy a new computer pull the monitor's EDID data, hack it to enable new resolutions, and then tell OSX to use this custom EDID instead of the one retrieved from the monitor.
       
      Following the steps of the EDID injection guide, here is where I am:
       
      * Retrieve EDID, DisplayVendorID etc from ioreg.
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 F1 * Use an EDID editor to enable new 848x477 and 1024x576 resolutions.  (Verify with an online EDID tool, and compare to the previous version)
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 4B C0 4B CA 4B CF 61 C0 61 CA 61 CF 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 47 * Create a new subfolder and plist within /System/Library/Overrides/Display/ containing the new EDID string and monitor name.
      * Reboot.
       
      Now the problems begin.  Even though the plist file is being read (which I know because the Monitor Name has changed in Displays), the custom EDID is not being used.  When I dig into IORegExplorer I am able to come up with AAPL00,EDID string and it is the unmodified one read from the monitor.  I even tried a plug-and-unplug while OSX is running, and also tried to reset the SMC and NVRAM, but no dice.
       
      Do I need to start digging into DSDT hacking?  Is the Intel driver pulling down EDID during boot and I need to override it somewhere else?  What am I missing here?
    • By DaniiSwan
      Hello,
       
      I've been attempting for the past few days to install OS X Mountain Lion on my Lenovo Thinkpad Edge E530 with little success. So much so that I've finally decided I'm probably out of ideas and created this forum post requesting help.
       
      My Laptop Specs are:
       
      Intel Core i3-2328m (Sandy Bridge CPU at 2.2GHZ with support for SSE2 , SSE3 and SSSE3)
      8GB RAM
      500GB Hitachi Z7K500 HDD
      Lenovo 627226G Motherboard (Intel HM77 Chipset)
      Intel HD Graphics 3000
       
      More Detailed Specs ---> https://drive.google.com/open?id=0B-GXUa1I8xyDZU1SdklDSlhER2c
       
      So far , I've attempted to install iAtkos ML2 and ML3U via USB and so far both have worked up until the first sighting of the apple logo then the laptop restarted. In both cases , I was using a separate USB with chameleon bootloader on but in the instance where I tried to use the onboard bootloader on ML3U , I hit enter and the screen simply remained black.
       
      Any help would be much appreciated
       
      Thank you for your time.
    • By VanekMedia
      Hey all,
       I built my first Hackintosh back in 2012 and its been runner amazing. Thank you again for the awesome guides and forums that made it all possible. I have however hit the end of this builds software limits. I am still running 10.8.2 mountain lion on the machine. I would like to update to Sierra and want to make sure I am clear on the procedures. Now that it seems like everything is could based and no longer get physical versions of OS.
      currently i am backing up the system using and external drive and "carbon copy cloner" as shown here: http://www.macbreaker.com/2012/06/backup-your-hackintosh-with-carbon-copy.html
       
      My question is should i follow the set via the App store updates, Wipe the system and start over or is there a better way to achieve running Sierra on my machine?
       
      Here are my build specs:
      Processor name: Intel Core i7
      Processor Speed: 3.50 GHZ
      # of cores: 4
      memory: 32gb
      Boot rom version: insanelymac.com
      Graphics Card: Nivda GeForce GTX 670
      System Version: OSX 10.8.2 (12c60)
      i have also attached screen shots of the spec to further help:
       
      Thank you for taking the time to help me out with my build. look forward to getting this bad boy updated.
       
       
      Mahalo,
       
      -VM




    • By OSXDev
      While most of the VMWare guest hardware is virtualized, the guest VM CPU reflects the same CPU features the physical host CPU has.
      This guide details the additional work that is needed to run OS X 10.8-10.12 with an AMD CPU under VMWare.
       
      If your AMD CPU supports SSE3 and SSSE3 (and SSE4.1 for OS X 10.12):
      The installation should be pretty simple:
      1. Install VMWare Workstation 8.0.6 / 9.0.4 / 10.0.4 / Player 6.0.4.
      2. Run VMWare Unlocker 1.3.0.
      3. Prepare an installation ISO from the untouched 10.8 (Mountain Lion) DMG using dmg2img.
      4. Create a new VM (select "Mac OS X 10.8" as the guest operating system).
      5. Set your 'number of cores per processor' to 1 (the number of processors can be set to more than one).
      6. A. For OS X 10.8-10.11:
      Open the .vmx file of the virtual machine and add the following lines:
      cpuid.0.eax="0000:0000:0000:0000:0000:0000:0000:1011" cpuid.0.ebx="0111:0101:0110:1110:0110:0101:0100:0111" cpuid.0.ecx="0110:1100:0110:0101:0111:0100:0110:1110" cpuid.0.edx="0100:1001:0110:0101:0110:1110:0110:1001" cpuid.1.eax="0000:0000:0000:0000:0000:0110:1111:0001" cpuid.1.ebx="0000:0010:0000:0001:0000:1000:0000:0000" cpuid.1.ecx="1000:0010:1001:1000:0010:0010:0000:0011" cpuid.1.edx="0000:1111:1010:1011:1111:1011:1111:1111" (this will identify the guest CPU as an Intel Core 2 Merom, and will help you avoid the 'The CPU has been disabled by the guest operating system. Power off or reset the virtual machine.' error)
       
      6. B. For OS X 10.12 Sierra:
      cpuid.0.eax="0000:0000:0000:0000:0000:0000:0000:1011" cpuid.0.ebx="0111:0101:0110:1110:0110:0101:0100:0111" cpuid.0.ecx="0110:1100:0110:0101:0111:0100:0110:1110" cpuid.0.edx="0100:1001:0110:0101:0110:1110:0110:1001" cpuid.1.eax="0000:0000:0000:0001:0000:0110:0111:0001" cpuid.1.ebx="0000:0010:0000:0001:0000:1000:0000:0000" cpuid.1.ecx="1000:0010:1001:1000:0010:0010:0000:0011" cpuid.1.edx="0000:1111:1010:1011:1111:1011:1111:1111" (this will identify the guest CPU as an Intel Core 2 Penryn which supports SSE4.1)
       
      7. If your Hardware compatibibility is set to Workstation 9.0 (virtualHW.version = "9") or 10, you must also add the following line:
      featureCompat.enable = "FALSE"

      8. You can now boot from the ISO and proceed with the installation.

      9. Even though I could complete the installation without a hitch with my A8-5600K, a few applications consistently crashed (e.g. Grapher), this was resolved by replacing the kernel with a modified kernel that emulates all missing SSE3 / SSSE3 instructions (see below).


      If your AMD CPU does not support SSSE3:
      You need to replace the kernel with one that has SSSE3 emulation (see below),
      the easiest way to do it is to use another computer that has SSSE3 to create the virtual disk and replace the kernel.
      1. After you have a working OS X machine, update to 10.8.5, make a copy of the virtual disk and attach it to the same VM.

      2. Change the os settings to show hidden files (see here), and delete the hidden 'mach_kernel' from the root folder of the attached disk.
      (alternatively, use the terminal to perform this, e.g. 'sudo chflags nohidden mach_kernel' or 'sudo rm mach_kernel')

      3. Put the modified kernel (see below) instead of the one you just deleted (use the same file name).

      4. Delete the old kernel cache by deleting the content of the '/System/Library/Caches/com.apple.kext.caches/' directory.

      5. Optionally: hide back the kernel (with 'sudo chflags hidden mach_kernel').

      6. Create a new VM, update the .vmx files to include the 8 cpuid.* lines from above.

      7. You can now use the attached disk to boot OS X 10.8.5 from a VM hosted with an older AMD CPU that does not support SSSE3.

      Tested With A8-5600K, A8-3850 and VMWare Workstation 8.0.6 / 9.0.4 / 10.0.4 / Player 6.0.4

      Modified Kernel:
      For your convenience, I have created a modified 10.8.5 kernel (a.k.a. xnu-2050.48.11) specifically to be used with VMWare, and attached it to this post.
      The only modification to this kernel is that it includes OpEmu3, the SSE3 and SSSE3 emulator created by Sinetek and AnV (thanks guys!).
      This emulator is only used when necessary (i.e. if your CPU support a specific instruction, the emulator will not be used to execute it).
      The source code to OpEmu3 is available here and my adaptaion to 10.8.5 is available here.
      10.8.5-OpEmu3.zip
    • By Haris Usmani
      M​A​C OSX Mountain Lion on a Lenovo x61
       
      Hello everyone this is my first post on this forums so I hope I will recieve help. I have a Lenovo x61.
       
      My specs are:-
       
      Intel 965 Express Chipset
      4Gb DDR2 Ram
      250 GB HDD Hard Drive
      Windows 10 Enterprise                  
      ----------------------------------------------
      I want to install Mac OSX Mountain Lion with sound and WiFi on my laptop. I know Mac OSX Mountain Lion cannot be installed on Intel 965 Express chipset but I read an article on the internet that says that I can install with the help of  MLPF hack. So can you please help me to install Mac OSX Mountain Lion.
      ----------------------------------------------
       
      Thank you
×