Jump to content
Sign in to follow this  
Followers 0
coscos

Issues for Gigabyte p35-ds3l on Lion 10.7.3: DSDT attached

1 post in this topic

Recommended Posts

I have been using my hackintosh for more than a year. My hackintosh has a gigabyte p35-ds3l, Sapphire Radeon HD5770, Q6600. Running 10.7.3. In /E/E, I have following kexts:

  • AHCIPortInjector.kext
  • ALC8xxHDA.kext
  • AppleHDA.kext
  • AppleRTC.kext
  • FakeSMC.kext
  • HDAEnabler888.kext
  • IOAHCIBlockStorageInjector.kext
  • JMicron36xATA.kext

 

So far, everything is good except following issues:

 

1. After system gone sleep, it can't be woken up.

 

After the machine sleeps properly, when it is woke up by keyboard or power button, it goes to black screen directly. The power is on, fans spinning, but no output to screen. I have to shutdown the machine to bring it back.

 

I’ve tried patching AppleRTC file, using SleepEnabler, set darkwake to 0, but none of them works (all black screen). I also disabled the onboard LAN, and replaced it with a "Presto Gigabit Ethernet Pro PCIe Card", which is supported by Apple natively, but still no help.

 

Now I'm stucked. Any suggestion? My DSDT file is attached, which is already patched by using DSDT auto patcher (http://www.insanelymac.com/forum/index.php?showtopic=275658).

 

2. iStatMenu doesn't detect all sensors -- only CPU and harddrive temps. No fan speed etc (see pic attached). How do I enable them?

 

3. Sound: I still need ALC8xxHDA, AppleHDA, HDAEnabler888 to make my sound work.

 

Is there any patch for DSDT to eliminate these kexts so that I can just use all vanilla kexts?

post-244426-0-44458300-1329623230_thumb.png

dsdt.aml.zip

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Drovosek
      Hey.
      I have a Dell Vostro 3267 system unit. It has a Skylake processor Intel Core i5-6400 with integrated graphics Intel HD 530, 8 GB RAM, 256 GB SSD. The monitor is connected via HDMI.
      I faced a problem that if I enter Hackintosh in a sleep mode, and then I press something on the keyboard, the system unit wakes up (I hear as coolers begin to turn), but the monitor does not react in any way.
      I tried to disconnect and reconnect the HDMI cord, tried to inject EDID in config tried to change SMBIOS on MacMini8,1, but it did not change the situation.
      How to solve the problem?
       
      P.S.
      All in Mojave 10.14.6
      CLOVER.7z
    • By ludufre
      Installing macOS Mojave 10.14.6 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      09/01/2019 15:57h GMT-0
      - Updated to 10.14.6.
       
      06/10/2019 00:44h GMT-0
      - Completely rewritten.
       
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
       
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
       
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
       
      10/07/2018 00:36h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not tested yet.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
      - Test DP.
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover Configurator
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes. / 8 minutes with USB 3.0
       
       

      Install bootloader

      Download the CloverEFI (used 5058, from Automated Clover Builds) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended drivers (check all)
      - UEFI Drivers - Human Interface Devices (check all)
      - UEFI Drivers - FileVault 2 UEFI Drivers (check all, If you are going to use FileVault)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (if you are going to use NVMe)


       
       
      Make things works
       
      We'll make a full working flash drive, so follow these instructions:
       
      Will be mounted the EFI partition of the flash drive.
       
      Open the the /Volumes/EFI/CLOVER/config.plist inside this new partition with Clover Configurator (used 5.5.0.0)
       
      Important modifications
       
      config.plist
       
      ACPI Page
       
      - Check: SSDT - PluginType
       
      BOOT Page
       
      - Add: Arguments - darkwake=2
      - Check: Legacy - XMPDetection=Yes
       
      KERNEL AND KEXT PATCHES Page
       
      - Check: KernelPm
       
      RT VARIABLES Page
       
      - Change: CsrActiveConfig - 0x3E7
       
      SMBIOS Page
       
      - Change: Macmini8,1 - Mac mini (Late 2018) | Intel Core i7-8700B @ 3.20 GHz

       
      - Click: Generate New (few times in the two buttons)

       
       
      Need some Kexts in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the HWSensors 3 from here. I used the FakeSMC.kext, ACPIMonitor.kext, ITEIT87x.kext and IntelCPUMonitor.kext inside of DMG version r240.
      - Download the Lilu.kext from here. I used the version 1.3.8.

       
      Intel UHD 630
       
      ACPI Page
      - Uncheck: Fixes - AddHDMI
      - Uncheck: Fixes - FixDisplay
      - Uncheck: Fixes - FixHDA
       
      GUI Page
      - Change: Screen Resolution - 3840x2160 (My monitor is 4K)

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the WhateverGreen.kext from here. I used the version 1.3.1.

       
      Audio ALC 1220 and HDMI audio

      BOOT Page
      - Add: Arguments - alcid=11

      DEVICES Page
      - Change: Audio - Inject - 11
      - Uncheck: Audio - AFGLowPowerState
      - Uncheck: Audio - ResetHDA

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the AppleALC.kext from here. I used the version 1.4.0.

       
      All USBs (2.0, 3.0, Type-C, internal)
       
      KERNEL AND KEXT PATCHES Page - KextsToPatch
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FF0F0F
      - Replace* [HEX]: 83FF3F0F
      - Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Need SSDT patch in the folder /EFI/CLOVER/ACPI/patched/
       
      - Download the SSDT-EC.aml, SSDT-UIAC.aml and SSDT-USBX attached bellow.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      LAN Cards
       
      Need a Kext for feach card in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the IntelMausiEthrenet.kext from here. I used the version 2018-1031.
      - Download the SmallTreeIntel82576.kext attached bellow. I do not remember where I found it.

       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Save & Exit Setup
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the EFI folder inside your destination disk EFI parittion, with EFI folder inside flash card EFI partition.

      If the flash drive EFI partition of your destination disk or flash drive is unmounted:
      Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 0 for destination disk and 1 for flash drive.
       
      Then, eject the flash drive.
       
      Last step
       
      Move all Kexts from EFI partition to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.6
       
      - Download and open latest CloverConfigurator
      - Open Mount EFI and click in Mount Partition in EFI Partitions list
      - Click in Open Partition that appears
      - Go to EFI -> CLOVER
      - Backup config.plist and ACPI folder to desktop
      - Go back and delete CLOVER folder
      (If you restart now you can't boot in macOS - DON'T RESTART)
      - Download latest Clover and install (link and config above)
      - Replace config.plist and ACPI folder from your desktop
       
      - Update Lilu.kext, AppleALC.kext, WhateverGreen.kext, HWSensors kexts (FakeSMC, ACPIMonitor, IntelCPUMonitor, ITEIT87x) in /Library/Extensions/
      - Run:
       
      sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i /  
       
      - Install macOS Update 10.14.6 and restart
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
       
       
      Z370N-WIFI v2.zip
    • By Pedro Diniz
      Hello Friends, how are ya?

      Could you help me with a problem?

      I followed some guides like: https://www.insanelymac.com/forum/topic ... coffeelake -dsdt /

      and the installation of high Sierra 10.13.6 (17G8030) and nvidia webdrivers (correspondent to OS version) went smoothly, the problem starts when I try to boot the GPU.

      Hardware:
      MOBO: Aorus B360M gaming 3 (rev.1)
      CPU: i5 8400
      GPU: GTX 1060 OC Galax redblack

      BIOS:
      Fast boot - disabled
      windows 8/10 features - other os
      lan pxe - disabled
      storage boot option - UEFI
      other pci devices - UEFI
       
      Initial display output - PCie 1 slot
      Intel's Platform Trust Technology (PTT) - disabled
      sata mode selection - AHCI
      XHCI hand off - enabled
      VT-d - disabled
      internal graphics - auto


      The problem is:
      I can log into the system normally without using my nvidia GPU but when I boot the system with the flags for webdrivers to work I fall into the login screen but it keeps flashing, I can see the mouse and I can move it but the screen flashes and the following error appears when the screen goes "black": IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0. I searched for this error on the internet and tried to solve but to no avail so far.

      If someone can help me I would be extremely grateful! thanks in advance!

      Clover file attached.
      CLOVER.zip
×