Jump to content
InsanelyMac Forum
Sign in to follow this  
Jamie Cruickshank

How to Install Mountain Lion on MacPro1,1

Recommended Posts

Advertisement

Great news for all those MacPro users worried at the prospect of not being able to use their dual-Xeons with mountain lion!!!

 

(In the Apple forums had people who were really angry.)

 

good job!

Share this post


Link to post
Share on other sites

Update: Graphics are now detected. Installed the GMA X3100 kexts from my Lion Time Machine backup. I'm trying to enable QE/CI now...

 

Well done! Up and running on my MacBook (Early 2008). Now on to the graphics issue (not detected after install). Everything else looks good so far.

Share this post


Link to post
Share on other sites

It looks like the Lion kexts for GMA X3100 are 32-bit. After some research I found that the 10.6.2 update included 64-bit versions (returned to 32-bit in 10.6.3). I extracted all GMA related kexts from the 10.6.2 update and installed them to my 10.8 install. Upon reboot I now have a 64-bit AppleIntelGMAX3100.kext and AppleIntelGMAX3100FB.kext recognized in System Profiler. Even with 64-bit kexts, I still don't have full graphics. Not sure what else is needed at this point...I thought it might have been a 32-bit graphics issue but apparently there's something else needed...

Share this post


Link to post
Share on other sites
I extracted all GMA related kexts from the 10.6.2 update and installed them to my 10.8 install. Upon reboot I now have a 64-bit AppleIntelGMAX3100.kext and AppleIntelGMAX3100FB.kext recognized in System Profiler. Even with 64-bit kexts, I still don't have full graphics. Not sure what else is needed at this point...

 

Did you also extract AppleIntelFramebuffer.kext?

 

I've been doing a little reading on getting ML running on older Macs. Just wondering if it's worth trying on my late 2006 MacBook (GMA950).

Share this post


Link to post
Share on other sites

Did you also extract AppleIntelFramebuffer.kext?

 

I've been doing a little reading on getting ML running on older Macs. Just wondering if it's worth trying on my late 2006 MacBook (GMA950).

 

No luck with the 10.6.2 AppleIntelFramebuffer.kext. I'll keep looking around.

Share this post


Link to post
Share on other sites

No luck with the 10.6.2 AppleIntelFramebuffer.kext. I'll keep looking around.

 

That would be rather odd that the Mac Pro dual Xeon would be unsupported while the mostly-identical *single Xeon* Mac Pro 3,1 (and those early Hacks based on the twin-by-birth of both sorts of XEON CPUs - the LGA775 Q6600) work with nary a quibble; however, the issue seems to relate more to graphics than anything else. (That is alos likely why - outside of niche uses - there is little interest in the Mac Pro; what could have truly been a powerful workstation contender got seriously undercut by a poor decision on graphics upgradability by Apple.)

 

I certainly can't fault even the early XEON CPU; after all, the more plebian and general-purpose Q6600 is what I am piloting today (in multiboot guise - it dual-boots Windows 8 Release Preview and Mountain Lion GM, in fact); still, it is rather embarrassing that these early Mac Pros are losing their edge "for want of a GPU".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×