Jump to content
InsanelyMac Forum

Kernel panic after installing/uninstalling failed custom DSDT.aml

Recommended Posts

THIS PROBLEM IS SOLVED ! post-559655-0-86313100-1329497552_thumb.pngAfter several successful builds, my current setup is in my signature. It was completely stable running 10.6.8 (with everything working except sleep and the XFX 5770 HDMI audio) until I decided to take the plunge and compile a custom DSDT so I could get the XFX 5770 HDMI audio working. I compiled a DSDT.aml (without the HDMI edits) installed it correctly on the internal system drive and rebooted. Kernel panic. So I removed it and rebooted. Kernel panic again. And again... I have included a snapshot of the problem. After 2 years of OSx86, this is the first time I have been stumped. For 3 days I have tried every remedy I could find here and on Google to no avail: permissions, kextcache rebuilding, replacing the indicated kexts, etc...I have an external USB drive with 10.6.8 (and the exact same extensions as the troubled system) that I use as a rescue drive. I can boot into it just fine. I sure don't want to re-install the OS, as my primary use of this system is for Logic Pro, Native Instruments Komplete 8, and many other music and graphic programs. I would have to re-install a whole lot of stuff. Fortunately all my projects and creations are safe on a 3rd HDD. HEELLPP !!! As soon as I fix this, I'm upgrading the chip to an X4 980...


Kernel extensions in backtrace (with dependencies) :


dependency: com.appl.iokit.IOACPIFamily(1.3.0)@0xffffff7f805f5000

dependency: com.appl.iokit.IOPCIFamily(2.6)@0xffffff7f805f9000

BSD process name corresponding to current thread: kernel_task


Kernel Version:

Darwin Kernel Version 10.8.0: Mon Jun 27 16:33:21 EDT 2011; legacy kernel v6 :xnu-1504.15.3/BUILD/obj/RELEASE_X86_64

System model name: MacPro3,1 (Mac-F42C88C8)

Share this post

Link to post
Share on other sites

Thanks for the reply LatinMcG, I tried the flags but I still get the exact same panic. And now after trying the flags you suggested, upon rebooting into my USB rescue HDD, the HDD at issue isn't on the desktop anymore (it would always mount before) and doesn't show up in Disk Utility anymore either. This kernel panic appears to be the same kernel panic one gets when they upgrade to 10.6.8 and are faced with the PCI config. issue that is fixed with the insertion of the AppleACPIPlatform.kext(1.3.5), the IOPCIFamily.kext(2.6), and the npci=0x2000 flag. As I related, the DSDT.aml has already been removed from the Extra folder. I am very inclined to think it is a cache or kernelcache issue. Here is my boot.plist in case it might help :


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">








<key>Kernel Flags</key>

<string>arch=i386 -force64 -v npci=0x2000</string>











Share this post

Link to post
Share on other sites

Hello! those flags are in my chameleon boot.plist already. I also have tried them at boot with no luck. But I think I'm on the right track now, I removed the HDD at issue and put it on a sata-usb adapter( boy do they come in handy sometimes ) and tried booting into it... and got a boot0: done, boot1: /boot_(flashing cursor) issue. I finally got it to mount on my other USB HDD's desktop, and saw that the i386 flag had been removed from the plist. I corrected that. Methinks the boot sectors are corrupt. I reinstalled chameleon. No luck. Used Kext Wizard. No luck. Tried Drive Genius. No luck. When I try to boot it using chameleon, it shows up in the boot screen, but when I boot it , screen goes black and it instantly reboots. I need to research how to fix the corrrupt boot sectors...any ideas?

Share this post

Link to post
Share on other sites

each os is on a separate drive. osx86 is hfs+. Windows 7 is ntfs. my windows 7 install is rarely used and is on a sata drive I plug into a swappable sata bay. It wasn't present at the time of the issue. I have never used dual boot on the same drive. chameleon handles them just fine.

Share this post

Link to post
Share on other sites

copy the whole os to another drive and install chameleon on it. i bet it boots.

i had same issue once. had to complete wipe (disk utility in setup partition. check advanced for GUID and repartitioned) drive and reimage then reinstall chameleon.


i tried fixing EFI hidden and was broken.

Share this post

Link to post
Share on other sites

I appreciate your input. I have been into PC's since Windoze 3 and Mac OS 7. I was one of the guys running OS X on a PPC 9600. There isn't much I haven't done - except DSDT ! I'm not a programmer, just an experienced user that likes to fiddle with the established ways of doing things. I already know how to do all of your last suggestion, but it is a last resort. I am pretty stubborn, and anyway, one never learns anything by taking the easy route. Anyways, as far as the issue at hand, what had been a boot1: /boot error is now a " boot0: GPT boot0: error ". I have always partitioned osx86 drives as GPT. I think I have found the problem, and I am in the middle of the remedy. Like I said , I rarely use WIN7. But now I think it is a combination of using MacDrive under Windows 7, and sharing the Mac HDD under Windows file sharing on my home network. When I shared the drive, it assumed the Windows HDD sharing icon and it's properties. And even though the WIN7 HDD wasn't present at the time, when I tried booting with the DSDT.aml I compiled, it really addled this computers brain. I know it has addled mine. Time for dinner and a shower. I'll keep you posted, and maybe someday someone else can benefit from this, the same as I have from sites like this many times before....

Share this post

Link to post
Share on other sites

:thumbsup_anim: yessssssssss!!! Problem solved ! Thanks to a shower, dinner, coffee, google, and being stubborn ! :moil: It turned out to be a two-step fix. The first and most important was CHIMERA !!! After installing CHIMERA, I was faced with a new hang: " boot0: done , boot1 /boot ". I googled it and came up with a guy that had problems with a HDD size limitation while booting to a 500GB USB 2.0 drive. So I put it in the swappable sata bay instead and VOILA ! I had never experienced this size limit issue before though. I know that CHIMERA was the significant fix. As I said earlier, nobody ever learns anything by taking the easy route. What I learned was 3 things: How to solve a problem like this , to ignore bad advice, and most importantly, that when I attempt to build a custom DSDT again, it will be on a separate HDD that ONLY contains the OS and isn't my primary/important HDD. Hallelujah!


And thanks for this GREAT community! I'm outta here to make some more music ! :guitar:


PS: In regards to the retort "pciroot 1 ??" and " -force64 ??" , I'm on an AMD, one would know that if they had read my signature. My boot.plist IS WHAT WORKS ON MY AMD !!!!

I am so glad I didn't take the advice of re-installing the OS and copying/re-installing 400GB of programs to another drive, or wiping the drive and doing a clean install and then having to re-install the 400GB of programs. One never learns anything from taking the easy route, or by taking bad advice.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.