Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ASUS P8H67-M PRO (B3), i5-2400, speedstep, GTS 450, DSDT

18 posts in this topic

Recommended Posts

Thanks. :)


Will try to improve this guide. I'm now using the latest chameleon trunk (Chameleon Wizard) seems to fix some things.

Also I removed the monitoring tools. No changes on kexts/dsdt for the moment, because that seems to work fine. :)


I hope to here more reports from users if there sleep is working correctly.

Share this post

Link to post
Share on other sites

works fine for me, even with p67 chipset.


my config:


ASUS P8P67-M PRO B3 (everything seems to work, including audio and ethernet // P67(!) )


Sapphire AMD RADEON HD6870 VAPOR-X (works OOB)

Intel Core i5 2310

OCZ Vertex 2 60 GB - Mac OS X Lion 10.7.3

WD Caviar Blue 1TB - Windows 7 Ultimate 64-bit

LG BH10LS30 Bluray-Drive


all of the above do work.


last thing i have to fix is the pci-e wlan card (ASUS,PCE-N13).

Share this post

Link to post
Share on other sites

just pasted it into extra.


this is my first hackintosh, so i have a really big problem, i really hope you can help.


when i move the cursor to finder for e.g., it lags horrible and is not switching to click- mode or dock doesnt zooms when moving over icons, even if i activated it in settings .i dont know whats wrong? maybe got any solutions?

Share this post

Link to post
Share on other sites

You should try to create a new DSDT file, see the link to the guide in the first post.

After patching, change the _PTS values again.


What GPU do you have? (You could also send me a PM instead)

Share this post

Link to post
Share on other sites

Updated the guide, let me know if it is working for you. :)


@centurka: hope that you are okey? Anyway.. are you using the latest Chameleon?

Share this post

Link to post
Share on other sites

hey beta992,

yea, i'm ok :D


#1 - my network card driver is 32 bit only and there were no 64 bit kext´s available, so i just bought a D-Link DWA-556 which is recognized as an airport card. works great!

#2 - i bought a magic trackpad in combination with a speed link vias nano bt stick, works OOB!

#3 - i use chimera 1.8 (latest), do you recommend chameleon?

#4 - bought 8 GB RAM Corsair XMS3 -1333MHz, special offer ,32,99 euro (germany:D) so now i use 16 GB RAM Corsair XMS3-1333 MHz

#5 - solved UI probs. i use a cyborg rat 7 which is really great. i reinstalled the (latest) driver 5 times for sure, but all this didn´t help. then i downloaded an alternative (USBOverdrive) driver, installed it, reboot, works.


so now i am done with building my hackintosh :D big thanks, screenshot´s will follow..

Share this post

Link to post
Share on other sites

Nice.. hope we see some screens soon. :)

Magic trackpad better than a Apple mouse?


I use Chameleon trunk and it is working well here. :)


Do you tried the new BIOS?

Share this post

Link to post
Share on other sites

hey beta992,


the magic trackpad is, umm... magic:D


well, my board uses a p67 chipset ---> latest driver 1004. works just fine.

i changed the design of my bootmanager from tonymac´s theme to a boot camp theme... looks more "clear" .

screens will follow.



Share this post

Link to post
Share on other sites

Hey Beta,

complete noob here! i keep getting KP after installing SL, im running:

asus p8h67-m pro 3604

sapphire radeon hd 6850


could you please explain what post-install steps you followed?

Share this post

Link to post
Share on other sites

hi beta922


stumbled across this forum because looking for P8H67-M-PRO (B3) DSDT file, tried yours above and the result is my lion 10.7.3 is losing the support for PS2 Keyboard and unable to shutdown because of asmedia USB3.0 is active (through PXHCD.kext).


before applied your DSDT, PS2 keyboard was working and shutdown work just with a problem that the PC will power on again after 2-3 secs off, so I thought by using your DSDT, will solve the problem.


any thought about this ?, do you have your onboard USB3.0 activated ?


my system is :


P8H67-M Pro (B3)



8Gb Memory

On board Graphics

chameleon boot



Thank you

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By onlyJRevenge
      Buonasera ragazzi,
      grazie all'aiuto di questo forum, sono riuscito qualche mese fa a configurare il mio portatile e ne sono pienamente soddisfatto. Ora mi è sorto un dubbio, per poter utilizzare la porta HDMI esterna per collegare il portatile ad un monitor cosa dovrei fare? Ho letto che c'è la possibilità che questo non possa essere possibile, per via del fatto che ho disabilitato la GTX950M e di conseguenza essa portava il segnale "all'esterno". A voi cosa risulta? Riuscireste a darmi una mano?
      Grazie anticipatamente.
    • By Pink Waters
      Hi guys, I have my dsdt.aml extracted from windows.
      I compiled just fine no errors, but when I try to add audio in it following this guide I get a lot of errors

      I am running High Sierra
      my audio is ALC889

      The errors are attached

    • By uzmi
      Para los usb 3 de mi placa uso un inyector USB_Series8_Injector.kext modificado para mis puertos.
      Deseo eliminar dicho inyector poniendo los datos de los puertos en el DSDT directamente pero no se si es posible ni como hacerlo.
      Tengo dos instalaciones en dos discos con 10.13.3 
      Uno con un DSDT basado en el que crea Clover y luego modificado para mi equipo.
      Otro con un DSDT basado en el de Pikeralpha y luego modificado para mi equipo
      ¿Podrían echarme una mano?
      Dejo el inyector o un SSDT-UIAC con los datos de los puertos.
      Muchas gracias.
    • By sect0r5
      Hello guys I need help for tuning my system for better working possibilities.
      What works:
      Sleep/Wake Audio Ethernet App Store  
      CS:GO not working (other Steam games are OK) Bad GPU performance 40 fps on OSX Cinebench vs 85 fps on Windows Cinebench Big audio latency when using line input      //edit : problem is gone  Slow start of Viber Desktop, OBS and some web pages  //edit : OBS is slow on native MacBook too Sometime random mouse freezings            Huge lags on latest NVidiaWeb drivers(158, 159) Sometimes can't awake and stuck on black screen after restart   //edit : now is alright. magic! Sometimes sound start crackling when watching online video     //edit  : magically gone edit : she come again  
      It's happens on a both Kernel's :
      Shanee 13.3.3
      Clover 4392
      What info i can provide for better results?
      With best regards, Stan.
      Send me stanMacs-Pro.zip