Jump to content

89 posts in this topic

Recommended Posts

well I found one that would work to get me to freeze on the appleserverworksata. The kernel that works is the mach_kernel.test7, but (I'm pretty sure) the modbin_kernel from the modcd gets me to stick at that same spot.

Share this post


Link to post
Share on other sites
Advertisement

I honestly can't think of why launchd is not executing...

 

Look up "AMD FX-4100 10.6.8" w/out the quotes and see what you come up with. Reduce the clock speed to normal if you haven't already (it's important).

Share this post


Link to post
Share on other sites

Mongo

 

Legacy Kernel 10.8.0 V2 is crucial to getting up to 10.6.8.

 

I haven't over-clocked since the K7 series of AMD, but, the highest hurdle to cross was the FSB getting too charged up for the PCI devices to operate properly, it's a pain trying to synchronize memory to a hot bus, so, things tend to get out of balance. Just when you think everything is smooth sailing, an oil tanker comes around and runs you over. I don't know if HT presents the same problems or not though.

 

I understand there have been some strides in the OC world though. Still, over powering the CPU core can present problems all its own.

 

From what I have gathered recently 'Cool'n'Quiet' could also be a problem for getting the hack running.

 

There are only a handful of 'Bulldozer' OSXers out there right now. If you get yours running after an update, you are way ahead. I'm not sure any of them are as far as you are now.

 

Good Work!

Share this post


Link to post
Share on other sites

Ok so I turned off the OC. turned off my custom pstates. back to 3.6 ghz. and HOLY DAMN OSX IS SLOW NOW!!!! It seriously dropped almost half on it's load speed. still no difference on being able to use the legacy kernel 10.8. Just restarts. I am wondering if it has anything to do with the CPU Instructions that my CPU has. Not only do I have sse and sse2 but I also have sse3 ssse3 sse4.1 & sse4.2

 

I don't know anything about that but from what I have gathered is AMD's don't support anything higher than sse2 and intel is sse3 and ssse3 all the way. So could this be part of why I can only use the modbin_kernel?

 

I know the bulldozer architecture is different then any other AMD cpu out there.

 

As for overclocking I didn't even have to change my voltage. I can change the multiplier in my bios and over clock to 4.7ghz without adjusting the voltage and no bugs. but it gets hot after 4.5ghz. This chip can be OC'd to 8Ghz. But I will never attempt that.

 

I also think my biggest problem is that my motherboard is a NB990FX and SB950

 

EDIT: I deleted both kexts for the AppleIntelCpuPower...whatever and it still shows right before it loads the desktop that

AppleIntelPower........ is incomplete or unsupported

Share this post


Link to post
Share on other sites

My Athlon 64x2 supports SSE3 while my Athlon 64 3200+ does not.

 

The GUI on the 3200+ is whacked and shows lines through anything shaped like an oval--like the search window has a line by the magnifier icon. Also, when using Cover Flow, the stock icons look like balloons with dirt smeared all over them. Weird.

 

I guess it's down to the SSE3 emulation not quite working right. Maybe my {censored} NV 6200--Dunno?

 

I still don't understand the conflict with the Legacy Kernel you're having.

Modbin never worked for my AMD's but legacy always worked like a charm.

Share this post


Link to post
Share on other sites

it does the same thing as every kernel except modbin. So there is something in that kernel that is not in any of the other ones. (sorry for being captain obvious) :)

Share this post


Link to post
Share on other sites

I never thought it was unusual for AMDs to have SSE3/SSSE3/SSE4? Particularly newer models?

 

Do you boot with arch=i386? I believe the legacy kernels only support 32-bit (i386). You can force a 64-bit userspace later, but try booting with arch=i386 and the legacy kernel and see if that makes a difference.

Share this post


Link to post
Share on other sites

ok booting with arch=i386 doesn't help, the only way I have found to not get it to reset is to use busratio=18 (cause my busratio is 18 at factory speed) and I get this KPpost-966952-0-70650500-1332603763_thumb.jpg

Share this post


Link to post
Share on other sites

Alright so time to update you guys.

 

First off I got the DVD to work by turning off combined ide mode in bios. Easy fix.

 

Updated to 10.6.8 with the modbin_kernel. Yes it does work past 10.6.4

 

Flashed my Asus 6770 Radeon to a 5770 and got qe/ci working, at least i have the translucent bar and front page and video doesn't crash now. Still only shows a ati 5000 for the card but oh well I'll do more research.

 

And I can boot off the HDD's just for some reason I have to switch what HDD boots in my bios cause the Mac HDD can't load win 7 and the disc can't fix it. and i can't load osx from the windows part.

Share this post


Link to post
Share on other sites

Whatever it shows for graphics is purely cosmetic. :)

 

Now are both OS'es on the same HDD?

Share this post


Link to post
Share on other sites

no, here is how I got it.

 

Hd 0,2 SL 10.6.8 stable

HD 0,3 SL 10.7.2 experimental. We trying.

Hd 1,2 Windows 7

Hd 1,3 Data Drive

Hd 1,4-6 Linux (cause it has 3 partitions)

HD 2,2 Windows 8

 

If I have the HD 0 which is my samsung set to boot I can run sl but when I try to boot windows it says I need to put in the windows install disc, so I try and it says it is not compatiable with this version.

If I put HD 1 as my boot, I can boot windows 7, 8 and linux, just not osx.

Share this post


Link to post
Share on other sites

Download EasyBCD on Windows 7 and add a Mac selection to the Windows Boot Loader.

Share this post


Link to post
Share on other sites

already have it, maybe I need to refresh it since I have mac booting from HDD

Share this post


Link to post
Share on other sites

Yeah, just make sure that you have EasyBCD pointing to the right drive. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By benmills1
      Hi, i can someone help me with installing mac OS Mojave on my HP ENVY - 15-as102na?
      I have an imac to use for setting up my usb & installing MacOS Mojave.There are various kext files etc that i'm not sure about and need some help as some are hardware specific.
      I tried previously but got stuck on an apple logo and couldn't get past that, and tried today and had problems with Clover.
      Once i get mac os on my 128gb m.2 ssd ( which i'll upgrade to either a 256gb or 512gb depending on how well this hackintosh works)
      I have a free 2.5" inch hdd bay where i'd like to install windows on in the future.
      I think i may have to replace my wireless card ( based on a few google results) which i'm fine with as long as i can see it working without just so i know i won't waste money
      Specs:
      Cpu: i5 7200u
      GPU: HD 620
      8GB ram
      Wifi card- Intel Wireless 7265 ( Intel® 802.11ac (2x2) )
      Motherboard - HP 81D2 & BIOS version is f.56
      https://support.hp.com/gb-en/document/c05311862
      Thanks
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/forum/download/file.php?id=25033
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
      There Is No Better Guide Then The One That @glasgood Has Already Written So Just Follow He's Guide For a Perfect Install.     
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • Coolermaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Z390 Pro DSDT EFI.zip   (Updated 21 July 2019)
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these extra DSDT's)
      If your using a Vega 56/64 or Radion VII then use this DSDT (already installed in my EFI)
      DSDT.VEGA.VII.zip
      If your using a RX Series or Nvidia GPU then use this DSDT
      DSDT.RXxxx.NVIDIA.zip
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      AirportBrcmFixup.kext    (If your Wifi Card isn't working after installing my EFI then add the AirportBrcmFixup.kext to your clover kext folder and reboot)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled  (Can be set to disabled depending on what GPU you use)
       
      • MIT → Advanced Memory Settings  → Extreme Memory Profile (X.M.P) → Enabled  
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Enabled  (can be enabled or disabled, your choice)
      • Chipset → Internal Graphics → Disabled
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → Platform Power Management → Enabled
      • Power → ErP → Enabled  (can be enabled or disabled, your choice)
      • Power → RC6 (Render Standby) → Disabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       

       

    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

×