Jump to content

89 posts in this topic

Recommended Posts

well I found one that would work to get me to freeze on the appleserverworksata. The kernel that works is the mach_kernel.test7, but (I'm pretty sure) the modbin_kernel from the modcd gets me to stick at that same spot.

Share this post


Link to post
Share on other sites
Advertisement

I honestly can't think of why launchd is not executing...

 

Look up "AMD FX-4100 10.6.8" w/out the quotes and see what you come up with. Reduce the clock speed to normal if you haven't already (it's important).

Share this post


Link to post
Share on other sites

Mongo

 

Legacy Kernel 10.8.0 V2 is crucial to getting up to 10.6.8.

 

I haven't over-clocked since the K7 series of AMD, but, the highest hurdle to cross was the FSB getting too charged up for the PCI devices to operate properly, it's a pain trying to synchronize memory to a hot bus, so, things tend to get out of balance. Just when you think everything is smooth sailing, an oil tanker comes around and runs you over. I don't know if HT presents the same problems or not though.

 

I understand there have been some strides in the OC world though. Still, over powering the CPU core can present problems all its own.

 

From what I have gathered recently 'Cool'n'Quiet' could also be a problem for getting the hack running.

 

There are only a handful of 'Bulldozer' OSXers out there right now. If you get yours running after an update, you are way ahead. I'm not sure any of them are as far as you are now.

 

Good Work!

Share this post


Link to post
Share on other sites

Ok so I turned off the OC. turned off my custom pstates. back to 3.6 ghz. and HOLY DAMN OSX IS SLOW NOW!!!! It seriously dropped almost half on it's load speed. still no difference on being able to use the legacy kernel 10.8. Just restarts. I am wondering if it has anything to do with the CPU Instructions that my CPU has. Not only do I have sse and sse2 but I also have sse3 ssse3 sse4.1 & sse4.2

 

I don't know anything about that but from what I have gathered is AMD's don't support anything higher than sse2 and intel is sse3 and ssse3 all the way. So could this be part of why I can only use the modbin_kernel?

 

I know the bulldozer architecture is different then any other AMD cpu out there.

 

As for overclocking I didn't even have to change my voltage. I can change the multiplier in my bios and over clock to 4.7ghz without adjusting the voltage and no bugs. but it gets hot after 4.5ghz. This chip can be OC'd to 8Ghz. But I will never attempt that.

 

I also think my biggest problem is that my motherboard is a NB990FX and SB950

 

EDIT: I deleted both kexts for the AppleIntelCpuPower...whatever and it still shows right before it loads the desktop that

AppleIntelPower........ is incomplete or unsupported

Share this post


Link to post
Share on other sites

My Athlon 64x2 supports SSE3 while my Athlon 64 3200+ does not.

 

The GUI on the 3200+ is whacked and shows lines through anything shaped like an oval--like the search window has a line by the magnifier icon. Also, when using Cover Flow, the stock icons look like balloons with dirt smeared all over them. Weird.

 

I guess it's down to the SSE3 emulation not quite working right. Maybe my {censored} NV 6200--Dunno?

 

I still don't understand the conflict with the Legacy Kernel you're having.

Modbin never worked for my AMD's but legacy always worked like a charm.

Share this post


Link to post
Share on other sites

it does the same thing as every kernel except modbin. So there is something in that kernel that is not in any of the other ones. (sorry for being captain obvious) :)

Share this post


Link to post
Share on other sites

I never thought it was unusual for AMDs to have SSE3/SSSE3/SSE4? Particularly newer models?

 

Do you boot with arch=i386? I believe the legacy kernels only support 32-bit (i386). You can force a 64-bit userspace later, but try booting with arch=i386 and the legacy kernel and see if that makes a difference.

Share this post


Link to post
Share on other sites

ok booting with arch=i386 doesn't help, the only way I have found to not get it to reset is to use busratio=18 (cause my busratio is 18 at factory speed) and I get this KPpost-966952-0-70650500-1332603763_thumb.jpg

Share this post


Link to post
Share on other sites

Alright so time to update you guys.

 

First off I got the DVD to work by turning off combined ide mode in bios. Easy fix.

 

Updated to 10.6.8 with the modbin_kernel. Yes it does work past 10.6.4

 

Flashed my Asus 6770 Radeon to a 5770 and got qe/ci working, at least i have the translucent bar and front page and video doesn't crash now. Still only shows a ati 5000 for the card but oh well I'll do more research.

 

And I can boot off the HDD's just for some reason I have to switch what HDD boots in my bios cause the Mac HDD can't load win 7 and the disc can't fix it. and i can't load osx from the windows part.

Share this post


Link to post
Share on other sites

Whatever it shows for graphics is purely cosmetic. :)

 

Now are both OS'es on the same HDD?

Share this post


Link to post
Share on other sites

no, here is how I got it.

 

Hd 0,2 SL 10.6.8 stable

HD 0,3 SL 10.7.2 experimental. We trying.

Hd 1,2 Windows 7

Hd 1,3 Data Drive

Hd 1,4-6 Linux (cause it has 3 partitions)

HD 2,2 Windows 8

 

If I have the HD 0 which is my samsung set to boot I can run sl but when I try to boot windows it says I need to put in the windows install disc, so I try and it says it is not compatiable with this version.

If I put HD 1 as my boot, I can boot windows 7, 8 and linux, just not osx.

Share this post


Link to post
Share on other sites

Download EasyBCD on Windows 7 and add a Mac selection to the Windows Boot Loader.

Share this post


Link to post
Share on other sites

already have it, maybe I need to refresh it since I have mac booting from HDD

Share this post


Link to post
Share on other sites

Yeah, just make sure that you have EasyBCD pointing to the right drive. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gusbemacbe
      Hello,
       
      I am a former user of MacBook and Mac mini. Both died. One in 2014 and another last year.  I will think of giving my Hackintosh-compatible laptop to my brother that I purchased years ago, because he wants to play more than one computer, so he is a Twitch/YouTube streamer and a hardcore gamer and I will not need to lend him many times. If he wants, from my former laptop I will take only one 240GB SSD Samsung Evo with installed Arch Linux and leave one 500GB HDD for him. In the future, I will purchase a new Alienware laptop.
       
      As I got newly graduated, I moved to a new super PC with AMD Ryzen™ 7 2700X CPU and with NVIDIA GeForce™ 1660 Ti GPU. More details, you can see my signature below, that provides the complete details. I own an external SSD m.2 2280 with installed Windows 10.
       
      I will reconsider purchasing 4th drive – an external 480GB SSD m.2 2280 SATA WD Green 545MB/s or an external 1TB SSD SATA WD Green 545MB/s – for installing Hackintosh. But purchasing, I need to make sure.
       
      1. Is it worth to install Hackintosh on an external SSD m.2 2280? If I partition two partitions, one for Insansely's MyHack/Chameleon/Clover and another for Hackintosh and my new super-PC boot is natively BIOS and Grub, is it worth? Maybe I will try to install reFind on Arch Linux to replace the Grub if it is worth.
      2. I know that it will run on macOS High Sierra, Mojave and Catalina, but if I need Metal 2 to run the latest version of Sketch (the which I own an original licence) and of other apps the which I own original licences? Is NVIDIA GeForce™ 1660 Ti compatible with Metal 2?
      3. Since it be an external SSD, will I able to run Hackintosh as a portable OS in other computers?
       
       
    • By gusbemacbe
      Olá,
       
      Eu sou um ex-usuário do último computador da Apple – Mac mini – que faleceu no ano passado.
       
      Pensarei em dar meu computador portátil compatível com Hackintosh ao meu irmão que comprei anos atrás (em referência ao tópico «Sou novo ao fórum, já fui um usuário de Hackintosh e ainda pretendo montá-lo», porque ele quer jogar mais de um computador, pois ele é um streamer de Twitch e YouTube e um jogador hardcore, e não precisarei ficando emprestando-lhe muitas vezes.
      Se ele quiser, do meu antigo computador portátil, pegarei apenas um SSD Samsung Evo 860 de 240GB com o Arch Linux instalado e deixarei um HD de 500 GB para ele. No futuro, comprarei um novo laptop Alienware.
       
      Como me formei no início deste ano, mudei-me para um novo supercomputador cujo processador é AMD Ryzen™ 7 2700X e cuja placa de vídeo NVIDIA GeForce ™ 1660 Ti. Há mais detalhes que posso fornecer-lhes na minha assinatura abaixo. Possuo um SSD m.2 2280 externo com o Windows 10 instalado.
       
      Reconsiderarei a compra da quarta unidade – um externo SSD m.2 2280 SATA de 480GB 545MB/s da marca WD Green ou um externo normal SSD SATA de 1TB 545MB/s da marca WD Green – para instalar o Hackintosh. Mas antes de comprá-lo, preciso ter certeza.
       
      1. Vale a pena instalar o Hackintosh num SSD m.2 2280 externo? Se eu criar duas partições, uma para o MyHack/Chameleon/Clover do InsanelyMac e outra para o Hackintosh, e a inicialização do meu supercomputador é nativamente BIOS e Grub, vale a pena? Talvez eu tente instalar o reFind no Arch Linux para substituir o Grub, se valer a pena.
      2. Sei que macOS High Sierra, Mojave e Catalina funciona com o processador AMD Ryzen™, mas se eu precisar do Metal 2 para executar a versão mais recente do Sketch (a qual eu possuo uma licença original) e de outros aplicativos cujos possuo as licenças originais? O NVIDIA GeForce™ 1660 Ti é compatível com o Metal 2?
      3. Como é um SSD externo, poderei executar o Hackintosh como um sistema operativo portátil noutros computadores?
    • By Slice
      As I see many novices in the forum ask "How to make my Radeon working? I have bad resolution, no QE/CI...." and so on. They come to the section and have no find an answer here because all Radeons are different and they don't know where else they read about this.
      I want to explain all steps needed for launching the Radeon family of videocards.
       
      Bootloader.
      I will speak about Clover because I maintain this bootloader to know recent hardware and modern OSX. Not sure if you will have the same result with other bootloaders. I am carefully checking the injecting of ATI card and correcting it times to times. I am also accessible for bug reports.
       
      OSX version.
      Older card require older system, newer cards require new system.
      ATIRadeon9000 is possible to launch under Tiger.
      ATIRadeonMobilityX1400 requires 10.5-10.6. See RadeonHD topic.
      As I see RadeonHD3xxx was successful only in 10.5
      For new AMDRadeonHD7xxx there must be 10.8.3+ system.
       
      DeviceID.
      This must be the first question before asking about the card.
      You may know the device-id from Windows->DeviceManger->VideoCard.properties->compatibleIDs
      You may boot into system in safe mode (key -x) and see system profiler
       
      And you may boot into Clover GUI, press F2 and get preboot.log. Find here something like
      2:709 0:000 PCI (00|01:00.00) : 1002 6758 class=030000 2:709 0:000 Found Radeon model=AMD Radeon HD 6670 Series It means my DeviceID=6758 (these are hex numbers)
      Then you must check that Apple's drivers support your DeviceID. If not then add it!
      For example HD7850 has DeviceID=6819. If we look into ATI7000Controller (AMD7000... in new systems) we find 6818 here but no 6819!
       
       
      I show you how to do this with terminal commands. Launch /Application/Utilities/Terminal.app. Type in opened window:
       
      cp /System/Library/Extensions/ATI7000Controller.kext/Contents/Info.plist ~/Desktop So you get a copy of the Info.plist on Desktop. Edit it with TextEdit. Change 68181002 -> 68191002.
      Don't edit this file directly in the system folder! 
      Then copy back by terminal. Don't use finder to copy kexts! They will have wrong permissions in this case.
      sudo cp ~/Desktop/Info.plist /System/Library/Extensions/ATI7000Controller.kext/Contents/ sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/* Second command make sure next reboot the kext will use your edited info.plist.
      The same operation you must do with a kext AMDRadeonAccelerator or ATIRadeonX2000 or other one. Check all candidates if they contain such list of possible IDs and choose closest to you.
       
      FakeID
      Since Clover revision 1971+ you may just inject new DeviceID into DSDT instead of correcting kexts. See instruction here.
       
      GraphicsEnabler or Injector
      OSX needs to know some properties (Model name, Family, etc...) that must be somehow injected at boot time. Yes, also real Macs got DeviceProperties string from firmware.
      Alternatives:
      1. Set InjectATI=Yes in Clover (same as GE=y in Chameleon).
      2. Use custom string made with gfxutil. For whom who knows.
      3. Write _DSM into DSDT. You should know what to write.
      4. Use some kext like ATY_init.kext or Natit.kext. If you are sure that the kext is for your card namely.
      I want to say that all this methods make the same thing. Differencies in their tuning.
      The Clover do this automatically for most known cards at this moment.
       
      Connectors.
      As you may see to start HD5000-7000 some strange names used: Pithecia, Orangutan, Elodea... What are they?
      They are configs for framebuffer. Predefined configs how connectors are solded for cards used in real Macs. Strange but these configs rear coincide with PC card. Usually gurus make advice "choose a framebuffer that most appropriate for your card". The chances 1:10. In most cases you may find a FB name that gives you main monitor working. Or nothing at all.
      Great respect to bcc9 who gives us a method to correct one of config to be exactly for you. See here.
      My retelling for Clover is here
      Success example in the thread in posts 44-52
       
      Radeon Mobility
      I tested Clover's methods with two users having Mobility Radeon HD5470 and HD5650M. We found that full memory and QE/CI will be achieved if we set in Clover's config
      LoadVBios=Yes
      even thou no file with bios is provided. This is the key to make Radeon Mobility working!
      Other problem is bad gradients or artifacts. For this case Clover accept the key
      InjectEDID=Yes
      and sometimes you also need to inject CustomEDID.
      See Clover instructions for details.
       
      And my results.
      Gigabyte Radeon HD6670
      <key>Graphics</key> <dict> <key>GraphicsInjector</key> <true/> <key>InjectEDID</key> <true/> <key>FBName</key> <string>Ipomoea</string> <key>LoadVBios</key> <false/> <key>VideoPorts</key> <integer>3</integer> <key>PatchVBios</key> <true/> </dict> <key>KernelAndKextPatches</key> <dict> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>6000</string> <key>ATIConnectorsData</key> <string>000400000403000000010000120401050008000004020000000100001102040310000000100000000001000000000002</string> <key>ATIConnectorsPatch</key> <string>040000000403000000010000100001061000000010000000000100000000000100080000040200000001000012040403</string> VTX Radeon HD5570
      <key>Graphics</key> <dict> <key>PatchVBios</key> <false/> <key>FBName</key> <string>Baboon</string> <key>VideoPorts</key> <string>3</string> <key>GraphicsInjector</key> <string>Yes</string> <key>LoadVBios</key> <string>No</string> </dict> <key>KernelAndKextPatches</key> <dict> <key>Debug</key> <false/> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>5000</string> <key>ATIConnectorsData</key> <string>040000001400000000010000010201030008000000020000007100002205020110000000100000000001000000100002</string> <key>AppleRTC</key> <true/> <key>ATIConnectorsPatch</key> <string>040000001400000000010000010001040008000000020000007100002200020510000000100000000001000000000002</string> <key>AsusAICPUPM</key> <false/> <key>KextsToPatch</key> <array> <dict> <key>Name</key> <string>AppleAHCIPort</string> <key>Find</key> <data>RXh0ZXJuYWw=</data> <key>Replace</key> <data>SW50ZXJuYWw=</data> </dict> </array> </dict> See PatchVBios=No
      for this card "yes" leads to black screen. Use with precautions.
       
      A sample for Radeon R7 240
       
      UPDATE for ElCapitan.
      It seems has more problems. My HD6670 is not working in ElCapitan OOB unlike Mavericks.
      I had to set FakeID=0x67401002 as correspond to real iMac12,2 and set this model in SMBIOS section.
      It related to GraphicsPM or GraphicsControl.
      Look these kexts to decide what you can do for your configuration.
       
      HighSierra requires change these kexts by version from Sierra 10.12.6
      for Radeon HD6xxx
      AMDRadeonX3000.kext AMDRadeonX3000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .  for Radeon HD7xxx and up AMDRadeonX4000.kext AMDRadeonX4000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .    Black screen after wake problem resolved by follow method radeon_bios_decode.0.2.zip
      ati-personality.pl.0.15.zip
      ati-personality.pl.0.15a.zip
    • By ricardos7
      Preciso de ajuda para terminar um meu hackintosh, alguém poderia me ajudar?
       
      Boa tarde a todos, gostaria de ajuda com o meu hackintosh, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador
      Modelo: Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck 

      Dell Wireless 1705 WiFi
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
      Os problemas que encontrei ate agora foram.
      O que não funciona?
      WIFI
      AUDIO
      BRILHO DA TELA
      BLUETOOTH
      GERENCIAMENTO DE ENERGIA NAO SEI COMO SABER SE FUNCIONA
      GRAFICOS DEDICADOS NVIDEA 930M
       
       
      O QUE FUNCIONA?
      GRAFICOS INTEL
      TECLADO
      TRACKPAD
      TECLAS FN
      PLACA DE REDE
       
      AS DSDT E AS SSDT?
      Nao sei como fazer para esse modelo mais ja extrai as originais mais nao sei quais arquivos usar e quais pachs ativar,
      alguém poderia me ajudar a terminar esse hack por favor. Desde ja obrigado.




    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.1
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&amp;t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
×