Jump to content

89 posts in this topic

Recommended Posts

Ok I've been trying this for a few days. tried a few different distro's. hazard went the farthest, with booting -x -v I can get most of the hfs+ files to load through chameleon but it errors on the tmsafetynet.kext, pauses 5 seconds, displays:

ACPI table not found. Dsdt.aml

No DsDt found, using 0 as uid value

Using PCI-root-uid value:0

No SMbios replacement

Patched DMI table

found SMbios system information Table 1

customizing systemID with 002-003-004-005-006007008009

efi_inject_get_devprp_string NULL trying stringdata

 

post-966952-0-56898200-1329761048_thumb.jpg

 

 

Then it has another ACPI and reboots.

 

System is Fx-4100 cpu, ta990fxe mb, radeon hd 6770 gpu, 8 gig corsair 1600 dual channel ram, seagate 250 gig sata 6.0gbs hdd.

 

Please help a brother out

Share this post


Link to post
Share on other sites
Advertisement

Here are shots from cpu-z......could it possibly have anything to do with the bulldozer architecture supporting sse3 as intel chips do. The hazard distro i'm using only seems to have Mach_kernel.

post-966952-0-82228500-1329439900_thumb.png

post-966952-0-92554200-1329439974_thumb.png

post-966952-0-28608500-1329440018_thumb.png

Share this post


Link to post
Share on other sites

Ok well after a lot more looking and playing with downloads. I got osx 10.5 to run through vmware. I hooked up my physical disk and formatted it into the mac os Journled format. Now I'm gonna try to get the retail version to restore to the drive and then patch the amd kernel over since I can now do the patching through leopard.

 

If anyone has some advice on what steps I should take I would greatly appreciate it.

Share this post


Link to post
Share on other sites

Ok so after all the different distros I have tried, the only thing I can get to run is 10.5.5 leopard in vmware workstation. I have been able to use the virtual machine to partition my drive to an hfsj and been able to load the iosx86 10.5.6 onto the partition through my virtual machine but I don't seem to be able to boot it anyway.

 

Anytime I try to boot my comp with one of the distro cd's i get a kernel panic.

 

Can anyone out there give me a point in the right direction?

Share this post


Link to post
Share on other sites

Try using a 10.6.3 Snow Leopard retail disk with Nawcom's ModCD.

This will give you a 'vanilla' (un-bastardised) install. This will be much easier to support as we know what goes on during the install.

By using a distro like Hazard you are at the whim of the authors as to which kexts are patched/installed and to where.

 

A distro may look like the easy option but I promise you it is not.

There is a very steep learing curve with OS X 86 and this is where most seem to be put off. But if you stick with it, read as much as you can and don't be affraid to experiment, you should get there eventually.

Share this post


Link to post
Share on other sites

thank you, I kinda got dismayed with the lack of help in the osx86 community. I am not new to computers at all but mac I am, so trying to piece together how to write everything I need gets discouraging.

 

I now have the SL retail install on a Usb and I'm going to go from there, looks like next step is to setup a linux live enviro so I can work my dsdt.aml file there. Any pointers are greatly appreciated as always.

Share this post


Link to post
Share on other sites

If you want to move the modbin kernel over to your installation, boot with the ModCD into SL, locate the ModCD and open the image Preboot.dmg. Inside Preboot, there is an Extra folder; that folder contains the modbin kernel. Simply drag the kernel onto the root of your hard drive. :) Now, to make Chameleon boot the modbin kernel automatically, open Terminal (/Applications/Utilites) and type:

 

sudo nano /Extra/com.apple.boot.plist

 

Locate the following:

<key>Kernel</key>
<string>legacy_kernel</string>

and change it to:

<key>Kernel</key>
<string>modbin_kernel</string>

And now you can boot from your HDD. :)

Share this post


Link to post
Share on other sites

I already tried taking the modbin_kernel.test7 and sticking it in the root directory of my mac drive, since I cannot get osx to boot after a successful install, I can't edit anything this way. I was able however to edit the com.apple.boot.plist in win7 and edit that string so it would load the modbin kernel. Now whether I use the osx86 mod cd, or I boot directly from the mac (it brings up chameleon when I pick mac on my boot list) it runs through the text and hangs at.

 

AppleServerworksATA: IXP700 (cmd 0x1f0, ctr 0x3f4, IRQ 14, BM 0xf000)

USBF 7.688 AppleUSBOHCI [0x421b800] Check sleep capability controller will be unloaded across sleep.

 

When I throw in the -x command it runs through the kexts and then runs the white lines again, this time it will pass this one line but the next line it gets stuck on is the

 

ERROR: Firewire unable to determine security-mide: defaulting to full-secure

 

 

And it just sits, and sits, and sits,.....then it sits some more.....thinks about doing something else.....doesn't....it just sits there........

 

the only way I have access to anything for mac is when I boot the Install USB, I then can use terminal but it doesn't seem to work like it should........maybe I'm doing something wrong........

Share this post


Link to post
Share on other sites

PROGRESS!!!!!!!

 

 

Ok I got vmware workstation 8 and found a working image of 10.5.5 from Xelabos. But I can access my mac drive and run certain things. Now I know that I can't pull files through the virtual machine, but since I can pull them in linux for example and I can edit them in the virtual machine, what do I do now?

Share this post


Link to post
Share on other sites

I need to know if I understand you correctly.

 

You now have 10.5.5 on the workstation? If so, do you also have an install on a separate drive; USB shell, or a key drive?

 

If you have enough space on your host drive, then, you are good to go for a fresh install from either SL or Lion at this point. Do you have cloning tools?

 

You can do everything you need such as patches and file moves straight from your VM. No need for linux or windows at this point. It will be a bit sluggish but the job will get done just the same.

Share this post


Link to post
Share on other sites

Keep in mind that if you move a kernel extension to (or make modifications to anything in) /System/Library/Extensions it will not load, because it will not have the proper permissions and ownership.

 

If you do that you'll have to set permissions and ownership correctly first before trying to boot, you can do that via Terminal.app from your virtual machine or your USB installer.

 

Note that Chameleon doesn't care about permissions or ownership, so any kernel extensions you place in /Extra/Extensions will work without having to do anything else. Some kernel extensions (mainly those with lots of dependencies) will not work from /E/E at all though.

 

Also:

 

The screenshot in your first post shows normal verbose output from Chameleon, this is from before the kernel loads and OS X starts to boot. There's nothing out of the ordinary there. Apparently you have no DSDT.aml and no smbios.plist but that's not necessarily a problem. DSDT override is mostly used on Intel platforms that are closer to Apple hardware and can run the vanilla kernel, smbios.plist is where you set which mac model you want your hack to appear to the OS as, but smbios.plist is not necessary in order to boot, Chameleon has some smbios defaults built-in which will be used when there's no smbios.plist in /extra. Google/Forum search smbios.plist for more information.

 

Neither "USB bla bla unloaded across sleep" nor "Firewire bla bla full security mode" mean anything in relation to the boot process, it is not stopping because of any of those messages. As an experiment you can try disabling Firewire in the BIOS, I can guarantee that it will halt at the same place.

Share this post


Link to post
Share on other sites

Gringo: I did try to disable firewire and same thing, On one boot it actually said waiting for root device. but the rest it just freezes. I just tried copying the ata kexts from the install dvd to the hard drive through terminal and that didn't seem to help either.

 

Zoot: Yes I have 10.5.5 installed through vmware 8.0.1. I cant seem to get the permission to access a physical drive though. I keep getting an error and I have been trying to work around that so no dice on editing any files through the virtual machine.

 

As for the installs I have 3 HDDs. My main is a 1.5tb WD I have that in 3 partations, 1 for win 7, 1 for data files, 1 for ubuntu. the second drive is a seagate 250gb that has win 8 on it, and the 3rd is a samsung 200gb that I have 1 partition for mac osx.

 

My SL install is on a 8gb usb.

 

Did I answer all your questions?

 

Edit: Whatever device it is sticking on, the numbers may flucuate but the IRQ address is alway 14. How do I find out what this is?

 

This is where it sticks, this is even after copying the ata kexts. and I must us the command rd(0,0)/extra/modbin_kernel or anything else reboots

 

post-966952-0-60144200-1332016700_thumb.jpg

 

FYI to copy the kexts I loaded the boot usb and used terminal and used :

cp -pr /Volumes/Snow/System/Library/Extensions/*ATA* /Volumes/Mac/System/Library/Extensions/
chown -R root:wheel /Volumes/Mac/System/Library/Extensions/*ATA*
chmod -R 775 /Volumes/Mac/System/Library/Extensions/*ATA*
rm -rf /Volumes/Mac/System/Library/Extensions.*

then rebooted with -f

Share this post


Link to post
Share on other sites

ok after doing some digging I see what is causing my issue, just not sure how to fix yet. The appleserverworksATA is trying to access my IDE ATA/ATAPI controllers. That has the IRQ of 14 and that seems to be responsible for the hang up. Seems to have to do with the SB controller. Since, in the pic u can see that it is ixp700, giving this issue, it has something to do with the sb700 support on my MB. now my board will go up to 950SB so any ideas on how to correct this so I get rid of my hang?

Share this post


Link to post
Share on other sites

After playing around with the bios settings and my sata control I notice I have 4 options to choose from, native ide, raid, ahci, legacy ide. Now on ahci it sticks on the appleseverworksata, under legacy ide it makes it past the appleserverworksata but the next line in ATI ATA and it sticks there, same on native ide, and didn't even bother with raid mode, also it will allow me to enable or disable combined ide, with legacy ide and combined ide disabled, my cdrom does not load.

 

Also a side note, now when I was just playing somehow instead of my boot menu from BCD that gives me win 7, win 8, ubuntu, and osx option has now been replaced with the chameleon bootloader and I have to select my win 7 drive to get back to my main bootloader. What would cause that? I was just playing with the sata controls in bios?

Share this post


Link to post
Share on other sites

Success!!!!! IT BOOTED!!!!!!!!!!!!

 

 

Ok so what I had to do.......The good, the bad, and the dirty.

 

Reloaded the install usb, deselected every option on the customize screen except under chipset. I did not pick the atiata that it auto selected, it was the one down on the list for ati. After successful install, did not restart, opened terminal, copied all the kexts from the install usb, gave permission, rebooted modcd, typed rd(0,0)/extra/modbin -v -f. SUCCESS!!!!!!!!!!!!

 

 

 

now I just gotta get everything else working.....but I got it to boot :)

Share this post


Link to post
Share on other sites

Well, great job!! :D

 

Something to note: if you are planning on updating to 10.6.5 or later, you will have to update your kernel.

Share this post


Link to post
Share on other sites

yes I noticed, em messed up the working copy...

 

So what I did for experimenting is I reformatted my hd for mac with 2 parts. One for the reg install of SL, the one I'm typing on again, and one so I can install SL onto that and try to update it.

 

So this way hopefully I won't have to keep reloading on trial and error.

 

Also I can't seem to locate my cdrom now on the mac, I of course have to use it to boot with the modcd but it doesn't show in SL.

and when I try to boot my mac osx partition from my regular bootloader it gives me a chain boot error.

Share this post


Link to post
Share on other sites

well I had the iso for the modcd so I pulled the modbin kernel out of there, put it in the root, sudo nano'ed to death and then when I try to boot without the cd it gives me a cpu halt.....hmm

Share this post


Link to post
Share on other sites

sudo nano'ed? You edited some kexts? :P

 

CPU halt...hm? Boot with the ModCD, download the latest Chameleon package via Chameleon Wizard (click the Buildbot tab, then click the little package beside the Chameleon build) and run the pkg. See if that helps.

Share this post


Link to post
Share on other sites

Have you tried Virtual Box? Try that out as it seems you have plenty of drive space. It is more supportive of USB peripherals than VMWare. Mounting an external drive is no problem under the VB environment. VB is also a tad faster.

Share this post


Link to post
Share on other sites

Pookymacman: well it definetely gave me a new symptom, now it freezes on powermanagement :(

 

Zoot: I gave up on VM since I just got it working on the HDD, just gotta boot with modcd everytime.

Share this post


Link to post
Share on other sites

Well, your situation is different, but, I was able to take my external drive to my PPC (Leopard Universal 10.5.8). I mounted OSX86ModCD on the desk top, mounted my SL 10.6.8 drive, then, I opened Tinker Tool to show all files. I installed ChameleonRC3PCEFI10.5. to my SL drive using Pacifist. I went to the ModCD and took the entire Extra folder and dragged it to SL /. with Administrative Privilege, then, I opened the usr folder from ModCD and replaced the i386 in the usr on the SL drive.

 

After all that I plugged into my notebook and booted without the ModCD; that would be because I esentialy have the CD on my SL root now. I can boot on any machine in my house with this method. Once on the desk-top I repair permissions with Kext Utility.

 

I have different images of pre boot configured for each machine to make swapping easy.

 

Change this: <string>-v maxmem=2048 cpus=1 arch=i386</string>

to: <string> maxmem=(whatever you have and what is supported) cpus=1 arch=i386</string> from pre-boot com.appleBoot.plist

Then you'll get the Apple Spinner before you reach the desk-top.

 

It is all a grand experiment so results may vary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gusbemacbe
      Hello,
       
      I am a former user of MacBook and Mac mini. Both died. One in 2014 and another last year.  I will think of giving my Hackintosh-compatible laptop to my brother that I purchased years ago, because he wants to play more than one computer, so he is a Twitch/YouTube streamer and a hardcore gamer and I will not need to lend him many times. If he wants, from my former laptop I will take only one 240GB SSD Samsung Evo with installed Arch Linux and leave one 500GB HDD for him. In the future, I will purchase a new Alienware laptop.
       
      As I got newly graduated, I moved to a new super PC with AMD Ryzen™ 7 2700X CPU and with NVIDIA GeForce™ 1660 Ti GPU. More details, you can see my signature below, that provides the complete details. I own an external SSD m.2 2280 with installed Windows 10.
       
      I will reconsider purchasing 4th drive – an external 480GB SSD m.2 2280 SATA WD Green 545MB/s or an external 1TB SSD SATA WD Green 545MB/s – for installing Hackintosh. But purchasing, I need to make sure.
       
      1. Is it worth to install Hackintosh on an external SSD m.2 2280? If I partition two partitions, one for Insansely's MyHack/Chameleon/Clover and another for Hackintosh and my new super-PC boot is natively BIOS and Grub, is it worth? Maybe I will try to install reFind on Arch Linux to replace the Grub if it is worth.
      2. I know that it will run on macOS High Sierra, Mojave and Catalina, but if I need Metal 2 to run the latest version of Sketch (the which I own an original licence) and of other apps the which I own original licences? Is NVIDIA GeForce™ 1660 Ti compatible with Metal 2?
      3. Since it be an external SSD, will I able to run Hackintosh as a portable OS in other computers?
       
       
    • By gusbemacbe
      Olá,
       
      Eu sou um ex-usuário do último computador da Apple – Mac mini – que faleceu no ano passado.
       
      Pensarei em dar meu computador portátil compatível com Hackintosh ao meu irmão que comprei anos atrás (em referência ao tópico «Sou novo ao fórum, já fui um usuário de Hackintosh e ainda pretendo montá-lo», porque ele quer jogar mais de um computador, pois ele é um streamer de Twitch e YouTube e um jogador hardcore, e não precisarei ficando emprestando-lhe muitas vezes.
      Se ele quiser, do meu antigo computador portátil, pegarei apenas um SSD Samsung Evo 860 de 240GB com o Arch Linux instalado e deixarei um HD de 500 GB para ele. No futuro, comprarei um novo laptop Alienware.
       
      Como me formei no início deste ano, mudei-me para um novo supercomputador cujo processador é AMD Ryzen™ 7 2700X e cuja placa de vídeo NVIDIA GeForce ™ 1660 Ti. Há mais detalhes que posso fornecer-lhes na minha assinatura abaixo. Possuo um SSD m.2 2280 externo com o Windows 10 instalado.
       
      Reconsiderarei a compra da quarta unidade – um externo SSD m.2 2280 SATA de 480GB 545MB/s da marca WD Green ou um externo normal SSD SATA de 1TB 545MB/s da marca WD Green – para instalar o Hackintosh. Mas antes de comprá-lo, preciso ter certeza.
       
      1. Vale a pena instalar o Hackintosh num SSD m.2 2280 externo? Se eu criar duas partições, uma para o MyHack/Chameleon/Clover do InsanelyMac e outra para o Hackintosh, e a inicialização do meu supercomputador é nativamente BIOS e Grub, vale a pena? Talvez eu tente instalar o reFind no Arch Linux para substituir o Grub, se valer a pena.
      2. Sei que macOS High Sierra, Mojave e Catalina funciona com o processador AMD Ryzen™, mas se eu precisar do Metal 2 para executar a versão mais recente do Sketch (a qual eu possuo uma licença original) e de outros aplicativos cujos possuo as licenças originais? O NVIDIA GeForce™ 1660 Ti é compatível com o Metal 2?
      3. Como é um SSD externo, poderei executar o Hackintosh como um sistema operativo portátil noutros computadores?
    • By Slice
      As I see many novices in the forum ask "How to make my Radeon working? I have bad resolution, no QE/CI...." and so on. They come to the section and have no find an answer here because all Radeons are different and they don't know where else they read about this.
      I want to explain all steps needed for launching the Radeon family of videocards.
       
      Bootloader.
      I will speak about Clover because I maintain this bootloader to know recent hardware and modern OSX. Not sure if you will have the same result with other bootloaders. I am carefully checking the injecting of ATI card and correcting it times to times. I am also accessible for bug reports.
       
      OSX version.
      Older card require older system, newer cards require new system.
      ATIRadeon9000 is possible to launch under Tiger.
      ATIRadeonMobilityX1400 requires 10.5-10.6. See RadeonHD topic.
      As I see RadeonHD3xxx was successful only in 10.5
      For new AMDRadeonHD7xxx there must be 10.8.3+ system.
       
      DeviceID.
      This must be the first question before asking about the card.
      You may know the device-id from Windows->DeviceManger->VideoCard.properties->compatibleIDs
      You may boot into system in safe mode (key -x) and see system profiler
       
      And you may boot into Clover GUI, press F2 and get preboot.log. Find here something like
      2:709 0:000 PCI (00|01:00.00) : 1002 6758 class=030000 2:709 0:000 Found Radeon model=AMD Radeon HD 6670 Series It means my DeviceID=6758 (these are hex numbers)
      Then you must check that Apple's drivers support your DeviceID. If not then add it!
      For example HD7850 has DeviceID=6819. If we look into ATI7000Controller (AMD7000... in new systems) we find 6818 here but no 6819!
       
       
      I show you how to do this with terminal commands. Launch /Application/Utilities/Terminal.app. Type in opened window:
       
      cp /System/Library/Extensions/ATI7000Controller.kext/Contents/Info.plist ~/Desktop So you get a copy of the Info.plist on Desktop. Edit it with TextEdit. Change 68181002 -> 68191002.
      Don't edit this file directly in the system folder! 
      Then copy back by terminal. Don't use finder to copy kexts! They will have wrong permissions in this case.
      sudo cp ~/Desktop/Info.plist /System/Library/Extensions/ATI7000Controller.kext/Contents/ sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/* Second command make sure next reboot the kext will use your edited info.plist.
      The same operation you must do with a kext AMDRadeonAccelerator or ATIRadeonX2000 or other one. Check all candidates if they contain such list of possible IDs and choose closest to you.
       
      FakeID
      Since Clover revision 1971+ you may just inject new DeviceID into DSDT instead of correcting kexts. See instruction here.
       
      GraphicsEnabler or Injector
      OSX needs to know some properties (Model name, Family, etc...) that must be somehow injected at boot time. Yes, also real Macs got DeviceProperties string from firmware.
      Alternatives:
      1. Set InjectATI=Yes in Clover (same as GE=y in Chameleon).
      2. Use custom string made with gfxutil. For whom who knows.
      3. Write _DSM into DSDT. You should know what to write.
      4. Use some kext like ATY_init.kext or Natit.kext. If you are sure that the kext is for your card namely.
      I want to say that all this methods make the same thing. Differencies in their tuning.
      The Clover do this automatically for most known cards at this moment.
       
      Connectors.
      As you may see to start HD5000-7000 some strange names used: Pithecia, Orangutan, Elodea... What are they?
      They are configs for framebuffer. Predefined configs how connectors are solded for cards used in real Macs. Strange but these configs rear coincide with PC card. Usually gurus make advice "choose a framebuffer that most appropriate for your card". The chances 1:10. In most cases you may find a FB name that gives you main monitor working. Or nothing at all.
      Great respect to bcc9 who gives us a method to correct one of config to be exactly for you. See here.
      My retelling for Clover is here
      Success example in the thread in posts 44-52
       
      Radeon Mobility
      I tested Clover's methods with two users having Mobility Radeon HD5470 and HD5650M. We found that full memory and QE/CI will be achieved if we set in Clover's config
      LoadVBios=Yes
      even thou no file with bios is provided. This is the key to make Radeon Mobility working!
      Other problem is bad gradients or artifacts. For this case Clover accept the key
      InjectEDID=Yes
      and sometimes you also need to inject CustomEDID.
      See Clover instructions for details.
       
      And my results.
      Gigabyte Radeon HD6670
      <key>Graphics</key> <dict> <key>GraphicsInjector</key> <true/> <key>InjectEDID</key> <true/> <key>FBName</key> <string>Ipomoea</string> <key>LoadVBios</key> <false/> <key>VideoPorts</key> <integer>3</integer> <key>PatchVBios</key> <true/> </dict> <key>KernelAndKextPatches</key> <dict> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>6000</string> <key>ATIConnectorsData</key> <string>000400000403000000010000120401050008000004020000000100001102040310000000100000000001000000000002</string> <key>ATIConnectorsPatch</key> <string>040000000403000000010000100001061000000010000000000100000000000100080000040200000001000012040403</string> VTX Radeon HD5570
      <key>Graphics</key> <dict> <key>PatchVBios</key> <false/> <key>FBName</key> <string>Baboon</string> <key>VideoPorts</key> <string>3</string> <key>GraphicsInjector</key> <string>Yes</string> <key>LoadVBios</key> <string>No</string> </dict> <key>KernelAndKextPatches</key> <dict> <key>Debug</key> <false/> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>5000</string> <key>ATIConnectorsData</key> <string>040000001400000000010000010201030008000000020000007100002205020110000000100000000001000000100002</string> <key>AppleRTC</key> <true/> <key>ATIConnectorsPatch</key> <string>040000001400000000010000010001040008000000020000007100002200020510000000100000000001000000000002</string> <key>AsusAICPUPM</key> <false/> <key>KextsToPatch</key> <array> <dict> <key>Name</key> <string>AppleAHCIPort</string> <key>Find</key> <data>RXh0ZXJuYWw=</data> <key>Replace</key> <data>SW50ZXJuYWw=</data> </dict> </array> </dict> See PatchVBios=No
      for this card "yes" leads to black screen. Use with precautions.
       
      A sample for Radeon R7 240
       
      UPDATE for ElCapitan.
      It seems has more problems. My HD6670 is not working in ElCapitan OOB unlike Mavericks.
      I had to set FakeID=0x67401002 as correspond to real iMac12,2 and set this model in SMBIOS section.
      It related to GraphicsPM or GraphicsControl.
      Look these kexts to decide what you can do for your configuration.
       
      HighSierra requires change these kexts by version from Sierra 10.12.6
      for Radeon HD6xxx
      AMDRadeonX3000.kext AMDRadeonX3000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .  for Radeon HD7xxx and up AMDRadeonX4000.kext AMDRadeonX4000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .    Black screen after wake problem resolved by follow method radeon_bios_decode.0.2.zip
      ati-personality.pl.0.15.zip
      ati-personality.pl.0.15a.zip
    • By ricardos7
      Preciso de ajuda para terminar um meu hackintosh, alguém poderia me ajudar?
       
      Boa tarde a todos, gostaria de ajuda com o meu hackintosh, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador
      Modelo: Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck 

      Dell Wireless 1705 WiFi
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
      Os problemas que encontrei ate agora foram.
      O que não funciona?
      WIFI
      AUDIO
      BRILHO DA TELA
      BLUETOOTH
      GERENCIAMENTO DE ENERGIA NAO SEI COMO SABER SE FUNCIONA
      GRAFICOS DEDICADOS NVIDEA 930M
       
       
      O QUE FUNCIONA?
      GRAFICOS INTEL
      TECLADO
      TRACKPAD
      TECLAS FN
      PLACA DE REDE
       
      AS DSDT E AS SSDT?
      Nao sei como fazer para esse modelo mais ja extrai as originais mais nao sei quais arquivos usar e quais pachs ativar,
      alguém poderia me ajudar a terminar esse hack por favor. Desde ja obrigado.




    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.1
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&amp;t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
×