Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Crazy Software

Snow Leopard 10.6.8 and ATI Radeon HD 5000 Series

15 posts in this topic

Recommended Posts

Hi everyone :)


After many attemps, I've installed Snow Leopard 10.6 on my PC with the following hardware components:


Gigabyte GA-770TA-UD3,

AMD Phenom II X4 945,


XFX Radeon HD 5750 1GB,

Maxtor 250GB S-ATA II (Windows 7),

Samsung 500GB S-ATA II (Snow Leopard),

and two optical drives.


I've downloaded the kexts that I've found at

http://www.osx86.net...?do=file&id=476 (already patched with the Device ID), and after installing them I got a Full HD resolution (I use an HDMI cable) but without QE/CI (no graphic acceleration). So I've tried to update my OS from 10.6 to 10.6.8 with the Combo Update; I've restored the "IOPCI" and the "IOACPI" kexts with success, but if I try to reinstall also the video kexts, after the boot loading I get a blue screen. However, I can access to Snow Leopard only in Safe Mode ("-x" at the boot).

Every kext/driver that I find on the web, doesn't solve my problem. I've read a lot of tutorials and hints, but none of them worked for me.



So, there's a way to make this XFX Radeon HD 5750 working, with QE/CI too? :mellow:

I hope you can help me to fix this problem.


Thanks in advance.


Share this post

Link to post
Share on other sites

What if you boot with -f

Only boot with this flag, and if you like you can use -v ofcourse, but avoid the -x because you'll not be able to check whether this is working in that case or not.


This flag will ignore the system caches and load all kexts available. If the error is over, you know that the caches are corrupt or something. Give it a shot ;)


I have to boot my Lion constantly with -f (ignore caches) or my keyboard won't work, but that's another story :)


P.S. I'm sorry for any misspelled english or for being a bit short. It's been a bit late for me ;)

Edited by Wcool

Share this post

Link to post
Share on other sites

Don't worry for your english, it's not my native language... I'm italian ;)


However, I've tried both with "-f" and "-v" without success. :(

With "-v" I can't see what appears on my screen because the files are loaded too fast.


Now, I'm going to replace the kexts of my VGA that I've downloaded from osx86.net, with the originals included in my Hackintosh installation because Safe Mode doesn't works always and I'd like to boot without "-x". :unsure:

Share this post

Link to post
Share on other sites

Hmm... Well, I'm also a kinda new hackintosher, so the only thing is wait until somebody can answer your question / problem with more knowledge.


Sorry if I cannot help you any further.

Share this post

Link to post
Share on other sites

you must tell us, what we would see on your boot screen, otherwise no help

take a snapshot with your camera.


this card should be supported out of the box.

Share this post

Link to post
Share on other sites


Yesterday I got this error screen during boot: "CPU halted: It is now safe to turn off your computer".

So I've reinstalled my Hackintosh, and now I haven't any kext or driver installed. In fact I have a 1024x768 resolution without QE/CI.

Share this post

Link to post
Share on other sites

What bootloader CD did you use?

Did you already try Chameleon Wizard´s Graphicsenablers checkbox?

That way my AMD´s HD5450 is working fine with 10.6.8 QE/CI.

If 1you only want to try once, you can add the argument GraphicsEnabler=Yes at boot in the Cameleon screen too of course.

Share this post

Link to post
Share on other sites
It will work without any installed kext?

Yes, no additional kext is needed for my PCI graphics, the kexts installed with OSX make use of the video card by default.

Whether this is true for a 5750 as well, I cant tell, but it will be easy to find out. :)

Share this post

Link to post
Share on other sites

I think I have the same problem....please help, I've been stuck on this for days. Almost giving up after reading about a lot of stuff over the past days on troubleshooting it and no progress.


mobo: ga-z68ma-d2h-b3

mem: 4g kingston

cpu: intel i5 2500k

gfx: HIS radeon hd 5450 1gb


After fresh install mac os x 10.6.3 retail disk, update it with 10.6.8 w/ help of updatehelper... run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url](followed the lifehacker video on how to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url])basically the same for the audio and ethernet on gigabyte boards.

Restart and I only get to white screen. Can please tell me what I need to do more(in details for a very noob guy)?

Share this post

Link to post
Share on other sites

Something may have got lost with the update.

Can you boot with -x -f to find out? You might try -v too, to post the error message, someone should be able to tell you whats wrong.

Share this post

Link to post
Share on other sites

New development, I am able to load up os x 10.6.8 now after waiting everytime for the apple white screen loading screen. I followed 1 of the post here in the forum with identical specs but with some issues, no audio from the board and no audio from the video card too through hdmi. I've tried running [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] so many times but no avail. any suggestions? oh and I can't access my mac app store anymore too...to download my lion update, it sayd my device/comp can not be verified :(

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mr.Darkwraith
      Is it possible to install/run Android TV/x86 on the 1st generation Apple TV?
    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By lucasrm654
      Eu instalei o Hackintosh, porem uso um Cougar 200k, meu teclado, e a tecla shift, windows e alt não funcionam, não executam função nenhuma, já o Ctrl funciona como Shift, gostaria de saber como eu posso atribuir funções a essas teclas que não fazem nada e mudar a função do Ctrl.
    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.
    • By Zsparrow0
      NOT WORKING   SD Card Reader (Use USB adapter ) Hibernation Nvidia Graphic Cards Fingerprint Reader Thunderbolt HotPlug REQUIREMENTS   Fresh installation One working OSX environment Whole disk available (No partitions) Knowledge in PLIST edition Backup Made (EVERYTHING WILL BE ERASED) Latest BIOS version 4k sector patch NVME WIFI CARD DW1560 (EFI FOLDER CONTAIN PATCH FOR THIS CARD ONLY)     1 - CREATE USB     Download High Sierra from AppStore Plug in your USB Key (16GB or More) Format it with Disk Utility and name it « MyVolume » Launch Terminal and type : sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume Mount the EFI partition /MyVolume/EFI/ with Clover Configurator (See in the EFI Folder) Copy the entire EFI folder linked to the post to /MyVolume/ 2 - BIOS SETTINGS   MAKE SURE EVERYTHING IS CORRECT BEFORE CONTINUE OR IT WILL FAIL ON BOOT !     System Information          Check that Video Memory is already 64MB       Advanced Boot Options (all off)        System Configuration      SATA Operation (AHCI)      Drives (all on)      SMART Reporting (on)      USB Configuration (all on)      Dell Type-C Dock Configuration (on)      Thunderbolt Adapter Configuration (all on, no security)      USB PowerShare (on)      Audio (all on)      Touchscreen (on)      Miscellaneous Devices (all on except SD Card Reader)      CPU XD (on)      Secure Boot        Secure Boot Enable (disabled)      Intel Software Guard Extensions        Intel SGX Enable (Software-Controlled)      Performance        (Everything on/enabled)        Power Management        (USB Wake Support = off)      (Wake on Dell USB-C Dock = on)       Wake on WLAN (off)      Block Sleep (off)        Virtualization Support        (Everything on)    3 - BOOT PROCESS
        Start your computer and press F12 to open the boot menu Boot from your USB Key Select the "Installer from (Your usb key)" (Verbose mode is enable by default to see what's going on if it fail)   -----------------------------------------------------------------------------------------------------------------------------------------     WAIT ! EVEN IF YOU THINK THAT THE LOADING BAR IS STUCKED IT COULD TAKE 5MIN TO LOAD ENTIRELY     IF IT FAIL SEE THE REHABMAN GUIDE BEFORE ASKING QUESTION     IF YOU CAN'T BOOT YOU CAN TRY TO USE A FAKE IG-PLATFORM GO TO THE CLOVER OPTION IN THE GRAPHIC PARTS AND USE A FAKE IG-PLATFORM SUCH AS 34567898764   ----------------------------------------------------------------------------------------------------------     4 - INSTALLATION   - Once arrived on the installation screen - Open Disk Utility and Erase your Main Hard Drive and format to : MacOS AFPS (not encrypted) - Go back to the installer continue and choose your Formated Hard Drive to install MacOS. - The computer will reboot after about 2 min - Press F12 to choose your usb key and hit ENTER   (YOU COULD HAVE 2 CHOICE DURING THE REBOOT : INSTALLER ON "YOUR DRIVE NAME" OR PRELOADER "YOUR DRIVE NAME". You have to use "Installer on your "drive name" in case it FAIL select the OTHER OPTION. You will have to do this twice if I remember correctly.   BE CAREFUL YOU HAVE TO ALWAYS BOOT ON YOUR USB KEY BECAUSE CLOVER IS NOT YET INSTALLED ON THE SYSTEM, SO PRESS F12 ON EVERY REBOOT AND CHOOSE YOUR USB KEY UNTIL CLOVER PROPERLY INSTALLED     5 - POST INSTALLATION   - Open Kext Wizard in My EFI folder - Click on installation tabs browse kext and select ALL THE KEXT IN USB/EFI/CLOVER/KEXT/OTHER - Make sure that the destination drive is your MAIN HARD DRIVE and press INSTALL - Once done go to MAINTENANCE TAB and select the radio button for System/Library/Extensions and press EXECUTE.   6 - RESTART WITHOUT USB   - Disconnect your usb and reboot normally, everything should work properly now.     !!! CONGRATULATION YOU DID IT !!!               if not...       Give us enough clear information in the comments section so we can help you to have this laptop working.   A BIG         TO     Dell for making this laptop Apple for Mac OS RehabMan for so many detailed posts, enormous collection of SSDT files, kext development, and being overall incredibly helpful throughout this whole process KNNSpeed for this amazing guide Pike R. Alpha for his in-depth blog and the 0xE2 patch (among being the source of many other developments and patches) The Clover team for the Clover bootloader netkas, kozlek, and Slice for FakeSMC wmchris for his initial XPS 9550 write-up Jonny4911 for posting his 9560 setup and his version of the AudioFix folder syscl for a lot of work into the XPS 9360 and his build of VoodooPS2Controller darkhandz for his XPS 9550 repo toleda and goodwin_c for audio, ALCPlugFix goodwin_c for HWP dpassmor for the Thunderbolt/USB-C ExpressCard trick vit9696 for Lilu and AppleALC PMHeart for CoreDisplayFixup lvs1974 for NvidiaGraphicsFixup darkvoid for Wi-Fi patches filequit for the 5GHz global channel bonding patch denskop for the "Boot Graphics Glitch" patch netkas, kid2010, and syscl for the Thunderbolt 3 blacklist bypass patch Blazinsmokey for all his good advice and knowledge   AND ALL THE OTHER THAT I DIDN'T QUOTE BUT WHO CONTRIBUTED TO MAKE THIS DREAM HAPPENED !     MORE CUSTOMIZATION   Improve battery life and CPU temperature :   Check the @abn6x Guide : http://www.insanelymac.com/forum/topic/331775-guide-how-to-undervolt-your-haswell-and-above-cpu/     EFI.7z