Jump to content
About Just Joined group Read more... ×

1,164 posts in this topic

Recommended Posts

How can we get a fan to register if it had no value?

 

By modifying plugin's info.plist. Just set the name for one of FANINx

Share this post


Link to post
Share on other sites
Advertisement

this is the windows report

 

with your last update i lose all the sensors

 

New revision should fix this problem. Also you can add more voltages via info.plist, if you want. Maybe you'll find your memory voltage sensor. You could check readings from OpenHardwareMonitor and set VINx for your specific voltage sensors. See it87x's default profile to get sensors names you could use in info.plist

Share this post


Link to post
Share on other sites

Which kext is the kext that we need to edit for fan? (for a CPU fan)

 

Would that be IntelCPUMonitor?

Share this post


Link to post
Share on other sites

Which kext is the kext that we need to edit for fan? (for a CPU fan)

 

Would that be IntelCPUMonitor?

 

You need to edit info.plist of one of the SuperIO plugins.

Share this post


Link to post
Share on other sites

Hi kozlek ;)

Overall thanks for your work, really appreciated.

That's what I get with FakeSMC and IntelThermal.kext, NuvotonNCT677x.kext and RadeonX.kext PlugIns into it:

 

post-499963-0-67405400-1330979174_thumb.png

 

I've a P8P67 Sabertooth with an i5-2500K and a Sapphire 6450 1GB GDDR3 passive.

Share this post


Link to post
Share on other sites

Hi kozlek ;)

Overall thanks for your work, really appreciated.

That's what I get with FakeSMC and IntelThermal.kext, NuvotonNCT677x.kext and RadeonX.kext PlugIns into it:

 

post-499963-0-67405400-1330979174_thumb.png

 

I've a P8P67 Sabertooth with an i5-2500K and a Sapphire 6450 1GB GDDR3 passive.

 

I´m interested in your dsdt and your ssdt, as i also have Sabertooth P67 and 2500K ... ioreg seems alright, as kozlek also stated, but no HDD temps show up ??? Could you send me your .aml´s to make a diff? Also: which UEFI version do you use?

 

Cheers

 

Goron

Share this post


Link to post
Share on other sites

I got kernel panic after install the newest version (2012-03-06) from Github.

 

Does anybody know how to restore it...?

Share this post


Link to post
Share on other sites

I got kernel panic after install the newest version (2012-03-06) from Github.

 

Does anybody know how to restore it...?

 

Which kexts did you installed? Please, get the screen shot of kernel panic.

Share this post


Link to post
Share on other sites

Which kexts did you installed? Please, get the screen shot of kernel panic.

 

Hi,

 

Finally I used a bootable installation usb disk to boot into Lion installation. Download a new FakeSMC from http://www.projectosx.com/forum/index.php?showtopic=1643 (the top one). Delete the FakeSMC.kext from /S/L/E and put all new kexts from the new one into /S/L/E. Now system can boot. However something is wrong. System menu on the top right corner seems to be broken.

 

when I run:

sudo kextcache -prelinked-kernel

 

I got:

 

W836x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
W836x.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
PC8739x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
PC8739x.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
IT87x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
IT87x.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
F718x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
F718x.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
ACPIMonitor.kext - no compatible dependency found for org.netkas.FakeSMC.
ACPIMonitor.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
W836x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
PC8739x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
IT87x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
F718x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
ACPIMonitor.kext - no compatible dependency found for org.netkas.FakeSMC.
/System/Library/Extensions/System.kext/PlugIns/Libkern6.0.kext doesn't support architecture x86_64; omitting from prelinked kernel.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.mozodojo.SuperIOFamily; omitting from prelinked kernel.
W836x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.mozodojo.W836x; omitting from prelinked kernel.
PC8739x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.slice.PC8739x; omitting from prelinked kernel.
IT87x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.mozodojo.IT87x; omitting from prelinked kernel.
F718x.kext - no compatible dependency found for org.netkas.FakeSMC.
SuperIOFamily.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.mozodojo.F718x; omitting from prelinked kernel.
ACPIMonitor.kext - no compatible dependency found for org.netkas.FakeSMC.
Prelink failed for org.slice.ACPIMonitor; omitting from prelinked kernel.

 

Looks like some mismatch version problem.

 

How can I fix that? Thanks!

Share this post


Link to post
Share on other sites

Which kexts did you installed? Please, get the screen shot of kernel panic.

 

I did not take a screenshot. The options I checked were:

  • Utilities
    • HWMonitor
    • HWMonitor Menu

    [*]FakeSMC

    [*]Misc Plug-Ins

    • Intelthermal

    [*]Graphics Card Plug-Ins

    • NVClockX

    [*]Motherboard Plug-Ins

    • Winbond W836x

 

When it's panic the backtrace shows something wrong within FakeSMC and WinbondW836x.

Share this post


Link to post
Share on other sites

 

 

I did not take a screenshot. The options I checked were:

  • Utilities
    • HWMonitor
    • HWMonitor Menu

    [*]FakeSMC

    [*]Misc Plug-Ins

    • Intelthermal

    [*]Graphics Card Plug-Ins

    • NVClockX

    [*]Motherboard Plug-Ins

    • Winbond W836x

 

When it's panic the backtrace shows something wrong within FakeSMC and WinbondW836x.

 

Ok, I'll see on it

Share this post


Link to post
Share on other sites

Hi,

 

Finally I used a bootable installation usb disk to boot into Lion installation. Download a new FakeSMC from http://www.projectos...?showtopic=1643 (the top one). Delete the FakeSMC.kext from /S/L/E and put all new kexts from the new one into /S/L/E. Now system can boot. However something is wrong. System menu on the top right corner seems to be broken.

 

when I run:

sudo kextcache -prelinked-kernel

 

I got:

Looks like some mismatch version problem.

 

How can I fix that? Thanks!

 

You must use either the Kozlek's branch on the Github or the Slice's branch on Assembla, NOT BOTH.

DO NOT combine the branches as they are incompatible and therefore, they are not interchangeable.

Share this post


Link to post
Share on other sites

I did not take a screenshot. The options I checked were:

  • Utilities
    • HWMonitor
    • HWMonitor Menu

    [*]FakeSMC

    [*]Misc Plug-Ins

    • Intelthermal

    [*]Graphics Card Plug-Ins

    • NVClockX

    [*]Motherboard Plug-Ins

    • Winbond W836x

When it's panic the backtrace shows something wrong within FakeSMC and WinbondW836x.

 

 

Same here...kernel panic with winbond!!!

Share this post


Link to post
Share on other sites

post-216126-0-87945300-1331141428_thumb.jpg

New revision should fix this problem. Also you can add more voltages via info.plist, if you want. Maybe you'll find your memory voltage sensor. You could check readings from OpenHardwareMonitor and set VINx for your specific voltage sensors. See it87x's default profile to get sensors names you could use in info.plist

 

thanks kozlek

 

great job now i should found the real name for each sensor

but really great job

thank you

i will update the real name and upload it here

 

Sacaman :-)

Share this post


Link to post
Share on other sites

hi there, still kernel panic...log attached!!!

 

Try the new version, it shouldfix the problem.

Share this post


Link to post
Share on other sites

The latest available revision of the NSCPC8739x.kext plugin fails to load with the following output:

 

kernel: Can't load kext org.slice.NSCPC8739x - link failed.
kernel: Failed to load executable for kext org.slice.NSCPC8739x.
kernel: Failed to load kext org.slice.NSCPC8739x (error 0xdc008016).
kernel: Kext org.slice.NSCPC8739x failed to load (0xdc008016).
kernel: kxld[org.slice.NSCPC8739x]: The vtable '__ZTV7PC8739x' is malformed. Make sure your kext has been built against the correct headers.
com.apple.kextd: Failed to load /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns/NSCPC8739x.kext - (libkern/kext) link error.

Share this post


Link to post
Share on other sites

The latest available revision of the NSCPC8739x.kext plugin fails to load with the following output:

 

kernel: Can't load kext org.slice.NSCPC8739x - link failed.
kernel: Failed to load executable for kext org.slice.NSCPC8739x.
kernel: Failed to load kext org.slice.NSCPC8739x (error 0xdc008016).
kernel: Kext org.slice.NSCPC8739x failed to load (0xdc008016).
kernel: kxld[org.slice.NSCPC8739x]: The vtable '__ZTV7PC8739x' is malformed. Make sure your kext has been built against the correct headers.
com.apple.kextd: Failed to load /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns/NSCPC8739x.kext - (libkern/kext) link error.

 

I got rid off this plugin because it uses hack to work only on specific hardware

Share this post


Link to post
Share on other sites

thanx...working ;-)

but missing fans, voltages, and i got 128 degrees on my vertex 3!!!!

 

Could you upload, please, you kernel log and ioreg dump (dumped with IORegistryExplorer)

Share this post


Link to post
Share on other sites

Edit !!!! Not working properly!!!!

 

 

Mar 10 10:12:00 localhost kernel[0]: kxld[org.slice.NSCPC8739x]: The vtable '__ZTV7PC8739x' is malformed. Make sure your kext has been built against the correct headers.

Mar 10 10:12:00 localhost kernel[0]: Can't load kext org.slice.NSCPC8739x - link failed.

Mar 10 10:12:00 localhost kernel[0]: Failed to load executable for kext org.slice.NSCPC8739x.

Mar 10 10:12:00 localhost kernel[0]: Kext org.slice.NSCPC8739x failed to load (0xdc008016).

Mar 10 10:12:00 localhost kernel[0]: Failed to load kext org.slice.NSCPC8739x (error 0xdc008016).

Mar 10 10:12:00 localhost kernel[0]: kxld[org.mozodojo.WinbondW836x]: The vtable '__ZTV5W836x' is malformed. Make sure your kext has been built against the correct headers.

Mar 10 10:12:00 localhost kernel[0]: Can't load kext org.mozodojo.WinbondW836x - link failed.

Mar 10 10:12:00 localhost kernel[0]: Failed to load executable for kext org.mozodojo.WinbondW836x.

Mar 10 10:12:00 localhost kernel[0]: Kext org.mozodojo.WinbondW836x failed to load (0xdc008016).

Mar 10 10:12:00 localhost kernel[0]: Failed to load kext org.mozodojo.WinbondW836x (error 0xdc008016).

Share this post


Link to post
Share on other sites

hi kozlek

 

your new update is not working i lose all my sensors

only the CPU's and HDD's with GFX are shown

i get this on the log file

 

 

Mar 10 23:16:55 localhost kernel[0]: SuperIO: found Fintek F71869A on port=0x4e address=0x290

Mar 10 23:16:55 localhost kernel[0]: F718x: [Warning] wrong vendor id=0xffff

Share this post


Link to post
Share on other sites

That's what I get with FakeSMC and IntelThermal.kext, NuvotonNCT677x.kext and RadeonX.kext PlugIns into it:

Thanks for this, now HWS is working here like a charm.

 

10fz607.jpg

 

First, this is really a great piece of software, but it needs a better description in the OP, so people know how to use it. ;)

 

Second, in a earlier version I could check the CPU MHz, but now it's missing?! Or just me doing something wrong?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By miliuco
      Install macOS 10.15 Catalina on Gigabyte P55-USB3 with Radeon RX 580 graphics card using a USB device created with the createinstallmedia command and Clover as bootloader. Instructions to install macOS 10.14 Mojave on this computer are almost identical, replacing Catalina app with Mojave, so this article is suitable for both versions of macOS. The Gigabyte P55-USB3 motherboard (and some others from the same brand with the P55 / H55 chipset) have made it easy to build a hackintosh and install macOS since 10 years ago. Although it is an old motherboard, the behavior with Mojave or Catalina is very good after changing the classic hard drive (HDD) for a solid state drive (SSD).

      Components of the hackintosh
      Gigabyte GA-P55-USB3 motherboard: P55 chipset, 1156 socket, ALC892 audio, Gigabit RTL8111D network, DDR3 RAM Intel Core i5-750 processor for socket 1156: 4 cores, 8MB cache, clock rate 2.66 GHz Fenvi FV-T919 wireless + Bluetooth card: PCI-Express, wifi is ac type, detected by macOS as Airport and Apple Bluetooth Radeon RX 580 8 GB graphics card: works OOB but with a few details to be considered, it has its own article.  
      Previous requirements
      Install macOS Catalina app in /Applications folder USB flash drive with at least 16GB prepared from Disk Utility with MBR partition scheme and formatted as Mac Os Plus (on older Gigabyte boards like mine, USB sticks partitioned with GUID scheme instead of MBR usually hang the system when booting) Recent version of Clover (I have used r5117) Recent versions of Lilu (at least 1.4.4) and WhateverGreen (at least 1.3.9) to fine-tune the behavior of the graphics card Recent version of RealtekRTL8111 (I have used 2.2.2) FaceSMC version 6.26-322 (newer versions disable automatic mounting of USB devices on my system).  
      Create install USB
      Run this command from Terminal (assuming the target device is called USB):
      Bash: sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/USB /Applications/Install\ macOS\ Catalina.app
      Clover must be installed on the USB memory, I choose the following options:
      Bootloader > Install boot0af on the MBR CloverEFi > CloverEFI 64-bit SATA BIOS Drivers, 64 bit > Recommended drivers > FSInject + SMCHelper + XhciDxe BIOS Drivers, 64 bit > File System drivers > ApfsDriverLoader Install RC scripts on selected volume Optional RC scripts > Disable sleep proxy client.  
      You have to copy 4 kexts to the EFI/CLOVER/kexts/Other folder of the USB device: FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2. Regarding the config.plist file, the most significant is:
      Boot > kext-dev-mode = 1 in Boot arguments GUI > Theme embedded, EmbeddedThemeType Dark, Screen Resolution 1920x1080, Preboot in Hide Volume Graphics > blank, nothing is checked except if foxbox solution is used to have more than 2 connectors enabled RT Variables > 0x28 in BooterConfig and 0x67 in CsrActiveConfig SMBios > iMac14,2 Sytem Parameters> Yes in Inject Kexts and check Inject System ID.  
      Install macOS Catalina

      Boot from the USB device and choose Install macOS from Install macOS Catalina. The installation program runs until the PC restarts. Here choose Install macOS from HDD (the name of the volume you are installing macOS on). With RX 580 graphics card, the screen goes black in this second phase of the installation, it is a phase in which the user has nothing to do until the PC is restarted so you can let it work until the Clover menu again. You have to choose Boot macOS from HDDto boot the installed system from the hard disk, the screen is recovered and you can configure the account and the initial options. From this moment the screen works fine.

      In summary:
      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine Boot from USB > Clover menu > Install macOS from HDD > black screen Boot from USB > Clover menu > Boot macOS from HDD > screen works fine.  
      Install Clover and kexts on the hard drive

      Clover needs to be installed on the disk where we just installed macOS. Options are the same as when installing it on the USB memory. You also have to copy the 4 kexts (FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2) into the EFI/CLOVER/kexts/Other folder on the EFI partition of the disk. And review the config.plist file remembering the comments for the USB.

      If everything goes well, the computer starts from the hard disk with a running copy of macOS Catalina.
       
       

    • By Slice
      The thread splitted from HWSensors3.
       
      Tools to testing Radeon state.
      Load RadeonPCI.kext  
      RadeonPCI.kext.zip
       
      How to load
      sudo chown -R root:wheel ~/Downloads/RadeonPCI.kext sudo chmod -R 755 ~/Downloads/RadeonPCI.kext sudo kextutil -v ~/Downloads/RadeonPCI.kext and use RadeonDump utility
      RadeonDump1.zip
       
      Commands to see temperature
      Polaris
      ./RadeonDump1 -n 6b0,c0300014
      SeaIsaland
      ./RadeonDump1 -n 200,c0300014
       
      Old families
      ./RadeonDump1 -r 714,7f4
       
      Other possible methods to find a register for temperature
      ./RadeonDump1 -n 6b0,c0300e0c
      ./RadeonDump1 -n 6b0,1c5
      ./RadeonDump -n 6b0,d8200ca4
      ./RadeonDump -r 59800,59810
      ./RadeonDump -r 678,680

       
       
       
      01.12.2017
      Latest solution RadeonMonitor.kext here
      works for RX 460,480,580
      not works for HD7790, R9 290X?
       
      06.12.2017
      Here works also with HD7790, R9 290X
       
      14.12.2017
      Support VEGA here
       
      13.12.2017
      Version for test modern cards
      RadeonPCI5.kext.zip
       
      06.04.2020
      Version for Catalina
      RadeonPCI5-v2.kext.zip
    • By kevin_1351
      tl;dr: VirtualSMC causes me a flood of log messages and correlated cpu spikes. FakeSMC doesn't.
       
      Hi, I have almost finalized my Huawei Matebook X Pro Opencore setup and everything is working very well besides wifi/bt ofc (which is about to change).
       
      However, I noticed how the cpu usage sometimes went up a little and when looking at the Console I could see a never-ending flood of:
      default 14:05:05.983292+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:05.982975+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:05.982996+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985932+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985949+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.986134+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426574+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:39.426729+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426585+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431085+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431097+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431246+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433068+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:42.433227+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433078+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434453+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434465+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434622+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:44.436155+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:44.436166+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0  
      As you can see, multiple of these per second. Another guy with the same computer is also having this issue and posted a dsdt change to fix it. This fix didn't solve anything though
      He tried to limit the Notify call by implementing a state change requirement before calling Notify.
       
      Here is the original acpi:
      Scope (_SB) { Device (LID) { Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } ^^PCI0.GFX0.CLID = Local0 Return (Local0) } } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } Notify (LID, 0x80) // Status Change } } Which he changed to: 
      Scope (_SB) { Device (LID) { Name (_OLD, One) // assuming everything else.. the lid should start open? Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } Return (Local0) } } Device (PNLF) { Name (_HID, EisaId ("APP0002")) // _HID: Hardware ID Name (_CID, "backlight") // _CID: Compatible ID Name (_UID, 0x0A) // _UID: Unique ID Name (_STA, 0x0B) // _STA: Status } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } If ((^^^^LID._OLD != Local0)) { Notify (LID, 0x80) // Status Change ^^^^LID._OLD = Local0 } } } Besides me not seeing any reason to declare _OLD in LID. The idea itself shouldn't be too bad right? Well, as I said, his fix didn't work.
       
      In fact, to prove that Method _Q81 doesn't have anything to do with the issue at all, I created a Clover/Opencore patch to change _Q81 to XQ81. This resulted in my lid not working at all of course, but the log flooding still persisted!
      So _Q81 doesn't have anything to do with the issue afaik.
       
      Now, further Google searches led me to a chinese post where he tied the issue to VirtualSMC. And indeed, by migrating to FakeSMC the issue is no more.
       
      Unfortunately, I'm very fond of VirtualSMC for various reasons. So I would very much like to keep it. If not I'd have to implement the old way of doing Battery monitoring etcetc. Which isn't very elegant and update proof as it requires DSDT patching.
       
      So, I do believe that the issue may very well be in the DSDT code, perhaps in the ambient light part. I'm not very skilled at this and just started studying the ACPI spec 3 days ago.
       
      Could someone please help me out? Thanks a lot in advance
       
       
      origin.zip
      OC.zip
    • By Slice
      Guys,
      Don't mix 6.18 and 3.41.
       
      There are three different projects for monitoring temperatures, voltages, fans speed and other hardware parameters:
      Initially it was FakeSMC with plugins for producing SMC keys for hardware parameters for different hardware. But sometimes ago Kozlek separated own version of FakeSMC and producing new set of plugins while I stay with good working version 3. So..
      1. FakeSMC v3 with Hardware Sensors3  which I still supported.
      2. FakeSMC v6 (rev1800) by Kozlek and supported by Rehabman. AFAIK both are abandoned and the project is not supported. Or may be maintained by coauthors.
      3. New VirtualSMC by vit9696 with own set of sensors kexts. It depends on Lilu.kext. The project is in active development.
      All three project have incompatible interfaces sensors<->SMC so they are incompatible with each other.
       
      There are applications for monitoring hardware parameters and they commonly depends on these projects.
      1. iStat, iStatMenu, iStatPro compatible with real Macs because they use SMC keys just like those presents in real Macs.
      2. HWMonitorSMC by Navi (initial codes from Kozlek)  used in my HWSensors3.
      3. HWMonitor by Kozlek with graphics like in IntelPowerGadget used in his HWSensors version.
      4. HWMonitorSMC2 by Vector_Sigma tends to be universal supporting all project. It also may use sensors information produces by Apple graphics and by IntelPowerGadget.
       
      Let us discuss here differences and common ideas for this projects.
       
×