Jump to content

Need help w/ RealtekRTL81xx.kext working on EVGA SR-2 Mobo


6 posts in this topic

Recommended Posts

Hi Guys,


First, Before I go into what my issue is, here's my System Setup:


- 1 x EVGA Classified SR-2 Motherboard (270-WS-W555-A1)

- 2 x Xeon X5650 CPUs

- 1 x EVGA 480 GTX Superclocked GPU

- 48GB Kingston RAM (KHX1600C9D3K6)

- 1 x 120GB OWC 6G Mercury Extreme SSD

- 2 x 2TB Western Digital Caviar Black (WD2001FASS) HDs

- Silverstone TJ11 PC Case

- Koolance Water Cooled system throughout

- Mac OS X Lion 10.7.2


Here's my situation:


I have tried using Syba Gigabit 1000Base-T Ethernet PCI-Express Network Card, w/ Realtek RTL8111 Chipset (P/N: SD-PEX24009) and using lnx2mac's RealtekRTL81xx-0_0_90.pkg (found here: RealtekRTL81xx-0_0_90.pkg) that installed RealtekRTL81xx.kext, but to no avail. It still doesn't work. I have a Motorola Cable Modem connected to a D-Link DIR-655 Router and I can go online through my own D-Link admin and see that the my SR-2 system is connected (by viewing it on my other Hackie), but so far I get no connection on my new SR-2 setup. No clue what's going on, any help would be appreciated. Thanks...


PS - I'm about to possibly use a Trendnet USB to Gigabit Ethernet Adapter (TU2-ETG). I would like to see though what help I can get through here... Again, thanks...

Link to comment
Share on other sites



IMO, its cheap and I bet it will work considering its Mac compatible but I would use D-link DWA-556 it works great OBO or both...




Opps I forgot there might be other revisions of the DWA-556 so will look that up on my build and post back what rev. it is!

Link to comment
Share on other sites

I look forward to your reply. Thanks. BTW, lnx2mac is trying to help me with a debug app that is in the same RealtekTRL81xx-0_0_90.pkg that I just ran. I don't know how to figure it out but he does. What's confusing is that this PCI ethernet card has the Realtek RTL8111 Chipset built in. An SR-2 builder has used this very card with no issues. Maybe this card is bad I will wait for your reply here soon. But I would like to have something that is not wireless if I can help it. Thanks again... :-)

Link to comment
Share on other sites



Here it is and the reason for being so specific is that other posts suggest that some don't work. Its been around awhile.

I do have an intersting theory about the way PCI-E is implemented and how the hardware is detected, in your case with the pci nic's I would think that somewhere you need to add information so it picks up the card as a device and then recognize to load the apropraite Kext. I am also aware others have your set up and unsure if they have used the Marvell onboard lan.




Here's the specs and I envy your set up very nice.The other thing is over @ tonymac seems not have the first insanelymacians that got this thing running but I'm very sure theres a kext bundle for this already. I just can't remember the thread. Over at EVGA there's someone who had this thing going for awhile. Just simply pointing out its around somewhere...

Link to comment
Share on other sites

I just purchased one of these gigabit ethernet cards for my SR-2 Hackintosh. I use a USB WiFi stick for my actual internet access, but I needed a valid “built-in” ethernet card in order to have access to the App Store and iTunes Match since there are no working Mac OS drivers for the SR-2’s built-in ethernet.




In order to get Mac OS to recognize it as "built-in”, I used gfxutil to output the hex for the com.apple.boot.plist file.

Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...