Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

Trackpad device id into Info.plist Acer E730G

Recommended Posts

Hi, I've got almost everything working on my laptop and Lion 10.7.2. It's an Acer E730G.


My problem is that I can't figure out how to get the trackpad working correctly. There are some basic instructions on this page http://wiki.osx86project.org/wiki/index.php/HCL_10.7.1/Portables#E730G


My problem is first of all that I'm not sure how to get the device id for the trackpad. I've found something I think is the device id in my Windows 7 install.

The second problem is that I don't know how do add it to the Info.plist file. I know how to find the Info.plist he talks about and how to edit it but not how to add my device id and what keys or where to put it. I can't find anything looking like device ids in the plist file he talks about.


Any help or pointers to help would be much appreciated!

Share this post

Link to post
Share on other sites


Actually, Voodoo ps2 didn't work for me for trackpad so I used ApplePS2Controller.kext (I hope you have it or you can find it in kext.com). You can get device id using your windows OS (I got from mine Win 7, you can go to Device Manager and browse through devices to find trackpad and u should see productID). however, u can try this kext that I have attached. You need to copy this ApplePS2Trackpad.kext inside ApplePS2Controller.kext. To do this u should

Right click on ApplePS2Controller.kext

Select "Show package Contents"

Click folder "Contents"

Click folder "Plugins"

paste or drag this file "ApplePS2Trackpad.kext"


Do not use kext wizard or any other app to repair permission, let it be like that. You might get a message saying that this kext has not been installed properly (I did get it) but do nothing. just restart your machine and i hope it should work. this is how mine work. it took me very long time to figure out this. i even bought a usb mouse until I had my trackpad work. let me know if it work or not.





p.s Did u upgraded to 10.7.2 without any problem? I got a lot of problem doing it. how did u do it?


Share this post

Link to post
Share on other sites

Thanks for your reply. Sadly it doesn't seem to work :/


I tried with your kext but no go. I also edited the Info.plist on my original kext and no go. Very weird. Are you sure you haven't done or isn't using anything else to get it running?


I checked Hardware ID in Windows and I got the same as you, PNP0F13


10.7.2 installed without any problems at all. I had to overwrite the display file and some minor things but nothing big. What's your problem? What smbios file do you use?

Share this post

Link to post
Share on other sites


It's sad to hear. I did manage to make it work after almost 2 months. I have attached my ApplePS2Controller.kext. try with that one. just copy it to the Extension folder without using kext installer and if it does not work try using kext installer.


I tried to upgrade twice but got into problem. I used both automatic updater and combo-update file. I think there is some problem with my graphics card. I've attached my smbios.plist file. Have a look at it. May be you can send your's one to me too.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.