Jump to content
Sign in to follow this  
Followers 0
Jappiman

AtherosController.cpp:962 load failed after combo upgrade (no wi-fi hardware found)

8 posts in this topic

Recommended Posts

I just updated to 10.7.3 (Build 11D46) and get the following message upon boot:

 

 

Jan 23 05:31:14 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros9380/AirPortDriverAtheros9380-430.14.9/src/common/lmac/ath_dev/darwin/AtherosController.cpp:962] load failed

 

I can't access Wi-fi now (no hardware found).

 

Anyone got this message and fixed it? (I've seen it's not a specifc message to this version). I also got a kext error message after installation, I think it was related to not being able to load Apple16X50 IIRC (but I think this shouldn't be related to this error message).

Share this post


Link to post
Share on other sites
Advertisement

i think it has to do with PCMCIA driver for 0x24 . PCMCIA cardbus isnt pci.

 

best bet is to change card for a newer AR5B91 .. i had same error in 10.6.x with 0x24 ar5008x

Share this post


Link to post
Share on other sites

Thanks LatinMcG

 

I'll try getting another wireless card for my laptop. It seems strange, as the card was taken out of an Apple device and it was working perfectly with Lion out of the box.

Share this post


Link to post
Share on other sites

i had same issue with the real apple card. in my dell. ended up getting AR5B91 and never had a problem after.

 

but i read somewhere the airport driver for PCMCIA did this problem. (tries to take over for atheros older cards)

 

the Apple16X50 is the COM port in bios is enabled.. disable it . same with LPT

Share this post


Link to post
Share on other sites

I've had the same problem. I had to use IO80211Family.kext of 10.7.2. Strange thing is that when I get that message, it breaks bluetooth, firewire and obviously wifi. On console, it also says something about PCI Open Failed. The above-mentioned workaround fixes all of them. I'll try again when I re-download Lion from the App Store.

Share this post


Link to post
Share on other sites

ahh 9380 not 9280 ..newer atheros card. nevermind on pcmcia i confused issue with older card.

I have a 9280 and 9380 is what appears on Console when I get that error.

Share this post


Link to post
Share on other sites

I had a same problem..

To solve this problem, Open an info.plist file which is located in the AirportAtheros40.kext > Contents

and delete 2 line

 

<key>OSBundleRequired</key>

<string>Network-Root</string>

 

p.s AirportAtheros40.kext is located in the IO80211Family.kext > Contents > Plugins.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By grisno
      Hi people,
       
      This is a preliminary installer to activate the Combo Mini PCIe Atheros QCWB335 in MacOS.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      AIRPORT : OK Atheros QCWB335 (AR9565) (168c:0036) Mini PCIe * BLUETOOTH : OK Atheros AR3012 (0cf3:3121) USB 2.0 ** AIRDROP : Not Tested HANDOFF : Not Tested CONTINUITY : Not Tested WOL : Not Tested IMESSAGE : OK FACETIME : OK ICLOUD : OK APPSTORE : OK   Known Issues:
       
      - Partial support with a maximum speed of 10Mbits (10.11.0+) *
      - Don't support Bluetooth Power Off/On by Software (10.10.0+) **
      - Sometimes Lost Bluetooth After Sleep WakeUp (10.10.0+) **
       
      Sources:
       
      Insanelymac
    • By Luk3_90
      Buongiorno a tutti,
       
      La scorsa settimana ho aggiornato High Sierra a Mojave seguendo le rispettive guide per l' aggiornamento dei Kext all' interno della partizione EFI. Tutte le periferiche funzionano correttamente audio compreso ( di solito non parte al primo riavvio ), tranne la Vram della scheda grafica integrata in firma ( 7 MB riconosciuti). Premesso che:
      - Ho aggiornato Lilu e aggiunto WhateverGreen nella cartella EFI/Clovers/Kexts/10.14 & EFI/Clovers/Kexts/Other
      - Ho rimosso IntelGraphicsFixup & Shiki
      - Ho rimosso Inject Intel con il relativo platform Id della scheda video ( era necessaria per High Sierra)
      - Con Clover configurator ho aggiunto sotto Device -> Proprieties  platform id, device id, Framebuffer-unifedmem ecc. ecc. ( Vedere config.plist in allegato)
      Al boot mi esce il messaggio [IGPU] Failed to initialize graphics firmware e si blocca la schermata. Qualora dovessi mettere un FakeId o semplicemente fare da clover Inject Intel + Platform Id: 0x00001912 ( se metto il Platform giusto 0x19120000 mi da sempre il solito errore), il sistema ovviamente parte senza problemi ma con 7MB di VRam.
       
      Mi è sfuggito qualcosa?
       
      Grazie in anticipo
      config.plist
    • By Frywyn10
      Hello, i installed Os X El Capitan on this pc : Dell Optiplex 3020, I3 4130, 6Gb RAM and a GT 220. Everything installed without problem (just usb injection needed). But now i want to update to sierra and/or high sierra . I downloaded the installer for both of them (5Gb each) on my hackintosh and tried to install the Os but when rebooting the boot loader don’t propose to boot onto install disk. El Capitan come from my old iMac (genuine system) and it can’t be update to newer Os. I would like to know if anybody have a solution to upgrade from El Capitan to a newer version of the Apple system. Thanks
×