Jump to content
gumman

[GUIDE] – HP8530p/8530w – Mavericks 10.9.1

63 posts in this topic

Recommended Posts

A few things are wrong i noticed that P-States are not where they should be so far i see 2 states 2530mhz and 798Mhz this needs to be fixed because even with my 2 batteries im getting like at a max 2 hours of battery life but with windows i had 10-12 hours before it was dead. And i just finished ordering a wifi card to replace the internal one right now so for now i must use a Linksys AE1000 which is fine for now. One other thing is that im having issues with only one more important thing VoodooPS2 does not work after sleep when setup with your instructions

Share this post


Link to post
Share on other sites
Advertisement

I tried mavericks with myhack as described in #47, I also have hp 8530w with fx770m card, my notebook boots and i see the Apple Logo for a little Moment than notebook reboots. So on 10.7.5 all is well. 

Share this post


Link to post
Share on other sites

HI!

Recently my cousin gives me a HP Elitebook 8350w notebook with Ati FireGL V5700. I read this tutorial and see that in the part one, the first thing is to chage the graphic card.

 

It is not possible to install OS X with Ati card?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi Gumman,

 

First of all thank you for figuring out the nice "how to" manual for the 8540W.

Currently everything seems to work fine, also with the latest updates so I am on 10.9.5 without major issues.

There is one thing I can't get to work, and it is not clear if this can be fixed.

I would like to connect my dvi monitor to it.

For some reason it is not working.

I tried it with a hdmi to dvi adapter on the laptop itself and also on the dvi port of my docking station.

My system has the FX770M card for video.

Any ideas?

 

thanxz,

Share this post


Link to post
Share on other sites

I have installed mavericks with alot of problems but finely it works.

My question is will all the kext work with yosemite?

 

Hi,

 

today I updated my HP 8530w to Yosemite 10.10.1. The last version of RehabMan-Battery-2014-1016 kext doesn't work perfect. 

The battery shown as working and not working. Flipping between percentage and the X. But better than nothing.

 

​Seems to be dependent what is in use in the menue, so the battery kext works.

 

Gummans AppleHDA works.

VoodooPs2 was taken from TonymacX86's "Multiboost"so it works after sleep mode.

Speedstep is fixed by editing org.Chameleon.boot.plist with P- and C-states. Reboot is faster selecting also c2, c3, c4 states, but I don't know why.

I trying to find a way for undervolting to make the more battery time. 

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the info!

However, none of the attachments in this thread are working.

Could anyone please provide me with the attachments from the first post?

 

EDIT: nm, attachments are working again!

 

Running Yosemite 10.10.3 with only minor problems: No sleep, VGA needs to be connected at boot, restart not working (shutdown does).

Share this post


Link to post
Share on other sites

[update] - Installing Mavericks 10.9 - Non Dual Booting Guide

 

After two years since starting this thread it's time for an update on how to install the latest OS X to your hp8530p/w.

Note: In this guide I only explain how to install OS X without taking care of any parallel Windows installation.

 

Requirements:

 

1.) Creating a Mavericks Installer using myhack / preparing the USB Drive

 

a.) Mount your mavericks image $something$.dmg

b.) Format your usb device with the Disc Utility as "Mac OS Extendend (Journaled)" else myhack won't detect it.

c.) Start myhack installer, enter su password, choose "Create OS X Installer" and "Create OS X 10.9 Install Disk" afterwards

d.) Choose your usb drive as volume to run myhack on, let myhack scan the system for your mounted mavericks image

e.) Proceed with the installation process.

f. ) After myhack has finished, copy the downloaded dsdt.aml to the Extra folder of the "myHack OS X 10.9 Install Disk"

 

attachicon.gif1b.pngattachicon.gif1c.pngattachicon.gif1e.pngattachicon.gif1f.png

 

2.) Install Mavericks on the hp8530p/w

 

a.) Plug the created myHack Install USB Stick into your hp8530p/w

b.) Press ESC after the hp boot prompt and F9 afterwards to choose the USB Device as boot device.

c.) In Chameleon choose "myHack OS X 10.9 Install Disk" and enter the additional paramter -v (in case something goes wrong)

d.) Wait for the setup to start... takes some time

e.) Format your HDD using Utilities -> Disk Utility as Mac OS Extended (Journaled) - Proceed with the setup

f. ) Myhack will ask you some additional questions during installation - I answered them in this combination

- Use Generic Extra that comes with myHack - YES

- Remove ApplePolicyControl.kext - YES

- Remove AppleTyMCEDriver.kext - YES

- Remove AppleUpstreamUserClient.kext - I'm not sure - I tried both.. didn't make any difference. Your choice.

g.) The setup will restart - boot the HDD in Chameleon - you can remove the usb drive at this point.

h.) Proceed with the Installation.... Done.

 

attachicon.gif2c.jpgattachicon.gif2e.jpgattachicon.gif2f.jpgattachicon.gif2h.jpg

 

3.) Driver Installation

 

a.) Navigate to /Extra/ and remove the whole folder "Extensions" and "RemovedExtensions"

b.) Copy the following files from the downloaded Extra.zip to /Extra

- SMBios.plist

- org.chameleon.Boot.plist

c.) Copy the latest dsdt.aml to /Extra

d.) Go to /System/Library/Extensions and remove the following files

- AppleHDA.kext

- AppleSmartBatteryManager.kext

- myhack.kext

e.) Extract the SLE.zip and install the following files using kext wizard to /S/L/E/

- ACPIBatteryManager.kext

- AppleHDA.kext

- AppleIntelE1000.kext

- FakeSMC.kext

- VoodooPS2Controller.kext

f.) Reboot

g.) Finish the installation of the VoodooPs2Controller Dameon (see https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller/wiki/How-to-Install). If you don't to this, your keyboard/touchpads won't work after sleep!

h.) Optional: Check if speedstep is working using the HWMonitor.app (inside SLE.zip)

 

attachicon.gif3b.pngattachicon.gif3d.pngattachicon.gif3j.png

 

Else

 

Update to 10.9.1 via AppStore is possible without any issues - just replace the updated AppleHDA.kext with the one from SLE.zip again...

 

I hope I didn't miss something...

 

Enjoy your hackbook,

Gumman

 

Thanks for this great manual - i have a problem , after finish everything , my pc will not reboot into mac os unless i use the my hack usb drive - what could be the problem ?

Share this post


Link to post
Share on other sites

Sorry for my English.

    I have a HP 8730w with t9600, fx2700m, 64gb ssd,AR9380(apple).

    First, I installed macos 10.9.5 follow your guide, but using clover 3726  to boot, with your dsdt and kext, it worked well.

 

    And then I installed macos 10.11.6  but  it  reported USB error.

 

    So I was tried to patch my dsdt,   it is working well, but battery.

 

    Could you please share your mothed to patch battery?

    

    I had tried to patch battery follow guide https://www.tonymacx86.com/threads/guide-how-to-patch-dsdt-for-working-battery-status.116102/

    it was realy hard to me.

20190709-HP8730W-T9600-FX2700M-AR9380-10.11.6zip.zip

HP 8730w-bat.rtf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×