Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sapphire 6870 on Lion?

15 posts in this topic

Recommended Posts



I successfully installed Lion 10.7.2 on my Asus P8H67-V, with Sound and Network working so far (can't be bothered at the moment with Sleep and USB3, first want to get my graphics up and running)


For this build I used iAtkos L2 10.7.2, without selecting anything before installation.


Unfortunately after the install, when I tried to boot, it loaded (showed the Apple logo) and after a while totally went black and stayed that way (screen lost signal). Initially I though there was something wrong with the build, but then realized it could be my graphics card, which indeed was the case. So I removed the Sapphire, started up with success and installed all the drivers etc. When it was time to install my graphics card, I located a 6870 kext on osx86.net (well 4 kexts in one file actually - ATI6000Controller, ATIFramebuffer, ATISupport and ATY_Init). I installed via Kext Wizard and shutdown my mac, plugged in the Sapphire and started-up. Only problem is, black screen again.


I tried: "GraphicsEnabler=Yes" and "PCIRootUID=1", but still no joy.


I saw that all XFX 6870 are supported natively, but currently I have a Sapphire (can't imagine that the two is that much different). Does somebody perhaps have a solution for me or any advice?


I would appreciate it very much :wink2:


Kind Regards

Share this post

Link to post
Share on other sites

i have the same card as you (Sapphire Radion HD6870. it works out of the box. i updated my boot loader yesterday to Chamlion1803

but worked before.


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">




<key>Kernel Flags</key>






above is what i have in my boot plist. I'm running two monitors in the dvi ports. take out the 4 kexts and put your default Ati 6000 kext back repair permissions update boot loader try booting with different frame buffers. type in the boot screen.AtiConfig= (then the frame buffer name)

try these.Pithecia, Bulrushes, Cattail, Hydrilla, Duckweed, Fanwort, Elodea, Kudzu,

Gibba, Lotus, Ipomoea, Muskgrass, Juncus and Osmunda.

Share this post

Link to post
Share on other sites



Thanks for the info! I rebuilt my whole pc (needed to for hard drive reasons) and discovered it works out of the box

I'm running my main screen on the top DVI and my other screen on the bottom DVI (dual screen setup)

I have no ATI kexts, clean build at the moment. Currently my second screen doesn't detect any signal, even though I used "Detect Displays" under Preferences > Displays. Can you perhaps explain how do I go about enabling the other DVI port or maybe the HDMI port?


Thanks for the info so far, really appreciate it!


Btw, I'm running Chameleon 2.0.0 RC5

Share this post

Link to post
Share on other sites

when i used GraphicsEnabler =yes i got two monitors but i couldn't move my mouse pointer to the right to the other monitor. so i changed it to Graphics Enabler=no. and it worked so then updated to Chameleon 1803. and just didn't check the box for the GE.

My main screen is on the bottom and the others a small 15 inch monitor using a Vga to DVI connector. as its to old and as no dvi

on the top port. not tried dp port or HDMI as not got any monitors that use it but i mite be able to try those the weekend as a friends bringing a new monitor around to me

try swopping them over. and booting with different frambuffers

also updating to Chameleon v2.1svn r 1803 mite help

i can't help you mutch i think I've been lucky with my card

Share this post

Link to post
Share on other sites

You are awesome :thumbsup_anim: I tried it with GraphicsEnabler=No, worked like a charm. Is there anyway I can perhaps add this command to boot up (not type it in every time)?



EDIT: I just went to Chameleon in System Preferences and under the "Peripherals" tab, I unticked "Graphics Enabler". Works awesome! Thanks again for all your help!

Share this post

Link to post
Share on other sites

ok go to you boot plist with text editor change graphic enabler string from Yes to No.

then try geek bench if your pc crashes reboot .go to system/ library extensions and put. AppleGraphicsPowerManagment kext . in the trash

repair permissions and reboot then try geek bench again

Share this post

Link to post
Share on other sites



I tried that, my Geekbench still crashes, but works when GE=Yes. Is there anything else I must do?



UPDATE: I installed ATY_init, but only get one screen (main) with GE=No or GE=Yes.

Share this post

Link to post
Share on other sites

@danill2008 As far as I know it's known issue that's been going on I have that issue too with my sapphire 6870 I just use GE=yes for normal boot and GE=no for when I need to run geekbench and a few other seelct apps. Unless you really need to run GB whenever you please I'd suggest that you just flick GE to no if you want to use GB and just leave it as yes by default for your normal boot.


That's my 2 cents.

Share this post

Link to post
Share on other sites



For me its the other way around. If I run "GraphicsEnabler=No", both my screens work, but apps crash (like GB). I don't care about using GB, but I do play games like Mafia 2 and that also crashes with "GE=No" and to reboot each time to play a game, can become quite annoying. If I run with GE=Yes, I can play without a hitch, but as mentioned, I only have one screen then (main).


I tried this, but had no luck: http://tonymacx86.com/viewtopic.php?f=15&t=45769&hilit=sapphire+6870


Perhaps I should switch one screen to Display Port?



Share this post

Link to post
Share on other sites

well in the thread the guy basically manually set his framebuffer to the Bullrushes (dunno if i spelt it right) fb. You could try out different fbs and see which one best suits you personally my 6870 works fine with Duckweed and Gibba although I use Duckweed personally because it sounds beter to me


To see if your fb successfully loaded just pop open terminal and type in

ioreg | grep ATY


with that you'll be able to see which one was loaded. Also if the fb you chose does't seem to give you the outputs you desire you could go and manually hexedit the values as some other users have done to get all outputs working using a given fb.


Good luck.

Share this post

Link to post
Share on other sites



Thanks for the info, I have tried almost all framebuffers imaginable and looks like the easiest solution so far, is to get an active Displayport to > DVI or HDMI adapter. So I'm going to give this a try and hope it works.




Btw, Bulrushes made my mouse lag most of the time and still didn't give me both screens. Duckweed does the same, but works perfect otherwise.

Share this post

Link to post
Share on other sites



Just to let you know. Today I got the Sapphire Active Display-port to Single-Link DVI Adapter (SKU# 44000-02-40R)


With my system already been booted with GE=Yes (wanted to check something on Geekbench) and with only my main screen running, I plugged in the adapter and immediately my second screen worked without a hassle. I'm very happy!


It really seems that getting an active adapter solves this problem on 6870 for now. Even if it gets corrected, I will always have the adapter for another screen. Already wondering how to get a third screen to work (little greedy of me icon_razz.gif )


So if you are seeking a solution (for now) as to how to get your second screen up and running on a Sapphire 6870 1Gb running Lion 10.7.2, just get an active Display-port adapter. It really isn't a waste, since you might up end up using it again in the future.


Thanks for your all your help TH3L4UAGH1NGM4N, as well as BALDY_MAN !

Share this post

Link to post
Share on other sites

No problem always glad to help out :star_sunglasses:


And if you want a third monitor you'll definetly need another active converter and it's as simple as plug and play like you did for the second monitor.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Newbie Mac
      Ciao a tutti,
      sono felicemente riuscito a installare Lion sul mio Optiplex 330.
      Funziona tutto tranne la scheda audio interna ma non importa perché vorrei installare una USB esterna: una Yamaha AG03.
      Dalle istruzioni questa dovrebbe essere installata su Lion senza driver e riconosciuta subito (http://www.yamahaproaudio.com/global/en/products/mixers/ag/manual/mac/index_en.jsp).
      Su un altro hackintosh sempre con Lion viene riconoscita perfettamente.
      Il sistema la vede, nel System Report, correttamente collegata all'USB ma da Audio Midi Setup mi dice "NO DEVICES FOUND".
      Temo che mi manchi qualche parte software per far riconoscere la scheda esterna.
      Ho installato i VoodooHDA ma mi hanno mandato in crash il sistema quindi li ho rimossi.
      Avete consigli?
      Grazie mille
      Retroman Newbie
    • By alainkalender
      Hello everyone,
      I'm new to this forum, I'm really searching for some help with my "project" and hope some of you can help me out with this one!
      It's all coming down to a not starting "Finder"
      The full story,
      I bought a Mac Pro 1.1 (2006) a few day's ago. All stock, dual Intel Xeon 3Ghz, 5GB Ram and the stock video card (256MB). (Lion freshley installed)
      I wanted to upgrade to OSX El Capitain, and after a lot of research and a lot... yes a lot of trouble in making it all work I finally got it. I've thrown in a Geforce GTX 760 2GB Jetstream... couldn't wait to get cables for powering it, so I frankensteind it all with a second PSU. Installed Lion on a Samsung 850 EVO, and then followd a tutorial on how to install el capitain using Piker's boot. 
      After 12 hours non stop messin around it worked, only after some time the mac froze and rebooted. I noticed that maby Google Chrome caused this to happen, and when using Safari it would work without any problem. I even can play 4K flawless.
      But still after some time it would crash, I monitored the CPU and Ram Usage, but there wasn't anything crazy happening at those things.
      .. didn't really got the time to instal other apps. Then I found out Finder wasn't responding. It kept on crashing. I tried a lot of things... deleting the plist files, resetting PRAM, VRAM, Savebooting, deleting cache, Disk repair (Disk Aid)... nothing worked.
      Is this maby a problem with the bootloader (Pike)?
      I hope someone can help me out!
      Thanks in advance,
      Greetings from Holland 
    • By spec3
      Qualcuno potrebbe aiutarmi con questa scheda? non riesco a farla andare su Sierra. Con la scheda riesco ad entrare nel sistema operativo ma sfarfalla tutto e ho disponibile solo una risoluzione. Sto utilizzando Clover su una scheda madre  asrock h110m hdv
    • By DenisGrusz
      Hi guys. I just try to get work my first eGPU, and unfortunetlly i have a little issue. 
      I use Sonet Echo III - D TB2 and Saphire Radeon RX480 Nitro 4g. I just install fresh system (sierra), have plug-in everything, but my system doesn't see the graphic card.
      In "This mac" ---> system report ---> PCI there is an information "An error occurred retrieving information about the PCI device." 
      I make change in the System ---> Extension ---> AMDRadeonX4100.kext and add to the strings correct ID and now it looks like: " <string> 0x67EF1002 0x67DF1002 0x67FO1002 </string> 
      I try other configuration with other order, but it still don't work.
      I really try to read a lot about this, but still can't find solution, 8 hours of research is to much for me so I decide to start new topic. 

      Does anyone have an idea what may go wrong ? Thanks for the replay !
    • By formatyourpartition
      I'm trying to install Mac OS X Lion onto a kinda old PC, the specs are:
      AMD Athlon X2 4450e NVIDIA GeForce 6150SE 3GB RAM I've successfully installed Snow Leopard on it, and then I tried OS X Lion which gives me "[ PCI configuration begin ]" and then it will give me "console 1024 x 768 @0xe0000000" if I add pci=off, I've tried Yosemite and Mavericks (and they give me the same results) but I'm trying to stay away from them as they probably don't support my graphics card, and weirdly, I've tried Mountain Lion which boots into the installer no problem but it doesn't show my hard drive, so i tried to install it onto a flash drive (which takes ages!) but then at the last moment it tells me that it was unsuccessful, so I try to boot into Mountain Lion and I get the same errors (except I haven't tried pci=off, but I really don't want to try again unless it's really needed.)
      Is there anything I can do or am I just stuck with Snow Leopard?