Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
mitch_de

FakeSMC + plugins SLICE branch

59 posts in this topic

Recommended Posts

In the last days IntelCPUMonitor (32/64Bit) , (MHz+Temp+Voltages for Intel CPU by SMC) got updates.

 

EDIT: Newer (than the attached in set.zip ) REV 505 was made 24.01.2012, LInk below ,

"Now rev505 (Version 1.0.1) with corrections for Merom and SandyBridge as well as some other tuning."

http://www.projectos...655

 

 

You can usew SMC Monitor to chek the SMC values + PSTATES:

http://www.insanelym...howtopic=247185

 

I use IntelCPUMonitor in /S/L/E.

For first tests you can use kextload to check if it works - recommended before you install it in /S/L/E

 

EDIT: Added SMC Monitor Link and removed before attached set.zip (older SMC Monitor , older IntelCPUMonitor 15.01.12)

 

EDIT: updated titile to FAKESMC slice branch

Share this post


Link to post
Share on other sites

Hello,

 

I find IntelCPUMonitor made by slice (15.01.2012)

http://www.projectosx.com/forum/index.php?showtopic=1644&st=100&p=16615entry16615

but your file is different (IntelCPUMonitor from you has 37KB, this one from slice has 82KB and different info.plist)

Share this post


Link to post
Share on other sites

I don't had to set tjmax even with older versions.

Console says at boot:

kernel: User defined TjMax=0
kernel: IntelCPUMonitor: CPU Tjmax 90

and it's working.

Share this post


Link to post
Share on other sites

Please check rev504 and report about FSBFrequency

MacBook:NewFolder slice$ ioreg -lw0 -pIODeviceTree | grep FSBFrequency
   |	   "FSBFrequency" = <00c2eb0b00000000>
MacBook:NewFolder slice$

Share this post


Link to post
Share on other sites

Please check rev504 and report about FSBFrequency

MacBook:NewFolder slice$ ioreg -lw0 -pIODeviceTree | grep FSBFrequency
|	   "FSBFrequency" = <00c2eb0b00000000>
MacBook:NewFolder slice$

 

Regis-Mac-Pro:~ regiyassin$ ioreg -lw0 -pIODeviceTree | grep FSBFrequency
| |	 "FSBFrequency" = <8de8f50500000000>
Regis-Mac-Pro:~ regiyassin$

 

im using rev504 IntelCPUMonitor.kext

 

is there something wrong with my rig?

post-572014-0-17126000-1327315992_thumb.png

post-572014-0-68384900-1327316026_thumb.png

Share this post


Link to post
Share on other sites

Regis-Mac-Pro:~ regiyassin$ ioreg -lw0 -pIODeviceTree | grep FSBFrequency
| |	 "FSBFrequency" = <8de8f50500000000>
Regis-Mac-Pro:~ regiyassin$

 

im using rev504 IntelCPUMonitor.kext

 

is there something wrong with my rig?

it happens to me also, i5-2410M

New rev505 for you

Share this post


Link to post
Share on other sites

New 505 shows frequency correctly with my Sandy Bridge system. Voltage readings are still messed up.

Share this post


Link to post
Share on other sites

Correct Vcore reading should be 1.392, memory voltage reading should be about 1.65 V.

 

post-375259-0-77203000-1327405327_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×