Jump to content

DSDT for Dell XPS L702X with Core i7-2670QM 2.20 GHz CPU, No 3D


15 posts in this topic

Recommended Posts

While attempting to get my Dell XPS 17" L702X laptop working under Lion, I have created a DSDT file for it. Now, I don't know how successful this will make anyone, but I thought I'd share it in case it helps anyone out. I have managed to get my system running with Snow Leopard 10.6.8, have network connectivity, USB, keyboard, mouse, and by some miracle it even sees the BT device! My problems stem from getting into the Lion installer successfully. Anyway, here is my DSDT (created under Windows with DSDTEditor), and system specs.


Dell XPS L702X:

-2nd generation Intel Core i7-2670QM processor 2.20 GHz


-17.3in FHD WLED AG (1920x1080)

-NVIDIA GeForce GT 555M 3GB graphics with Optimus

-Seagate Momentus 500GB 7.2k HDD

-Western Digital Scorpio Black 750GB 7.2k HDD

-Integrated 10/100/1000 Network Card

-Tray Load Blu-ray Triple Writer (reads and writes CDs, DVDs, BDs)

-INTEL6230 Intel Centrino Advanced-N 6230 and Bluetooth 3.0



  • Like 1
Link to comment
Share on other sites

Cheers Mate,


I see you also couldn't refuse an 800$ savings and a 3GB video card either haha... I am currently typing on my L1702x Bluetooth/Sound/512MB Intel HD/64GB SSD/750 HDD/1080p semi-bootable 10.7.2 system. I assume we can help each other out with future maintenance of our brand new Macx86 laptops.


I can help you with the Lion install, if you're using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], create a bootable install (laptop support if you feel it necessary) and then drop the v0.6 DSDT.aml into "/Extra" ON the USB that you created. DON'T TRY USING A DISK PARTITION! I'm currently facing difficulties configuring my Recovery Disk as I get stuck at the grey shaded screen (kind of glitches, but stays frozen)

Once I have everything fully functioning, I'll be sure to create a nice guide for all other HacBookDell users. If for some reason you can't boot the installer.. try just a "GraphicsEnabler=No" and include your bus ratio if you feel like it, if you give me the verbose result of where it freezes up, I can tell you what's wrong.


StarbucksSteve's DSDTs were funny.. I kinda gave up on them assuming that our non-3D systems kept causing KPs, I installed his kexts which I assume are functioning but didn't notice a difference from a fresh lion boot and after his kexts installed, UNTIL I installed VoodooHDA (latest) from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], and after googling a VoodooBattery, the battery meter works flawlessly.


when you install VoodooHDA (if you haven't done this before), make sure you edit the Info.plist to remove iGain from 90 to 0 since it creates an annoying hiss at boot.


Uhh what else, oh.. Bluetooth wasn't working, and I swapped DSDT's from v0.4-0.6 to my own edited versions to other {censored} with little to no success... I honestly can't explain how I got it functioning but I believe that removing the battery and power had something to do with it. The SDX reader isn't working yet, I'm using StarbucksSteve's smbios because it was so pretty and exactly what I wanted, it does 'detect' "nvidia gt 550m 1024mb" which really doesn't bother me so I don't know if I'll change it, the graphics are stunning and the video card will be supported one day (making our computer seem new once more).




Uh I hope this helps, if you have any answers to the following questions or ideas, I'd much appreciate it!


1. I wiped my Win7 and when I reinstalled ultimate edition, I can't install the wireless/gt555m/etc.. it's pretty damaged (might be because it's on a GUID part) Have you had any of the same trouble?


2. I can't install the boot loader!! i've tried various ideas such as creating a 1gb FAT32/HFS+/ExFAT part and installing chameleon with no success... (boot starts and fails), if you have a simple solution or had the same trouble, any help would be splendid.


3. Can't turn bluetooth off, don't know if you can or have a solution/care for it


4. what exactly is different with your DSDT and the 3d/Non-3d 2630? could you give me a comparison between your dsdt and v0.6? I'd love to give it a try but I'm so overwhelmed with getting this booted that I'd like to keep everything working as it is lol.



One other suggestion, the tedious snow leopard back and forth {censored} was ridiculous and I don't know if you're still dealing with it, but I'd suggest not wasting your time lol. once you have a DSDT on your usb, it'll boot just fine, and installs even better... saving you A LOT of time... the only kernel argument you need is GraphicsEnabler=No and maybe -x if it KPs, I don't really wanna mess with the bus ratio since we got SpeedStep enabled and I got above 9800+ GeekBench score (mainly because of my SSD) but nonetheless, I don't feel the bus ratio is necessary.

Link to comment
Share on other sites

My primary focus is to have a powerful laptop (since my desktop is too heavy to carry around!) that I can dual-boot between Windows and Mac OS. I still need Windows for school, but I want my Hackintosh for Adobe Creative Suite. I didn’t go with the 3D because I figured I’m not gaming with it, I want to use it for graphics creation and editing. Little did I know that Dell has “hobbled” the non-3D model – the system shows 4 DIMM slots, but only 2 are accessable! Besides that, Optimus makes it switch back and forth between the embedded video and the NVidia. I didn’t know I wasn’t getting dedicated graphics when I bought it. I’m arguing it out with Dell now, we’ll see where I get with it. I will try to address any concerns as best I can; I’ve been beating my head bloody against this (stubbornly!) since I received the laptop in late October, with few successes. I apologize if this post is too lengthy, but I’ve been working on this “science project” since then, and have had to educate myself with lots of time and failures.


1. As an IT Tech with a heavy background in PC and Microsoft, I can tell you Windows will not boot from a GUID partition, no matter where you put it.


-It’s my understanding, from a few sources, that the Dell XPS L702X WILL NOT BOOT FROM ANYTHING OTHER THAN A MBR PARTITION. I sure hope Dell fixes this in the future as they’re breaking a huge functionality point for those of us Uber geeks who want our cake, want to eat it too, even want it to be nutritious and non-fattening as well! (pardon the American idiom)


The XPS is presented as a high-end desktop replacement computer, but the bios (at least the currently available bios) limits it to Microsoft. I’m sure they’d argue that they don’t cover anything else in warranty, but I think that’s not what most geeks are interested in.


2. It’s also my understanding that Mac OS X will not boot from anything other than a GUID partition. Between the limited functionality of the bios not allowing you to boot from anything but a MBR partition, and the fact that the Mac OS X must boot from a GUID partition (specifically Mac OS Extended (Journaled)), it doesn’t leave us with many options.


I know StarbucksSteve’s “tedious snow leopard back and forth {censored}” is definitely a pain for those of us who just want to slap it on and make it work (speaking for myself), but the point is that when dealing with Snow Leopard you can’t run an update on the booted partition. It will, and does, blow up every time. I can’t tell you how many times I’ve tried to force-feed a Hackintosh setup on my XPS, unsuccessfully to date. I’ve got Snow Leopard 10.6.8 running successfully on one of the backup partitions he recommended; I can only get into it by booting to [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.2, and entering “-v -f busratio=22 GraphicsEnabler=No” each and every time. At least I have that, so I can download stuff directly to it, try different things. Until last night I didn’t know how to enable viewing hidden files and folders; now I at least managed to get my DSDT.aml file in the hidden /Extra folder (fat lot of good it did me). I got just so far before I started getting the dreaded “Still waiting for root device” error. [insert head-bang here]


3. I’m afraid I haven’t gotten as far as being able to pair BT devices. I opted for the Advanced wireless device (being Intel, won’t work with OS X anyway), but it looks like it has the same BT 3.0. When I managed to get into 10.6.8 successfully (via StarbucksSteve’s guide), the first thing it did was prompt me to configure a wireless network using the BT adapter it found.


4. I don’t really know how successful my DSDT.aml will be versus the one found here. I have also been reading a guide over at TonyMacx86 on “[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on Dell XPS17 L702X” from Starfire-1; both he and StarbucksSteve have mentioned that the DSDT.aml file needs a dual-link reference to be successful. I don’t think I found one in mine, and the best looking one I’ve found I downloaded at another Hackintosh site, OSx86.net, by “macky_reddy”. I admit I know nothing about C+ programming, so I’m clueless when it comes to viewing and editing these files. Searching it shows a lot of information, including the dual-link reference, for the embedded graphics in this XPS model.


As far as I’ve been able to find through research, I thing the primary difference between my Core i7-2670QM processor and the 2630 is clock speed, the former being 2.2GHz and the latter being 2GHz. If there is a difference other than that we should address, would someone else educate us?


I still can’t make this work, and can’t help but feel I must be missing something glaringly obvious. I’ve been able to boot to the Lion installer before, but now it simply spontaneously reboots during load, no matter where I try to boot from. I’m about to make a clean [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], edit it with the DSDT, and try again.


- I have removed 1 stick of RAM, leaving 1 4GB stick in the “first” slot (Mac OS shows it in Channel B Slot 1, with Channel A being empty)

- I have added PXHCD.kext to any booting device, but I still get “Still waiting for root device” when booting to USB 3.0

- I’ve even tried someone’s idea of entering “DSDT=/Extra/DSDT.aml” in the startup commands, no success


(By the way, StarbucksSteve has stated his guide is for installing a triple boot Snow Leopard – Windows 7 – Ubuntu on the XPS; he hasn’t written a guide for Lion)

It makes sense Lion would be the best way to go, if I could only get it to install! I’d appreciate any useful comments or directions to get me successfully through this. (starting another semester next week!)

Link to comment
Share on other sites

I have it working! WOOT! I'm using the v0.6 DSDT.aml posted under DSDTs, and using the simple guide to install on Dell XPS L702X. I used my UniBeastLE thumb drive I managed to get the DSDT.aml on, and also put the USB 3.0 kext in /S/L/E. The only way I've managed to get it to boot without all kinds of weird errors or artifacting is by booting with -v busratio=22 PCIRoot=0. That makes it work perfectly!


Following the guide at http://www.insanelym...=273500&st= seems to work pretty well; as I didn't use iATKOS I had to install VoodooBattery.kext, also borrowed a Realtek kext from StarbucksSteve's files to install for ethernet. I also installed TonyMacx86's Chimera stand-alone installer for a bootloader (such as it is with the whole broken bios thing going on).


I have audio, sleep, wake, network, graphics, even eSATA working. What's odd is that when I ran the installer my external monitor (on mini-displayport) worked as well as the laptop display panel, now in the regular Lion install I've created and configured, it doesn't seem to see the external monitor. Oh, well.


Also, the battery icon shows, but has an X in it and says there's no battery installed. Any ideas? (I still have to install Ubuntu to get the bootloader)

Link to comment
Share on other sites

search for the voodoo battery.kext on OSx86, using the latest for lion... Don't use one found on these forums as they are usually older versions for different revisions and all VoodooBattery's are the same.. it's not like they programmed one for our Dells haha. Works perfectly (in the sense that it knows what percentage you have).. don't expect much accuracy in the time gauge, mine always says 2 hours but I usually have a good 6 of browsing/scripting/and some vm usage. Your external display is likely connected through HDMI? If that's the case, than no you can't use it. The HDMI port (if u used windows at all) is controlled by the Nvidia Graphics, alas we don't have our chip enabled yet (maybe never depending on how much nvidia supports apple in the future).


You can buy an MiniDisplay to HDMI adapter for your little tiny port beside the HDMI, it's about 40$ and is powered by the Intel HD3000 Chipset (the graphics we have enabled) so no problems with compatibility! (I have my VGA monitor attached this way) If for some reason it isn't functioning, ensure that you type FN + F1 upon boot to connect the external, if it disappears in Lion, then try pressing the key combo again and toggling "Detect Displays" as it's odd for it not to work. Check your Graphics in "about this mac". your Intel HD3000 Graphics should support 512MB NOT 384MB.. if you have 384MB, then you are using the wrong graphics kext so your mini display port won't respond properly.


If you have the A12, or A14 Bios (14 is better) then you don't need to install ubuntu to "reroute your boot loader"... Mine boots fine from my GUID SSD, just make sure you install the chimera rev boot loader from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and repair permissions ONLY, anything else will cause the install to fail. Don't update the boot loader, it'll cause it to fail. I'm not sure how well booting from an MBR trick drive is, so I wouldn't suggest doing it if you have that set up. Once your able to boot from the disk, you might have better luck with your graphics port working too.


The bus ratio is really not necessary and can cause problems with TurboBoost likely disabling your 2.8-3.1GHz throttle. Intel chips are smart enough to calculate there own processing speed and I have not KP'd for over a week now without using a bus modifier. PCIRoot is unnecessary unless you have only 1 HDD and it's in the second bay and verbose is verbose.. doesn't make a difference either way.

Link to comment
Share on other sites

Well you must not have paid much attention in school lol, this should be second-nature if your in IT as I'm just about to graduate this semester from Seneca@York College in Ontario


Not to burst your bubble or anything, but I've been booting Windows 7 from GUID for over 5 years now, when you install windows to a GUID partition it must be synchronized with the MBR (GPTSYNC), there are several tutorials online, not to mention MacBooks Boot Camp partitions usually reside on the GPT. It's not hard to get windows to boot especially when were not even interested in using the Windows Boot Manager. Chameleon does the job just fine.


Err, you have a lot of loose ends here lol... I do have an MBR boot of Leopard enabled on my 750GB drive, (500 GB PART formatted as HFS+), I unfortunately can't work the boot loader as easily as with a USB but since I have my GUID SSD booting to Chameleon, it doesn't matter. So yes, you can boot mac from the MBR, again, refer to Google for tutorials if your lost, it's fairly simple with a hackintosh as making a Recursive copy of the contents to an already partitioned HFS+ part on an MBR will allow chameleon to boot from the drive.


Now I've read a ton of reports about the A12 bios not booting from GPT... if that's true, that's sucks. I suggest upgrading to the A14... I have a FULLY functioning triple boot with all my original drivers restored (turns out that Dell shipped us a laptop with the wrong driver CDs, and what's worse? they don't have the drivers on there support site.. luckily google led me to a forum who a fellow who was clever enough to back them up before wiping the drive)


The BIOS does not limit us to "microsoft" in anyway, A01-A08 only supported FAT32 booting which has skyrocketed in directions I can't explain but since A09+, Dell has always been able to boot from GUID (I also own an m1570... or 1750?, it's an old duo-core with fingerprint reader.. it's currently booting my Plex Media Server just fine from GUID)


Alas, did you have any success with Dell? As far as I know, Customer support sucks. If they offered you anything, let me know... I'd love to swindle something out of this haha...


I see you really do not have much C++ experience, lol, I didn't particularly find anything different in your DSDT.. that matters, anyway, haha sorry.... but I will be working on one to "detect our GT 555M 3GB memory" although of course it will only be a statistic, not an actual graphics driver. Uh as for your comment about the 4 Memory slots, I hope you aren't referring to the DIMM slots on your Mac, as you do realize, we are hacking the OS.. and they always show 4 DIMM's unless you configure it manually, but to be honest... it functions better thinking there's 4 DIMM slots as most high performance Macs do have 4 DIMMs and not any of there laptops and reconfiguring the dsdt or smbios to display only 2 would be a hassle, (it would be a crazy trial and error process as I believe no one has done it or cared to yet).



I plan on creating the installation guide (extensive guide describing single/dual/or triple booting) by mid february so if you need any help, just message me, I'll also be describing how to make a functional Recovery Disk as well as solving any boot problems, I'll also refer others to the Nvidia drivers that are ironically not on Nvidia or Dell's site for our GPU.


As for the DSDT and SSDT... I will edit the nicely compiled version that Steve left us for our model as well as correcting the differences between our SSDT so hopefully we can have a fully functioning sleep... apparently it's working splendidly on his model... I don't know if your lucky enough to have it functioning currently? but that may change once you boot from the HDD. I plan to have this finished by April, sorry, I'm going to be really busy this semester.


There's no reason to use USB3.0 to boot, it's a hell of a problem, not only does it occasional crash just from being a modified driver but the speed difference is unnecessary and injecting a kext to allow booting your install or drive should just scream out bad news to you.


As far the Chimera standalone installer... if you can't boot from the GPT than it isn't doing anything. don't use the standalone, it uses a newer revision and will only support your kexts in boot but will not boot your system.. Install Chimera from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 4.2.1 and take note of the Revision if it matters to you. Replace the chimera.boot.plist with Steve's, and add his legacy apple.boot.playlist just in case you need to boot into leopard again in the future. Add the DSDT if not there already... if you get KPs, remove the SSDT


The Realtek ethernet driver has NOT been customized (no drivers will ever be) for our dell so I wouldn't suggest using whichever your using, just update to the latest from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].


Steve's DSDT allows for the "QuickSet" keys to partial function so FN + F2 toggles your Bluetooth Adapter. The touchpad toggle likely doesn't work, and the monitor detection (F1) is key when having external connectivity issues. If you didn't get the TV Tuner adapter, you can get a WiFi PCI card in it's place and have both wifi cards unfortunately I have to use a USB version as I purchased and use the TV Tuner in Windows.


As you've probably noticed... It's extremely difficult to get into the Lion installer on first try... the RAM chip HAS to be removed unfortunately but I will post a way which allows you to boot from a Recovery Disk without having to remove your extra RAM although it's super easy, it's still tedious.. especially if your just doing a disk repair or something of the sort (time machine restore?)... and yah, I think that's it haha


God I hope Graphics Support comes from Nvidia but otherwise I know exactly how everything works on our machine, so if you have any specific questions or requests for support... (obviously I'm working on these damn brightness keys but since our GPU is being shafted, the Intel HD3000 definitely doesn't have brightness control so I'm thinking my chances are none to slimmer than none) but I've almost got the 3 touch keyboard shortcuts working (I don't actually know what they're for in windows haha)... try setting the [Gears] key to your System Preferences... the hot key is OPTION (Windows Key) + V... if you go to System Preferences.../Keyboard/Shortcuts/Add custom at the bottom... Type "System Preferences..." and assign it to WIN+V, when you reboot.. it should function as a nice system control panel key :)

Link to comment
Share on other sites



I'm new to all of this and a new IT student as well. It looks like I'm going to be struggling with this little project! :/


I just got Ubuntu 11.10 installed last night and it isn't even working totally smooth. First install, a graphics card driver install crashed it; kept wanting to restart and I couldn't shut down. Next, my Logitech m505 mouse is bleeping out, had a dock crash, and Firefox clicked from the dock crashed and disappeared on second install!


Yeah, so I can only imagine how crazy trying to put mac osx on here is going to be for a total n00b! :fear:

Link to comment
Share on other sites



While I have experience in the IT field, I've had none whatsoever with anything Mac, Linux, Unix, etc. to speak of until this summer. My summer project was to dual-boot my main desktop between Mac OS X and Windows 7 x64; since then I've gotten several working. The Dell XPS 17 is another matter altogether. I've worked on mine for a couple of months, off and on, and have learned quite a bit in the process (which is part of the goal). In the posts above, ssgoku129 brought up a few things that made me go back and do more research; consequently I found information that has gotten me much farther along [insert celebration/party here]. :)


I did find information on creating GUID partition mirroring for Windows 7, but I also found a guide on TonyMacx86.com to create a dual boot with both Mac OS X and Windows 7 on one drive: http://tonymacx86.bl...-os-x-snow.html. It doesn't work as perfectly as we'd like on the XPS (at least in my experience), but by cobbling together several methods I'm booting to one drive and can boot either Windows 7 or Mac OS X Lion as needed. As I have a fully functioning desktop with the Mac OS on it, I was able to create a [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] boot USB (with laptop files) to get the whole thing started, following the drive set-up method described in the dual-boot guide (partition the drive within Mac OS X setup with 2 partitions, format the first with Mac Journaled and the second partition as MS-DOS FAT). If you can create a [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB drive as described, you may have to do a few things to get it to boot into the installer, the first being to be sure you only have 1 4gb RAM stick installed, and no more! When you have the boot menu showing and the USB flash drive selected, you may have to enter start-up options (I had to use: -v busratio=22 PCIRoot=0 GraphicsEnabler=No to get it to work for me). I also had to use my desktop to copy the functioning DSDT.aml to the root of the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] flash drive.


Once the drive was partitioned, I booted to the Windows 7 installation disc, reformatted the FAT partition as NTFS, then installed to it as usual. Once Windows was installed, I booted back to the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB drive and installed Lion to the Mac OS X formatted partition. I borrowed from StarbucksSteve's guide for some of the kexts needed to get sound, and I admit I followed most of this guide to get everything else working. You have to be patient and follow it line by line, but that's what has worked for me so far. I also used his kexts and DSDT.aml v0.6, edited the smbios.plist with my Dell XPS information.


I still couldn't get it to boot from the hard drive, and spent several days with my [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB flash drive inserted, using that to boot back and forth. I did more research for "chameleon", and found TonyMacx86's guide to install Chameleon to your EFI partition. That didn't fully work, but gave me the foundation for success; I also found the Chameleon Wizard, which lets you get the bootloader installed on your EFI partition (using the menu).


The funniest part of this is if I don't have any USB flash drive or DVD inserted, I get a missing operating system error. It works perfectly when I have the Windows 7 installation disk in the optical drive; you get the "press any key to boot to cd…" message, just let it expire without touching anything. The next thing that came up is the menu screen I installed to my MACBOOT partition using the Chameleon Wizard. I can use my arrow keys to get the boot selection menu and choose my WIN7BOOT partition, or I can just let it go and it boots to Lion. I may find a way to "fix" this, but since it's working I really don't care at the moment. I have way too much homework already to worry about esthetics! :)


I found an updated BIOS on Dell's site, A16, and have created another DSDT.aml with it. I could upload it, but I don't know that it will give anything of use than the one I'm currently using from the afore mentioned "Mac OS X Lion Install Guide for Dell XPS 17 L702x". I am also using the download from here for the voodoobattery.kext, which work well for me.


I hope this helps.

  • Like 1
Link to comment
Share on other sites

Hi Jszekely,


Can u please upload A.16 bios aml or dsl anything is fine, i want to experiment with it.


I was bit skeptical in updating to A.16 as i heard a lot about problematic A.14. Were there any problems in updating to A.16 ( is it safe ?)


Best Regards,

Mahesh Kondraju

Link to comment
Share on other sites

Hi Johnw1999,


Thanks for the dump mate.


Well i applied usb 2.0 patches in my previous A.12 bios. Where as in OEM A.16 they are missing, thats the reason why usb 2.0 ports doesnt work.


I will try to apply all applicable patches to A.16 and then i let u know.



Link to comment
Share on other sites

Hi Johnw1999,


Thanks for the dump mate.


Well i applied usb 2.0 patches in my previous A.12 bios. Where as in OEM A.16 they are missing, thats the reason why usb 2.0 ports doesnt work.


I will try to apply all applicable patches to A.16 and then i let u know.




Thank you very much, I really do appreciate your work on this project!

Link to comment
Share on other sites

I will also upload my DSDT.aml, currently using it successfully under Lion 10.7.2 with Dell BIOS A16 installed.


I haven't put my second RAM stick back in yet (as I tweak things I boot into the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB drive and image my working boot to an external partition as a backup), but I have all USB ports working and functional, both 2.0 and 3.0. eSATA works, as does audio, function keys on the keyboard (haven't tried brightness control, but backlit key brightness works, as well as volume), and bluetooth. Intel HD 3000 graphics are recognized, thought it only shows 384mb RAM. It works, just haven't had time to mess with it (besides being afraid I might mess up what I have working so far).


I haven't had any perceptible problems with the new BIOS; in fact, it seems I've gotten the most success after I installed it with the most recent build. As I said previously, I have it dual-booting from a single (GPT) partitioned drive (WD 750 GB), MACBOOT as the first partition, formatted Mac OS, Journaled. WIN7BOOT is the second partition (partition 3), formatted NTFS. I know nothing about C+ programming, so if anyone sees anything of note in this DSDT, or makes useful changes to improve it, please let me know or re-post it.


Thought I'd also provide this screen shot, in case it gives any further helpful information. If you think it will help, let me know if you'd like to see my System Information.



After reinstalling the second 4GB RAM stick, the system now shows 512mb VRAM for the Intel HD 3000 graphics.



  • Like 1
Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...

  • Create New...