Jump to content
pro547

iTunes 7 - Official Problem Thread

330 posts in this topic

Recommended Posts

Advertisement

Yeah I just tried 7.0.1 and same memory error. It overwrote my version that I forced to run in Rosetta to make this work. I'm going to re-do the solution suggested in this forum and hopefully that will still work.

Share this post


Link to post
Share on other sites

the only thing that works so far is converting it to a powerpc app and running it in terminal. depressing.....

Share this post


Link to post
Share on other sites
the only thing that works so far is converting it to a powerpc app and running it in terminal. depressing.....

 

 

you dont have to run it in the terminal... read the posts, he explains how he did it.

Share this post


Link to post
Share on other sites

I think this is it, I'm finally getting a MBP as soon as the new models come out. My SSE2 machine won't cut it anymore, OSX86 has been a headache lately and this just tops it. Mark my words, this won't be the last app Apple will compile for SSE3 only.

Share this post


Link to post
Share on other sites
Time to get a new machine...

 

I think that all of us (sse2 users) are in for an update. I guess Apple is trying to make full use of their hardware to give their users a performance boost.

Share this post


Link to post
Share on other sites
I think that all of us (sse2 users) are in for an update. I guess Apple is trying to make full use of their hardware to give their users a performance boost.

 

I totally agree with you, but to be honest I just don't have the money. If I'm going to buy a new computer it's going to be a Mac, so that'll run me at least a grand (laptop). In the meantime however we just try to work with what we have, I just spent like $54 on a new graphics card which isn't too much and if it can solve my problems (at least for now) then I think it's worth it.

 

I ordered a Radeon 9800SE 128MB from eBay and I should have it by wed. so I will post my results with iTunes then. From what I've read in the wiki and forums the 9800SE will work unpatched with QE and CI so that's why I went with it, plus its really cheap. Wish me luck...

Share this post


Link to post
Share on other sites

I will be curious if the ATI card fixes your problem. Let us know. I just upgraded to 7.0.1 and it still works for me. Still think it is something to do with the graphics more than whether SSE2 or SSE3.

Share this post


Link to post
Share on other sites

The installer knows you installed a later version of iTunes so it won't let you install the older version.

 

Go to this folder and remove all iTunes receipts: /Library/Receipts

 

From Macfixit.com:

 

In order to revert to an earlier version of iTunes (if you cannot solve playback problems, or for other issues), you will need to use the following process:

 

Delete the following files:

* The iTunes 7.0 application (located in /Applications)

* com.apple.iTunes.plist (from ~/Library/Preferences)

* iTunes.pkg (from /Library/Receipts)

* iTunesX.pkg (from /Library/Receipts)

Then use the iTunes 6.0.5 (or earlier) installer.

Share this post


Link to post
Share on other sites

this is my experience...

 

i have a Semprom 2800 with SSE2, not SSE3

 

i did just the thing that earlier post have said...

 

1 - Go to /Applications and rename iTunes with iTunes2

2 - Install iTunes 7.

3 - Next go to Terminal and wrote:

cd /Applications
ditto -arch ppc iTunes.app iTunesPPC.app

4 - If you look your Applications folder, you must look 3 iTunes: iTunes (with the new blue icon), iTunes2 (with the green icon) and iTunesPPC (blue icon with a grey circle above)

5 - Right Click in iTunesPPC (blue icon with a grey circle above) and select "Show package content"

6 - There go to "Contents" and then "MacOS". You should see a file named iTunes. Copy it.

7 - Close that window. Go again to Applications and repeat steps 5 and 6 (except with the part that you copy the file) with the iTunes app (blue icon)

8 - In the MacOS folder, rename iTunes with iTunes-old and then Paste de iTunes file that you copied in step 6

9 - Close all windows and now you can run iTunes 7.0.1 from your dock

 

Hope it helps....

 

Any questions ?

Share this post


Link to post
Share on other sites
I think that all of us (sse2 users) are in for an update. I guess Apple is trying to make full use of their hardware to give their users a performance boost.

Dunno bout that, apparently, iTunes isnt so hot even amongst those woirthy of its presence.

Share this post


Link to post
Share on other sites

Hi everyone, I have a sempron that supports SSE 3, I have 10.4.5 installed. My question is, can I install iTunes 7.0.1 without it ruining everything?

 

Thanks

Share this post


Link to post
Share on other sites
Hi everyone, I have a sempron that supports SSE 3, I have 10.4.5 installed. My question is, can I install iTunes 7.0.1 without it ruining everything?

 

Thanks

 

Is 7.0 working fine, or have you never upgraded yet? We think that the problem is either related to SSE 3 support or having QE/CI enabled. You are 1 for 2 so far, if you have QE/CI already working then you probably won't have any problems. Be aware though, once you install iTunes 7 and it scans and updates your library for gapless playback your library won't be compatible with iTunes 6. Now there is a way to pull you previous library back up but I don't remember it, you should make sure that you backup your current one before you try anything. Trust me, it'll save you a lot of time.

Share this post


Link to post
Share on other sites

hi@all

 

is there a possibility to run the native/sse2 itunes 6.0.5 bsides the ppc-version of itunes 7.0.1?

so that you can choose between both versions.

 

if anyone has a solution please post.

 

thanks

Share this post


Link to post
Share on other sites

is there anyway, i could run iTunes 6 and iTunes 7 together? I want to use my 4G 40GB with the iTunes 6, my other 5.5G 80GB with the new one. before installing 7, i changed the folder name on 6, so i could use both but somehow after installing 7, when i run itunes 6, i get "iTunes Library cannot be read because it was created by a newer version of iTunes" error messages.

 

Is there any ways to have two different library files for each version?

Share this post


Link to post
Share on other sites
Is there any ways to have two different library files for each version?

You could create another user and turn on fast user switching.

 

Add a user - go to System Preferences -> Accounts, click the lock on the bottom left and give your password. Click the "+" on bottom left. Set up the new user.

 

Fast User Switching - in Accounts, click "Login Options" on bottom left. In new window, click on "Enable fast user switching"

 

Find new menu item in upper right side of screen next to Spotlight icon.

Share this post


Link to post
Share on other sites

Yea well if real Mac users are having problems with this then imagine how we are with Itunes 7. If you have sse3 then install but if you have a sse2 only processor then i suggest only installing if you need access to the new movies you can buy. and if you wan to look back at post 215. it is the ansewer to all the sse2 problems here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×