Jump to content
joshhh

[GUIDE] Lenovo ThinkPad T510/510i (plus T410 and W510) 10.6-10.7-10.8-10.9 all working OK! 2013.11.12 Update

499 posts in this topic

Recommended Posts

Just use this:

http://myhack.sojugarden.com/guide/

I've used [a process from an other forum] for my desktop but couldnt get the laptop options to work. I tried to follow the guide posted in this thread, but the link above is the easiest thing I've found. It works perfectly on my W510. Followed the directions exactly and it worked the first time I think.

 

What I do and don't have working:

 

Wifi is via USB dongle without BIOS editing

Trackpad works

Sound works with VooDooHDA

Ethernet works

Keyboard light works

Battery level works

USB 3.0 works

Webcam and mic work

 

 

Trackpoint does not

Touch screen registers as a click but not a mouse

Brightness control is not working (The only thing I really want to get fixed!)

Shutdown doesn't finish all the way (lights turn off but cpu fan still runs until forced off)

I don't even want to try to see if sleep is working right now (does not work for many hackintoshes)

 

I hope this helps. Feel free to PM me.

 

IMPORTANT: use the rear yellow powered usb port with the install thumbdrive. it's the only one that will work until the 3.0 ports are enabled.

Share this post


Link to post
Share on other sites
Advertisement

Thanks M4ng03z,

 

the tip with the rear yellow usb really helped ;)

Im writing this from my new Macbook pro ;)

The only thing not working currently is the resolution and hardware acceleration of my graphics card...

But i think i can solve that too ;)

Share this post


Link to post
Share on other sites

Well... i can´t seem to get it to work :hammer:

I have no mac around me so i have to use the iatkos ML2.

Every time i "install" the dsdt File by putting it in the extras folder the reboot hangs at PCI configuration End.

Before that the Graphics card is displayed correctly in the boot...

 

I always have to reinstall the whole thing, because i can´t seem to get it to boot up ...

 

EDIT: Finally i got it to work.

I changed the VT-d Bios setting to disabled and installed the whole thing again.

I also unclicked the nvidia drivers in the iatkos install options!

 

And whooza... that is a fast Thing! Adobe Lightroom runs like a dream!

Share this post


Link to post
Share on other sites

Is there a text based guide for getting Mountain Lion 10.8.3 on the W510 using the custom DSDTs on this thread? I don't see any new kexts posted for 10.8.3 either.

Share this post


Link to post
Share on other sites

First post here, so please be patient :-)

I have followed this guide by joshhh and now have a working T510 (4313-CTO) with 10.8.3. Everything is working except for wireless. I have purchased a Broadcom mini-pci card to use for wireless, but without flashing the BIOS I cannot install it.

Since my system is now OS X only now, I wanted to flash the BIOS back to the version joshhh has posted. However I cannot find a DOS tool to flash the bios. What and where can I find a program to do this? I have hunted the forums, however most people seem to boot into windows to load the bios, which I can't do. I can boot Ubuntu linux or DOS.

Can someone please point me in the right direction?

 

Thanks.

 

Lenovo T510, 8Gb RAM, 500Gb 7200rpm HDD, Nvidia NV3100 512Mb graphics, Broadcom bluetooth

Share this post


Link to post
Share on other sites

Try to find or make live CD/Flash Windows XP or Win7 and flash bios from it.

 

First post here, so please be patient :-)

I have followed this guide by joshhh and now have a working T510 (4313-CTO) with 10.8.3. Everything is working except for wireless. I have purchased a Broadcom mini-pci card to use for wireless, but without flashing the BIOS I cannot install it.

Since my system is now OS X only now, I wanted to flash the BIOS back to the version joshhh has posted. However I cannot find a DOS tool to flash the bios. What and where can I find a program to do this? I have hunted the forums, however most people seem to boot into windows to load the bios, which I can't do. I can boot Ubuntu linux or DOS.

Can someone please point me in the right direction?

 

Thanks.

 

Lenovo T510, 8Gb RAM, 500Gb 7200rpm HDD, Nvidia NV3100 512Mb graphics, Broadcom bluetooth

Share this post


Link to post
Share on other sites

Hi joshhh, whats up? Is there any further development or has the work on this project stopped?

 

I had several problems with my T510 and the stock BIOS, but with the modded one i have freezes, so i switched back to the stock bios. Maybe you can modify the dsdt, so i am able to use the ethernet card. At the moment i am note able to use network, i only can ping, nothing more. I used a mobile internet device (UMTS) but no chance, it doesnt work. Maybe you know whats wrong here.

Share this post


Link to post
Share on other sites

Anyone tried updating to 10.8.4 yet?

FYI: I just updated without major issues. Needed to rebuild kext cache and copy AppleHDA over again with permission fixing, and all fine (for now)

Share this post


Link to post
Share on other sites

Amazing guide, installed 10.8.4, almost everything is working perfect. Sleep, wake, etc. Had problem with bluetooth keyboard not found, but I just turned it off in system preferences.

The only problem is, when i boot from USB, i have USB 3.0 ports working fine. After installing kext package from this guide, USB 3.0 ports are not working. Only yellow and e-sata USB are ok.

 

Any suggestions? Thanks in advance:)

Share this post


Link to post
Share on other sites

hi All,

 

I'm just wondering, if someone was able to "hackintosh" a t410 with Intel HD graphic card (Intel HD Graphics, Ironlake, Intel Auburndale/Arrandale Processor - Integrated Graphics Controller [Lenovo]).

It seems, that packages attached to the first post work for NVidia graphic only. I found a DSDT which works for the Inter HD graphics somethere in the middle of the thread :)

But: the audio (line-out on the dock) does not work, the external monitor attached to the docking station via DVI can only 1280x800. The DisplayPort on the docking station no signal at all.

Is it possible at all - two external displays attached to a dock?

Thanks!

Share this post


Link to post
Share on other sites

Hello All participant to this gr8 thread
 
I need som explanation /help for installing ML on my Thinkpad T410i 2518-J3G http://support.lenovo.com/en_US/product-and-parts/default.page? (upgraded Ram to total 6GB and processor to i7 620M) with 1.44 lenovo BIOS.
I installed SL and Lion on this machine using various methods.
I purchased ML 10.8.4 on itunes and I'm triying to install it on my machine.
I used  3 methods for it but with no success!

  1. The first method with no succsess is Simple install guide for Lion and Mountain Lion
  2. The second is OSX Mountain Lion easy install guide bud I had no luck with it becouse of Terminal Error / Installer error - command line installs of OSX are not supported on system older than 10.8!!!
  3. Third method was http://www.insanelymac.com/forum/topic/284214-mountain-lion-1082-lenovo-t410-intel-hd-graphics/?p=1865583 also with no luck the installer would start and then rebooted with no kernel panic!!!
  4. The same thing is with http://myhack.sojugarden.com/guide/ !!!

What do you thing is the problem is (i'm thinking the graphics card) and how to install the ML on my Laptop??

 

Thanks

Share this post


Link to post
Share on other sites

@marko.m  

 

i dont have a 410, i have 420... but i recall some issues with ML install. i think i fixed by setting -x boot flag when bringing up the installer.

 

i am thinking since you could install SL and Lion then its not a graphics issue. Intel HD graphics is supported. 

I presume you cannot install/upgrade ML from Lion directly from your Install ML.app because it it MBR formatted? 

 

Mountain Lion Diskmaker is very reliable for installation with GUID formatted disks.

You-ni-beest (sorry) is pretty solid for installation on MBR disks.

Share this post


Link to post
Share on other sites

Hi Folks,

 

Nice to see this thread is still active. I haven't followed development on the Thinkpad Hackintosh for a while since I had a working one and lots of work to do with it. 

 

OSX on PCs give its true meaning to the old saying: "If it ain't broke, don't fix it." 

So as I was trying to fix an unbroken build of Mountain Lion, I deleted my working DSDT. I managed to get it all back and working, except one thing:

 

Screen Brightness.

 

I had it working before, and I don't really remember putting a lot of effort into it. I don't mind using the ScrLK and Pause keys, so I don't need all that fidling.

 

It seems now that no matter where I put the PNLF section in my DSDT, OSX just doesn't want to give me control of the screen brightness.

 

Anyone would have an idea of what I'm missing here? I have the PNLF section as follow:

 

Device (PNLF)
        {
            Name (_HID, EisaId ("APP0002"))
            Name (_CID, "backlight")
            Name (_UID, 0x0A)
            Name (_STA, 0x0B)
        }
    }
 
THANKS!

Share this post


Link to post
Share on other sites

Hi Im trying to install 10.8.2 iAtkos ML2 on my t410 and Im having no luck. Does anybody know what I have to select or deselect in the installer for iAtkos ML2 please Right now when I reboot after install completes it wont boot at all unless -x is used and then it never finishes and the hard drive light stops lighting any ideas thanx

 

update got it to install but need to use -x to boot do I need to replace all the kexts with an iAtkos ML2 install? I can replace extras and clear cache but when I replace the kexts it wont boot even with -x so I will install again this time replace 1 kext at a time any other suggestions would be greatly appreciated peace

Share this post


Link to post
Share on other sites

Update I successfully booted into desktop without -x, now trying to update to 10.8.4 from 10.8.2 problem is Im not sure which kexts need to be replaced I know AppleHDA needs to be replaced but what about fakecms or acpi and how do I rebuild kext cache. Thanx for any help

 

Also I could use help getting t410 intel hd kexts for 10.8.2 please really need qe and ci thanx

Share this post


Link to post
Share on other sites

@tluck 

Thanks for the answer.

well i read somewhere that the disks can be formatted as MBR if I want to instal WIndows 7 later on that same disk.

But I will try to format is as GUID to see what will happen.

Share this post


Link to post
Share on other sites

@marko.m

 

some install methods will turn off the GUID disk check will allow direct install to MBR disk. chameleon/chimera is an MBR boot loader. but if you have a 2nd disk you can install to a GUID formatted disk (using standard mac install tools) and use a tool like Carbon Copy to clone to back to an MBR Disk.  

 

Historically windows was MBR based too. but now it can boot from a GUID disk as can a hackintosh using UEFI boot mechanism such as clover and window7 efi boot loader. but thats a whole other can of worms.


@jughead1111 - there are a few basic kexts that get installed on the HD.

 

FakeSMC is number 1.

 

then you might need

 

ApplePS2Controller (or VoodooPS2controller) for mouse/keyboard.

AppleACPIPlatform rollback is often needed for better sleep

AppleIntelE1000 for ethernet

AppleHDA or VoodooHDA for audio ..

Share this post


Link to post
Share on other sites

Dear gcafrk

Can you share your DSDT file and some kext that's used on your T410?

My T410 (2522-CTO) has some problem with Fingerprint, Battery and Sleep/wake-up. :help:

Many thanks!

Sorry for late reply! Please see below link of my DSDT: http://www.insanelymac.com/forum/files/file/106-t410-nvs-dsdtamlzip/

 

My fingerprint, battery, sleep, wakeup works well.

 

This DSDT is for THINKPAD T410 with NVS3100M. It works on SL, LION, ML (up to 10.8.4)

 

Special key function:

1) ScrLk + Pause: LCD bright down and up

2) ThinkVantage (the blue key): fan control to extreme/normal speed switch

 

Needed kexts:

1) AppleACPIPlatform.kext (Version 1.3.6 on SL 10.6.8)

2) Patched AppleRTC.kext to avoid BIOS reset after restart

3) Patched AppleHDA.kext to enable sound (both internal and external, autoswitch. Please see my another download.)

4) P/S2 keyboard and Trackpad kexts

5) AppleIntelE1000e.kext to enable network

6) Patched AppleSmartBatteryManager.kext to show battery information

 

No HDMI/DP functioned codes in this DSDT.

Share this post


Link to post
Share on other sites

@tluck

thanks again for the information abut MBR.

But i'm still struggling with the installation ML.

I even udpaded my BIOS to modded one from here Lenovo-bios-t410-1.43-whitelist-removed.zip

now Im stuck on iA****ML2 method but with hte same result.

I even added Extra Folder and added kext to S/L/E from here T410-files.zip with kext wizard and repaired permissions but still no luck.

Share this post


Link to post
Share on other sites

hi Joshhh (Hi all)

 

thank you for the guide.

I'm trying (excuse my bad english and some mystake) to install ML on laptop in my signature, that have many hardware parts similar to your Lenovo T510, but but I failed with both pandora's box and Iatkos ML2. I tried with many flags (one by one and together) -X, -V, GraphicsEnabler=No, npci=0x2000/0x3000, -F, cpus=1, PCIRootUID=1, dart=0. If I copy some of the kext you gave in /Extra and /Library/Extensions and your DSDT (I know it's different from mine) of pandora installer, It should work? In this case, could you suggest me how to do? I'm a newbe of hackintosh world. Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By ludufre
      Installing macOS Catalina 10.15.4 on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/24/2020 20:30h GMT-0
      - Added 10.15.3 update instructions.
       
      01/30/2020 23:52h GMT-0
      - Added 10.15.3 update instructions.
       
      12/11/2019 04:24h GMT-0
      - Added 10.15.2 update instructions.
      - Replaced IntelMausiEthernet.kext with IntelMausi.kext.
       
      11/08/2019 20:30h GMT-0
      - Added instructions to swap Command with Option keys in VoodooPS2Controller.kext.
      - Added additional FileVault 2 UEFI drivers be more practical.
       
      10/30/2019 01:42h GMT-0
      - Added 10.15.1 update instructions.
      - Replaced AppleALC.kext with VoodooHDA.kext
      - No more issues after sleep or misconfiguration with jack sense.
       
      10/29/2019 18:18h GMT-0
      - Replaced the config.plist with AppleIntelCPUPM = true.
       
      10/27/2019 05:37h GMT-0
      - Replaced the DW1560 wireless card with BCM94360CS2.
       
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
       
      10/20/2019 18:10h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 BCM94360CS2 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
       
      - Wireless upgrade:
      Previously I have the DW1560 working almost perfectly, now replaced with BCM94360CS2 that is full native supported. 
      More info below.
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       
       

       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.6.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the VoodooHDA.kext from here. I used the version 2.9.2. (Need to turn up the volume on Info.plist, more instructions below)
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
       
      Audio volume adjustment
       
      - Open the Info.plist inside VoodooHDA.kext/Contents/ with TextEdit.app or any text editor of your choice.
      - Change:
      <key>PCM</key> <integer>90</integer> to:
      <key>PCM</key> <integer>140</integer> Or, download the versions 2.9.2 attached bellow.
       
       
      Keyboard swap Command with Option (optional)
       
      - If you prefer, you can swap Command and Option keys, to map Win Key - Command and Alt - Option.
      - Change /Volumes/EFI/EFI/CLOVER/OEM/S400CA/UEFI/kexts/10.15/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist:
      <key>Swap command and option</key> <true/> to:
      <key>Swap command and option</key> <false/> Or, download the version 2.0.4 already adjusted attached bellow.
       
       
      Wifi and Bluetooth (BCM94360CS2 + M2 NGFF adapter)
       
      Recently I replaced the DW1560 with BCM94360CS2. Now I have fully wireless and bluetooth working (including Instant Hotspot) without any kexts.
       
      See: 
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
       
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install
       
      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       

      Post installation
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      System Updates
       
      10.15.1
       
      Updated without changing or updating anything.
       

       
       
      10.15.2
       
      Before install, update the following kexts:
      - VirtualSMC.kext and all kexts and VirtualSmc.efi. I used version 1.0.9.
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      - VoodooPS2Controller.kext. I used version 2.1.0.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - VirtualSMC.kext. I used version 1.3.7.
      - VoodooP2Controller.kext. I used versions 2.1.2.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       
       
       

      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
       
       
      Attachments
       
       
      SSDT-L440.aml
      config.plist
      VoodooHDA.kext.zip
      VoodooPS2Controller.kext.zip
      Filevault 2 additional drivers.zip
    • By Georgiles
      Laptop: Asus Vivobook F510UA
      CPU: Intel Core i5-8250U
      Graphic: Intel UHD 620
      Wifi: Intel Dual Band Wireless-AC 8265 (no kexts for intel wifi) :(
      Card Reader: Realtek_CardReader(RTL8411B_RTS5226_RTS5227)
      Camera: ASUS UVC HD 7.Audio: Conexant Audio CX8050
      Touchpad: ELAN1300
       
       by parkrypto: thank you tctien342 for the amazing guide.
       
      https://github.com/tctien342/Asus-Vivobook-S510UA-High-Sierra-10.13-Hackintosh
       
      Ebayed the laptop for $290 + tax = $350
      added: 16gb RAM + existing 8GB = 24GB          Timetec Hynix IC 16GB DDR4 2400MHz PC4-19200 Non ECC Unbuffered 1.2V CL17 2Rx8 Dual Rank 260 Pin SODIMM Laptop Notebook Computer Memory Ram Module Upgrade S Series (16GB)     
      added: cheap wifi         TP-Link USB Wifi Adapter for PC N150 Wireless Network Adapter for Desktop - Nano Size Wifi Dongle Compatible with Windows 10/7/8/8.1/XP/Vista Mac OS 10.9-10.15 Linux Kernel 2.6.18-4.4.3 (TL-WN725N)     
      added: NAND 1TB Internal PC SSD https://www.amazon.com/gp/product/B073SB2MXT/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1
      Gadget Reviews upgraded too, video: https://www.youtube.com/watch?v=39EquX5PTkQ
       
      I just installed. Everything works fine. I'll test final cut pro, premiere pro with 4k footage and get back with you on performance. 
      For now moves like a performant Mac book pro. 
      I installed Catalina first but I could not make the Intel UHD 620 Graphics get proper QE/CI. 
      Mojave is just fine. I want to use this system for quick video editing on the go.
      Geekbench in my signature.  
      If you need any files or have any questions pls ask.
       






      asus f510u mojave.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (March 2020) Updated to Clover r5105 Updated Lilu based kexts - Lilu, ALC, WEG Added AirportBrcmFixup.kext
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
×