Jump to content
joshhh

[GUIDE] Lenovo ThinkPad T510/510i (plus T410 and W510) 10.6-10.7-10.8-10.9 all working OK! 2013.11.12 Update

499 posts in this topic

Recommended Posts

I had issues with this update on t410, but when i did a clean install of 10.8.2 with this update included i was able to make it work fine.

Don't ask what the difference is.

Share this post


Link to post
Share on other sites
Advertisement
still no luck :-(
Aaargggg ...

 

I just booted a Linux-Live-CD and guess what? No sound on speakers, OK could be the same problem like on Mac OS ...

 

But then I grabbed out an old harddrive, put the Lenovo Win7-Revovery on it and booted it. No sound on speakers (but on headphone) :wallbash: .

 

 

I have to admit that I never booted anything else than Mac OS on this system and that I have the laptop only since some weeks. But I never was thinking that there even was the possibility that the speakers could be defunct. I'm using ThinkPad since 15 years or so and this never happend to one of them :-(

 

Hopefully it's just the cable that is not connected.

 

 

@Joshhh: Thanks a lot for your efforts, sorry for bothering you with this and hopefully you received my small "thank you" a day ago or so ...

Share this post


Link to post
Share on other sites

I think its sense pin in sound connector malfunction. I had this problem on my old MSI PR210 laptop it didn't switch sound on headphones connection. It was pretty easy to replace it myself with soldering iron. Think this is same trouble. Only difference between them is lenovo has TRRS 4-pin but my old was 3-pin TRS

 

Aaargggg ...

 

I just booted a Linux-Live-CD and guess what? No sound on speakers, OK could be the same problem like on Mac OS ...

 

But then I grabbed out an old harddrive, put the Lenovo Win7-Revovery on it and booted it. No sound on speakers (but on headphone) :wallbash: .

 

 

I have to admit that I never booted anything else than Mac OS on this system and that I have the laptop only since some weeks. But I never was thinking that there even was the possibility that the speakers could be defunct. I'm using ThinkPad since 15 years or so and this never happend to one of them :-(

 

Hopefully it's just the cable that is not connected.

 

 

@Joshhh: Thanks a lot for your efforts, sorry for bothering you with this and hopefully you received my small "thank you" a day ago or so ...

Share this post


Link to post
Share on other sites

Hi Joshhh,

 

I think its sense pin in sound connector malfunction.
unfortunately I think you are wrong with this (see picture) :-(

 

post-293982-0-83438100-1354471860_thumb.jpg

 

Which idiot has done this???

 

Now I have to look how I get resolved this "issue", either I have warranty from the dealer where I bought the laptop used, or I still have IBM warranty. I think that audio probably never was working on this laptop, but it also is possible the the used-laptops dealer has done this, so IBM warranty will not count. And actually I do not want to send my laptop fo weeks to repair, so might be I just try to get a new speaker and replace the old one and hope, that the shortcut did not kill anything on the board.

Share this post


Link to post
Share on other sites

Hi Joshhh,

 

unfortunately I think you are wrong with this (see picture) :-(

Oh {censored}! really sad about it. Maybe possible to peel-cut wires, connect it and check if warranty is no more valid

 

 

post-293982-0-83438100-1354471860_thumb.jpg

 

Which idiot has done this???

 

Now I have to look how I get resolved this "issue", either I have warranty from the dealer where I bought the laptop used, or I still have IBM warranty. I think that audio probably never was working on this laptop, but it also is possible the the used-laptops dealer has done this, so IBM warranty will not count. And actually I do not want to send my laptop fo weeks to repair, so might be I just try to get a new speaker and replace the old one and hope, that the shortcut did not kill anything on the board.

Share this post


Link to post
Share on other sites

Fixed!

 

Was renaming by previous kext files accidentally keeping the kext extension.

 

Thank you all!

 

Battery indication works great with VoodooBattery and eSata works great too but eSata port in OSX doesn't work well with hot-plug. If OSX booted and you connect esata drive it gets detected, but if you unmount in and change physical disk in esata dock OSX won't show it until reboot

 

 

Here is "fixed" AppleHDA for Lion. If it won't help I can try to 1) unpair speakers-headphones in sound config - easy fix 2) try to change something else in config - needs deeper analysis

 

T410-Lion-fix-AppleHDA.kext.zip

Share this post


Link to post
Share on other sites

Silly question, the top of the post indicate that wireless works for T410. Do you mean the built in Centrino 6250 AGN + WiMAX with BIOS update? Or some other card?

Share this post


Link to post
Share on other sites

Non of all Intel WLAN cards works in OSX, Wi-Fi Link 1000/6100/6150/6200/6250

 

Only OSX compatible cards works with whitelisted bios from first post of thread

 

Silly question, the top of the post indicate that wireless works for T410. Do you mean the built in Centrino 6250 AGN + WiMAX with BIOS update? Or some other card?

Share this post


Link to post
Share on other sites

BT works fine with Apple HID devices Keyboard, Touchpad and Mouse. WIthout correct dsdt it gets lost after sleep sometimes and only reboot to windows or ubuntu may help to enable it again.

 

I updated first post of thread with info about supported WLAN cards

 

Thanks, that is what I thought. How about the bluetooth? Same story?. Any recomendations on WiFi and Bluetooth

Share this post


Link to post
Share on other sites

Currently running fedora 17 on my T510. I was wondering if anyone has a working mountain lion on an external bootable media (either eSata or USB stick). Also any "start from scratch" guides out there that I can use? Sorry for the newbie question.

Share this post


Link to post
Share on other sites

I'll make full step by step guide how to install OSX on Lenovos. That wold be install 10.6 -> install 10.8 from 10.6.

 

And all legals wold be is on your responsibility cause I had real MacBook Pro and have Snow Leopard Install DVD from its bundle and can use it to install. Another way you should buy it before.

 

post-120553-0-88869900-1354866109_thumb.jpg

 

More to come. Stay tuned

 

Currently running fedora 17 on my T510. I was wondering if anyone has a working mountain lion on an external bootable media (either eSata or USB stick). Also any "start from scratch" guides out there that I can use? Sorry for the newbie question.

Share this post


Link to post
Share on other sites

BT works fine with Apple HID devices Keyboard, Touchpad and Mouse. WIthout correct dsdt it gets lost after sleep sometimes and only reboot to windows or ubuntu may help to enable it again.

 

I updated first post of thread with info about supported WLAN cards

Hi there,

 

I have a T61 with Lion 10.7.5 and everything is working fine. Except my bluetooth is turned off during sleep, and does not work after sleep mode. To get it back on, I have to go into Windows, and turn it on using a Fn key.

 

Is there a way to edit my DSDT to bring it back to life after sleep? It looks like I have a Broadcom 2045, and in Windows I'm trying to find device and vendor ID. I see VID: 0a4c and PID: 2110.

 

EDIT: I added my Vendor and Device ID into IOBluetoothFamily.kext and now I can turn it on and off when it is working. However, I still lose all Bluetooth after sleeping.

 

EDIT 2: Also, I'm not sure if the bluetooth device is actually working. When I went to the bluetooth settings, a bunch of random devices were already in the device list (probably like 50-100). They all have random MAC addresses. So far I've tried adding some devices (another Windows PC, iPhone) and they seem to pair, but then I'm not able to actually do anything with either. I'll test with a bluetooth headset later today.

 

EDIT 3: Testing bluetooth with a headset and it worked fine. So that's good. Still seeing like 100 or so devices that are paired, even if I delete them, they just come back. Makes the bluetooth menu very slow.

 

EDIT 4: Remove my IOBluetoothFamily edit because the large amount of devices was making the settings app very slow. BT works without the edit, but I can't turn it off, nor can I tick the box "allow BT to wake computer." I'd rather have a faster settings app than those settings. Also with the edit, sometimes BT wouldn't connect right away (I would have to turn it on and off).

 

I'm still hoping for a solution to bring it back from sleep. Guessing that requires a DSDT edit.

 

EDIT 5: Got Bluetooth working on my own. Started with a "fresh" DSDT by booting without one. This was a little bit different than the one I found online that I've been using since the start. Sleep worked natively. Bluetooth now will wake from sleep with no problems.

Share this post


Link to post
Share on other sites

Hi all,

 

I did not found a reliable answer to this:

 

Is the "Ericsson f3507g" UMTS/3G-card supported by 10.7 if using it in my T410?

 

Thanks a lot,

Share this post


Link to post
Share on other sites

Sierra MC8780/8781 and Ericsson 3507g is working solution for WWAN on Thinkpads, so Ericsson 3507g should work with script in attachment

 

Unzip the script and place it in your root\library\modem scripts folder.

Go into system preferences and select Network

Select ‘Ericsson f3507g Mobile broadband’ from the list on the left

Click on advanced

Under the modem tab, change the vendor to ‘other’ and select ‘Dell Mobile Broadband’ from the list, click on ok

Back on the network screen, enter ‘none’ as the telephone number. This means the modem script will use the default APN. If you want to specify the APN you want to use, enter it in the telephone number field. Leave account name and password blank.

Select ‘show modem status in menu bar’

Click on apply

When you want to connect, click on the phone icon on the top menu bar, near the time. Click on ‘Connect Dell Wireless 5530 HSPA Mobile’ and you’re away.

 

mobile-broadband.zip

 

Hi all,

 

I did not found a reliable answer to this:

 

Is the "Ericsson f3507g" UMTS/3G-card supported by 10.7 if using it in my T410?

 

Thanks a lot,

Share this post


Link to post
Share on other sites
Sierra MC8780/8781 and Ericsson 3507g is working solution for WWAN on Thinkpads, so Ericsson 3507g should work with script in attachment
thank you very much for your answer, so I'll get such a card.

 

(And next week I have to send my T410 to get changed the speaker, even if it's a very little repair, I'm not allowed to fix it by my self without voiding the warranty :-( )

Share this post


Link to post
Share on other sites

Hi Joshhh,

What range of your Lap's temperature?

My Lap's FAN speed (T410) always run at silent speed, so its temp about 55*C->80*C.

Can modify DSDT to control speed of FAN without broken system as ghotic860 post about osx on w520 ?

And when connect to external display using VGA, it's not working on my Lap. I try using display port and it has same result.

Has no signal send to external monitor. What's wrong with this? (I use all most your file up at 1st page)

Share this post


Link to post
Share on other sites

Great guide. Thanks.

 

Managed to get ML 10.8.2 kinda' working on a Lenovo Thinkpad T410 2537-CD5 with Chameleon. But I had to delete all Intel/NVIDIA/ATI gpu drivers to get into the OSX GUI = no QE/CI and only 1280x800 resolution.

 

I'm kinda puzzled by this laptop. I've googled and googled but haven't found anything useful. Perhaps someone here can help me.

 

Many i7 T410 2537's seem to have dual GPUs, although I haven't found any info particularly on the 2537-CD5 model.

 

Question: Does this model have dual GPUs or not?

 

Lenovo Thinkpad T410 2537-CD5

Intel Core i7 2.66 GHz 620M

4 GB RAM

WXGA+ 1440x900 LCD monitor

 

I've tried EFIStudio with LSPCI, IORegistryExplorer, both System Info and Apple's System Information.app, lshw in Ubuntu, Device Manager in Windows XP and probably more.

 

All they find is Core Processor Integrated Graphics Controller [8086:0046] which means integrated Intel HD Graphics.

 

I'm not using any DSDT in /Extra to give more pure results.

 

Just seems a bit weird that a T410 with max options (from Lenovo) for CPU, RAM, monitor and HDD wouldn't have the better graphics as well. Equivalent of Apple selling the maxed out MacBook Pro with only Intel HD Graphics.

 

However, when looking into the raw/unedited DSDT extracted by DSDT Editor in ML 10.8.2 (only npci=0x2000 boot flag in Chameleon) I find a lot of lines mentioning Nvidia Optimus.

Scope (\_SB.PCI0.PEG.VID)

{

Name (OMPR, 0x02)

Name (HDAS, 0x00)

Method (NVOP, 4, NotSerialized)

{

Store ("------- NV OPTIMUS DSM --------", Debug)

Does this mean anything?

Share this post


Link to post
Share on other sites

I think this sub model is Intel only so no acceleration with this card in OSX

 

Great guide. Thanks.

 

Managed to get ML 10.8.2 kinda' working on a Lenovo Thinkpad T410 2537-CD5 with Chameleon. But I had to delete all Intel/NVIDIA/ATI gpu drivers to get into the OSX GUI = no QE/CI and only 1280x800 resolution.

 

I'm kinda puzzled by this laptop. I've googled and googled but haven't found anything useful. Perhaps someone here can help me.

 

Many i7 T410 2537's seem to have dual GPUs, although I haven't found any info particularly on the 2537-CD5 model.

 

Question: Does this model have dual GPUs or not?

 

Lenovo Thinkpad T410 2537-CD5

Intel Core i7 2.66 GHz 620M

4 GB RAM

WXGA+ 1440x900 LCD monitor

Share this post


Link to post
Share on other sites

@mandrean

 

it seems like your model may have Intel 5700 MHD graphics?

 

http://support.lenovo.com/en_US/?quickPathEntry=2537CD5

then click on any of the panels below like drivers and it lists the hw details.

 

i would suggest you use a dsdt to define a few things required to make a hackintosh laptop more compatible with osx.

 

for one thing you will need the gfx definition to get your monitor working to full resolution (dual-link definition)

i have the t420 with 1600x900 and without the dsdt definitions it wont bring up the display on the lcd properly.

Share this post


Link to post
Share on other sites

Hi, I would be extemely grateful for some advice on getting 10.8.2 installed on Thinkpad W510 (i7 quad core, 32Gb RAM, FX880M)

 

I have access to a Macbook running 10.7 and I have purchased the 10.8.2 download. I cannot install 10.8.2 on the Macbook as it will break certain apps which aren't yet compatible with Mountain Lion. I have tried following the easy install guide video but the terminal gives an error saying command line installs are not possible from OS X versions lower than 10.8 - is there a workaround for this? Do I need to use the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] method for this stage?

 

The other step I am not clear on is setting up the bootloader. In the W510 files download there is a Clover-Boot folder. Is this the recommended one as I see Chameleon mentioned in other posts? If it is Clover-Boot I should use then how exactly is this installed?

 

Apologies if these are basic or repeated questions - am entirely new to this.

 

Thanks very much

Share this post


Link to post
Share on other sites

Hi

I was playing with my W510 (4391-B51) a while but no success so far.

Tried step by step procedure from Simple Install guide - not working, just white screen with logo and spinner.

Managed to install system from USB created with ######, boot into installed system from USB and then make it running using ######.

System is booting, can get working keyboard and trackpad using Voodoo PS/2 from ###### (with PS2 kext from pack trackpad is working but not keyboard), also working gigabit ethernet, Nvidia Quadro FX880M.

With kext from packs I can get working battery and bluetooth and that's all

With dsdt files from first page system is not booting. Splash screen changing to more 3D-ish but that's all, just spinner spinning forever.

Installed patched BIOS - no change.

Already tried on both 10.8 and 10.8.2 - same result.

Not sure what more can I do to get it working as described.

 

Last info from verbose boot is about problems with CPU sensors kext - "failed to load", but then it says

[PCI configuration begin]

[PCI configuration end, bridges 1 devices 15]

[PCI Configuration begin]

 

so I assume problem with CPU sensors kext is probably not the reason, at least not the most important reason.

 

One - probably very basic thing - can't figure out how to apply patches from packs. Is it just something I shoult put into Extras folder?

Share this post


Link to post
Share on other sites

Hi all,

 

I seem to be struggling to find a definitive answer on this but sorry if I missed it.

 

Does qe/ci work with a lenovo t410 with just HD graphics on ML?

 

I've got my build done but ML isn't really worth it with all the odd glitches otherwise.

Share this post


Link to post
Share on other sites

Actually, my T410 (with NVS3100M) is working perfectly!!

 

1) QE/CI works.

2) AppleHDA works. Internal speaker/Internal MIC and external earphone/external MIC works, they can automatically exchange.

3) Sleep/wake-up works.

4) USB device reading/writing works well, even plugin USB HDD after wake-up, and no system crash.

5) Bluetooth works well.

6) Fingerprint works well.

7) Battery information can be shown.

8) LAN works well.

9) Firewire works well.

10) VGA output works well.

Ba ba ba ba ba ... ...

 

I patch AppleHDA and re-edit DSDT again after this Christmas holiday. Now, I can carry my T410 out for travel. I think that there is no need for me to buy a MBP.

 

Joshhh, I cannot download your DSDT from dropbox due to internet connection problem. But I am sure that some code in your DSDT for EHC1 & EHC2 need to be changed.

 

Do you consider to use my below codes for EHC1 & EHC2 in Method (_DSM, 4, NotSerialized)?

 

You may find a surprise!!!!

 

  • "AAPL,current-available",
  • 0x05DC,
  • "AAPL,current-extra",
  • 0x04B0,
  • "AAPL,current-extra-in-sleep",
  • 0x03E8,
  • "AAPL,device-internal",
  • 0x02,
  • "AAPL,max-port-current-in-sleep",
  • 0x3E8,
  • "AAPL,standard-port-current-in-sleep",
  • 0X1F4,

Share this post


Link to post
Share on other sites

Dear gcafrk

Can you share your DSDT file and some kext that's used on your T410?

My T410 (2522-CTO) has some problem with Fingerprint, Battery and Sleep/wake-up. :help:

Many thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      https://tinyurl.com/rkqmpd9
       
      --OpenCore Folder--
      https://tinyurl.com/y75hqg7z
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By BigAl
      i am getting a new lenovo ideapad 3 ( 15ADA05)
       
      1920 x 1080 - Ryzen 3 3250U - 8 GB RAM - 256 GB SSD - Windows 10 Home 64-bit - AMD Radeon Graphics - Twisted nematic (TN) - English Keyboard - 0.3 Megapixel Front Camera - Bluetooth
       
      I would love to know if its possible to put mojave  on it. i am a noob  so currently still learning and trying to gain as much info as i can.
       
      If anyone could tell me if its possible and point me in the direction that would be great
       
      Thanks in advance
      Al
    • By Isptn
      Hi I am newbie to Mac development and currently trying to get info whether a display is captured, I found such info in doc: CGDisplayIsCaptured(_:).
      https://developer.apple.com/documentation/coregraphics/1562061-cgdisplayiscaptured.
      But this one is deprecated. How can I find out whether a display is captured in other way?
      The goal is: The app should be visible only for user not for those, who see shared screen. So II need to blur the app on screen capture or send notification to user that screen is currently capturing, so I need to know which event cold notify me about that.
    • By MSzturc
      Hello everyone!
       
      I know that a lot of you are using a Lenovo Thinkpad as Hackintosh. For those i've created an Assistant Application that allows you to use all your Function Keys on your Laptop. It should be compatible to all T-, R-, X- and E-Series Models with the right Keyboard mapping.
       
      Features
      Fn+F4: Mute / Unmute Microphone Fn+F7: Screen mirroring / Screen extending Fn+F8: Activate / Deactivate Wi-Fi Fn+F9: Open System Preferences Fn+F12: Open Launchpad  
      Demo
       
       
      Keymapping
       
       
      Download & Changelog
      GitHub
       
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (March 2020) Updated to Clover r5105 Updated Lilu based kexts - Lilu, ALC, WEG Added AirportBrcmFixup.kext
        Various Tweaks over Last months The main branch in my github repo is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle seems to work on Sierra, HighSierra, Mojave and Catalina. There is an OpenCore branch in the repo as an alternative to Clover. This guide was developed for a Clover implementation. But the thread has evolved to include discussion of both Clover and Opencore for these systems: T460 and T470 family of ThinkPads.
       
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
×