Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
zEnterHacker

Optiplex GX520 Sleep Mode Issue

1 post in this topic

Recommended Posts

Hi

 

I have successfully installed Snow Leopard 10.6.8. on my Dell Optiplex GX 520 (2.8GHz/500GB-SATA/4GB-RAM/Intel GMA950).

 

Everything works fine (Ethernet, Hardware accelerated Graphics, Sound & USB, Sleep Mode)

 

Here is my problem:

I have enabled VNC Desktop Sharing and Wake On LAN in the BIOS. The Wake On LAN works perfectly from a Windows PC using wolcmd.exe and the sleeping Mac powers nicely on + however if I have made one single WOL command the MAChine will no longer enter sleep mode. It reacts on the sleep command in the Apple Menu and blanks the screen but it comes right back ON after a while.

 

If I do a reset without removing power using the Apple Menu I am still unable to bring the system into sleep mode.

 

If I shut down the system hereby completely powering OFF the Mac using the Apple Menu and then re-boot the system I am again able to bring the system into sleep mode - as long as I do not issue a WOL package from another PC.

 

I guess this is a hardware related hackintosh issue, or it could be related to the legacy kernel or the Ethernet kext.

 

Anyone else having experienced something like this or perhaps have solved a similar issue?

BIOS A11, Legacy Kernel for 10.6.8

 

/Extra/Extensions/EvOreboot.kext/

/Extra/Extensions/FakeSMC.kext/

/Extra/Extensions/IOAHCIBlockStorageInjector.kext/

/Extra/Extensions/IOATAFamily.kext/

/Extra/Extensions/IONetworkingFamily.kext/

/Extra/Extensions/LegacyAppleRTC.kext/

/Extra/Extensions/NullCPUPowerManagement.kext/

/Extra/Extensions/SleepEnabler.kext/

 

/System/Library/Extensions/AppleAC97Audio.kext/

/System/Library/Extensions/AppleBCM5751Ethernet.kext/

/System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext/

 

EDIT:

I have investigated a little more. I turns out that the BIOS enabled WakeOnLAN feature is not controlling the ability to WOL from sleep mode - it only controls the ability to WOL from a completely powered OFF mode - that was a nifty little thing to know :king:

 

One more thing:

It turns out that if I issue a WOL from an external PC and then a Shut Down command from the Apple Menu the MAChine starts to power down. I can hear a short slow down of the vents, I can see the power indicator turning yellow for a short period, but then after about one or two seconds the system powers on and reboots just like normal. Now this kind of shut down, where you can visually observe that power is gone for a short moment must cause some sort of reset on the network card, because after this cycle the GX520 is again able to enter sleep mode by issuing a Sleep Mode command from the Apple Menu.

 

One obvious thought popping up in my mind is, that maybe some sort of WOL hardware flag is not correctly cleared by the system (BIOS or IOS) after a WOL has been effectuated - and when the system then later tries to enter sleep mode (or shut down mode for that matter) - this pending flag causes the network card to power up the system again.

 

Well that was just a wild guess - any comments are welcome.

 

 

Regards

zEnterHacker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • I've tried these several methods of booting into clover, but it still skips. I even double checked that i was using your Clover folder. Bios settings should be the same too... this is getting really strange here.
    • Did you tried use ACPIBatteryManager.kext for the Battery? And for brightness you can use IntelBacklight  Both created by @RehabMan 
    • I have put it into clover drivers 64uefi folder on Yosemite thru High Sierra which allows me to edit my High Sierra disk if needed in Yosemite system.   There is no functionality of apfs in other versions but it does allow other clover bootloaders and systems to recognize the HS apfs drive or open it for inspection.   If you don’t have it you can’t see your HS drive or access it in another macOS version.
    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt


×