Jump to content
Sign in to follow this  
Followers 0
Aegisa

[Solved] Problems sleep and wake

6 posts in this topic

Recommended Posts

Hello everyone, after 2 days of trying to build hackintosh from my old pc, i finally got almost perfect hackintosh.

 

I'm running Lion 10.7.2 on

C2Quad Q6600 (socket 775)

P5K-SE (P35, ICH9)

4x 1GB DDR2 800

ASUS ENGTS 450 1GB

ALC883 onboard sound

640GB HDD (SATA2 without AHCI or SATA2 IDE)

 

And struggling to fix these problems, and still failed to.

 

1. USB storage drive (External Harddrive, and flashdrive) is not ejected properly every times i sleep my PC Solved by SleepWatcher 2.2

2. Onboard Ethernet is not working after wake from sleep. It failed to retrieve IP address from DHCP. But Apple USB Ethernet working just fine.

3. my onboard Ethernet is turned on while sleep but cant do Wake On Lan.

4. after bootup my pc shutdown and restart is working fine. After wake from sleep i cant do the restart but still can do the shutdown. Problem solved by using OSXRestart.kext (Neither EvOreboot nor OpenHaltRestart is working)

5. This is off the topic but I cant patch my DSDT to get SpeedStep working. So if any one knows how to fix this, please help.

6. Auto Sleep not working, monitor goes black but system still running. Also cannot wake it unless reboot. Worked after I replaced my onboard data controller with AsMedia ASM1061

 

And here is my Post-Installation, i case you guys needed to know for diagnostics

1. ###### with ##### + GF100 Fermi patch

2. Custom DSDT here

3. org.chameleon.Boot.plist here

4. AttansicL1Ethernet.kext here

5. SATA IDE kexts here

6. xnu-sleep-enabler here

7. AppleHDA.kext for ALC883 (working with patched DSDT) here

 

 

Thank you guys in advance :D

Share this post


Link to post
Share on other sites
Advertisement

the bug is :

 

Lnx2Mac driver : in the ga-z68x-ud3h-b3 (rev1,3) guide of Gordo74.

 

... Awesome : this driver kill the sleep/wake function, and usb ejected not so clean.

 

FIX : install realtek official driver.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Shanduur
      So let’s start from beginning. I’m owner of Lenovo Yoga 720-15IKB, with:
      i5-7300HQ Intel HD630 Intel HM175 GTX 1050 2GB (disabled) Intel SSD 660p Dell DW1820A (CN... version, working OOTB) I’ve found some configs to Yoga 720-15, but every is for i7-7700HQ version. I tried using Vesavlad’s config, and some random configs from TonyMacX86, with no luck. I’ve found, that I’m not the only person that tried that, but the second person abandoned their attempt to get it working...

      Here is what I’ve found:
      with Vesavlad’s config I can boot to installer, create APFS partition. In stage 2, after 1st reboot I’m getting this message. disabling Intel TPT does not allow me to get into installer. Nothing, just flashing black screen and back to clover and/or Windows 10 (according to boot settings). creating installer from MacOS 10.9 Mavericks works best for me. After making installer form Mojave, I was stuck on Prohibited sign.  
      What should I do, to make it working? Is there really any huge difference between config for i5 and i7? Why am I unable to boot to installer with Intel TPT disabled?
       
      My BIOS settings:
      Configuration Wireless LAN [Enabled] SATA Controller Mode [AHCI] Graphic Device [Switchable Graphics] Power Beep [Disabled] Intel Virtualization Technology [Enabled] Bios Back Flash [Disabled] Hotkey Mode [Disabled] Always On USB [Enabled] Thunderbolt (TM) Device Boot Support [Enabled] Thermal Control [Performance] Security Intel Platform Trust Technology [Enabled] Intel SGX [Disabled] Secure Boot [Disabled] Boot Boot Mode [UEFI] Fast Boot [Enabled] USB Boot [Enabled] PXE Boot to LAN [Disabled] IPV4 PXE First [Disabled]
    • By k.panic
      Hi to all!

      I've installed Yosemite on:
      - i5 4690
      - ASRock H87M Pro4 (with intel ethernet I219-V) (IntelMausiEthernet, AppleIntelE1000 and RehabMan for I219V kexts)
      - 8gb ddr3 RAM
      - 1tb hard disk
       
      If I disable I219-V from BIOS, when I shutdown it, don't reboots (tested with all kexts)
      If I enable I219-V from BIOS, when I shutdown it, the system reboots.
       
      How can I fix this? Thanks!
    • By gk12345
      Hi everyone, after lots of attempts i managed to install Mojave 14.4 on my asus zenbook ux303ub and get almost averything working, except i wasnt able to make wifi work with sleep, i replaced the intel wifi with dw1560/bcm94352z which i made to work by installing the kexts.The problem is that when i install it sleep gets affected, when i press sleep it takes 1 minute to go to sleep and when i press the power button it wakes to a black screen that is showing only the cursor and i have to force shut down by holding power button , so in order to fix sleep the only way i have found is to select "fixregions" in config.plist acpi section but then wifi stops working, it shows "hardware not installed" when i click the icon and only bluetooth works.I have tried clover config changes, patching ssdt and dsdt, usb ssdt, installing kexts in different locations but none of them seem to work , can someone help me with this?
      I attach the files below , thanks.
      debug_25741.zip
    • By RagK
      Hey , I have installed MacOS Mojave on my desktop
       I am facing issue in which the front pane USB ports on my cpu are working only after a reboot.
       
      When I start my PC after a shut down the USB ports docent seem to work as USB pen drive is not detected 
       
      Please Help
    • By BauerMac
      Hey guys,
      I hope you can help me solve a mystery.
      Even the amazing Mald0n has been working hard to help me find a solution, but now were are both stuck.
      Creative thinking or maybe just help to see the forest for the trees would be highly appreciated.
       
      PROBLEM:
      Mac will not sleep.
      Monitors sleep fine, and come back on with touch of keyboard.
      GPU and CPU coolers are constantly running on idle to low load and will not go on standby no matter what we have tried.
      Even when using full “Shut down” via apple menu the lights from the MoBo or GPU are pulsing slowly, which they normally dont as far as I recall.
      (This specific issue could possibly be solved by using ErP Ready in BIOS. Haven´t tested this since that´s a smaller issue ATM)
       
      Everything else seems to be working fine.
      This problem started appr a week ago, and I have no idea why.
      No major installs, updates or changes that I can think of.
       
      GOALS:
      • To be able to activate sleep via apple menu.
      • To have it sleep within 15-30 secs and wake up quickly (like it did before) via push on Power button

      TECH SPEC:
      • Running 10.13.6
      • Asus Maximus X Hero Wifi
      • Gtx 1080 Ti
      • 32 GB Corsair RAM
      • Intel i7 8700K
      • 2 monitors via Displayport
      • 6 internal disks (2 HDD, 4 SSD)
      • 1 external backup
      • 1 internal USB hub/SD reader
      • 3rd party Bluetooth and Wifi (Asus MB not compatible)
      • No Blutooth mouse, KB etc

      WHAT I HAVE DONE SO FAR:
      • Used Mald0n’s custom DSDT with latest config
      • IUpdated to latest Security Update
      • Updated to latest BIOS
      • Updated NVIDIA webdriver and CUDA to latest
      • Disconnected LED monitors and tested with old Mac monitor via DVI to see if Displayports were the issue
      • Disabled Adobe CC Sync
      • Run CleanMyMac
      • No start-up apps or extensions in System Prefs
      • Disk Utility: checked all disks
      • Terminal: no info on wake reason at all. (Possibly because it doesn´t sleep, hence nothing is interrupting it).
      • Blutooth allowed to wake sleep: set to OFF
      • Power manager: only setting is “never switch off monitors”. The rest are off/unchecked
      • BIOS: Tested by setting "ErP ready" to S5 > no difference
      • DSDT and EFI folder screenshot attached.

      I think that’s it - otherwise just ask
      I have read a lot of articles on this type of issue, but none with a clear answer.
      So if anyone can solve this mystery, it would be amazing!
      Thank you in advance!
       
      Bauermac DSDT.aml.zip



      UPDATE:
      Of course it was something seemingly insignificant and stupid that prevented sleep: An unfinished PRINTER job.... 
      After clearing the printer queue, it went to sleep but woke up immediately after due to a USB power issue. Possibly an internal USB/SD hub.
      Mald0n used his magic and made a new DSDT file to fix that, and now the machine is running almost perfectly apart from a fickle Bluetooth (fingers crossed).

      Hope this can help others out there with issues.

       
×