Jump to content
Sign in to follow this  
Followers 0

DELL Vostro / APIC CPU Fan fun

1 post in this topic

Recommended Posts

Hi everyone,


I am just trying to get an older DELL into life as a hackintosh. I am most of the way there, I have tried with both the 10.7 [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] / [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]:





As well as a 10.6 with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Legacy, the install is great (one minor Video driver issue, which I can fix once all is up and running :-p).


The problem, there is some issue with the IntelCPUPowerManagement, (NB: from memory here, I may have typed this wrong!!!), I am happy to try and capture logs etc, the problem is simple the CPU fan after [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], once the OS starts up shuts down :-(!!!


On a laptop this is always bad, as quickly the CPU will go into the protective thermal shutdown mode!!! This is a Vostro 1200:




With 64bit Linux I had a few issues with APIC on these monsters, and I can not remember what flags I discovered to make it work, so with a blower / fan on / under the CPU all is happy, is there any software /boot flags / etc (I have googled without success so far) to set the fan on fn=3 on the boot flags seems to work well, is there the .plist equivalent to this?


Kind Regards,



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mr.Darkwraith
      I'm having audio issues with my Dell Vostro 2520's microphone with VoodooHDA
      The internal microphone isn't detected, yet the microphone audio port is detected, and works.
      According to Windows and Dell, my laptop has the Cirrus Logic CS4213 codec in it, so if that's important, there it is.
      I am on Mavericks 10.9.5, since that works the best on this laptop, but would be open to try newer versions if things work well enough.
      I can provide my DSDT if needed.
    • By georges valch
      I hope someone will help me with this: I'm totally noob about programming and this kind of stuff. On the other side I'm passionate about hackintosh. I have a Dell Vostro 1540, mobo is hm57, proc core i5 arrandale, ddr3, with intel hd graphics. In dual boot win 8.1 and mac os 10.9, I really need a patched dsdt to get graphic resolution (cause, strange, i have not qe but ci - translucent menu bar, but no 1366x768 res). Without nullpowermanagement at chameleon boot i get kp. I attach here my dsdt extracted in windows with aida64, i really hope that some1 will help me fix it and patch it properly. Thanks in advance.
    • By mitch101
      Hi guys. I tried to install OS X today, but I can't get to the installer. I'm trying to do it off of USB with the Clover bootloader. I am not sure how to type in flags, and my laptop's inbuilt keyboard doesn't work apart from Enter and arrow keys. Plugging in a USB keyboard doesn't work. The error I get is Local APIC Error and then a panic. I don't have a camera so I can't take a pic.
      HP Pavilion dv6-3136tx Notebook
      6GB DDR3 (I think) RAM
      ATI Mobility Radeon Premium Graphics 5650 Graphics Card
      Intel Core i5 Processor
      Windows 7 Home Premium
      Just to clarify, I CAN NOT GET INTO THE INSTALLER.
    • By promo.sg
      Hello Guys,
      First of all I want to say thanks to all the developers out there and members of this forum, they are really helpful. I just completed the Quiz and I was curious to Share How to Install iATKOS L2 on Dell Vostro Series. It works well on most of them, and I tried it on Dell Vostro 1550 and 1500, leaving Wi-Fi Everything is working. Follow the steps :

      Download iATKOS L2 and write it on DVD.
      Boot from the DVD, first without using any boot flags or parameters. If it does'nt boot then try GraphicsEnabler=No or Yes. But it should boot without any bootflags.
      Go as the Installation says, if you want fresh installation, then Erase the HDD and make it GUID with desired number of Partitions (Mac OS X Journeled - Extended) and select any one of them in which you want to install Lion.
      In Customize, Check What I am saying and no other thing. Check the Chimera Bootloader and uncheck the Chameleon Boot Loader, Check Graphics Enabler, Check PS/2 under Hardware Sensors, Check Laptop Battery, you can check Voodoo HDA v2.7.3 for Audio, and Realtek RTL8111 under Wired Section for Ethernet. Thats all. Install and Enjoy. If anything is not working, I have the most compatible kexts for Dell Vostro series, unfortunnately, there is no kext for making BCM4313 WLL work.

    • By arches1
      Hello Hackintoshers! :-)
      The Credits go to Nawcom for creating the Original Atom diff and Meklort for his Injection Method!
      Also this forum here where I found the solution for the lapic_native.c problem! Thank you
      Some of you who tried to install OS X Lion on a HP Mini 110 may get the error saying that there is a Bug in the file "lapic_native.c" (like me), so I decided to apply Nawcom's diff for Intel Atom Netbooks to the Darwin 11.2.0 Source (OS X Lion 10.7.2), and add the fix used by many other HP Laptops.
      Tested on a HP Mini 110 - 3500 - Installing and running 10.7.2 (With iAtkos installer). The Kernel is 18 MB and supports 32 and 64 Bit.
      mach_kernel (HP Mini fixed).zip