Jump to content

Sabertooth X58 troubles


4 posts in this topic

Recommended Posts

Hello all. I'm having trouble installing iAtkos L1 on my Sabertooth X58-based system. I've searched the forums and tried all the suggestions I've been able to locate, but nothing seems to be working. My system:


Sabertooth X58 w AMI BIOS rev 1304

Intel Core i7 990x oc to 4464Mhz (33x135)

12GB Corsair Vengeance DDR3

5x 1TB SATA Western Digital HD (looking to install on #3)


NVidia GTS 450


So...... I've tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], iAtkos S3v2, and iAtkos L1 and all give me pretty much the same thing. The -v boot flag shows all the kexts loading until it gets to this:


Loaded HFS+ file: [system/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext]

efi_inject_get_devprop_string NULL trying stringdata

No SMBIOS replacement found

Patched DMI table


Then 2 more lines that fly by so fast I can't read them, and then a white flash and reboot.


I've tried booting with -s, -f, maxmem=2048, graphicsenabler=yes, cpus=1, and several other suggestions I found, but nothing seems to be able to get me past this point. I made sure that my BIOS is set to AHCI, so it should be seeing my drives, right? It seems like the graphical interface is about to appear when the crash happens, so I'm thinking at this point it may be something to do with my NVidia drivers. Any ideas?

Link to comment
Share on other sites

try booting with -v -f npci=0x2000


you're better off using a retail version with chameleon 2.1 or the latest chimera.

I don't use distros as they just complicate things further. I like to know WHY my system works, not just that it either does or doesn't.

Link to comment
Share on other sites

I tried all those flags with no success. The problem is that I can't get *anything* to boot - not [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], not Psystar, not iAtkos, not a retail DVD, not RebelEFI.... nothing. It all crashes with a kernel panic and throws errors about APIC and SMBIOS.


I was using iAtkos mostly because I used it with great success on my old Q6600 system a couple of years ago. Can you point me to a good guide for the method you mention? All the guides I've found seem to assume that you already have a working OSX86 installation, which is a pretty circular assumption in most cases, I'd be willing to bet.

Link to comment
Share on other sites

OK, I got it installed using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and this guide:



The first few times I tried it I got "waiting for root device" and I moved my BDR to the first SATA port, then it started working.

It's bootable now, and video is working great. Sound is *sort of* working - I can get sound from things like DVDs, but system sounds are garbled. I think the HD audio on the NVidia card is screwing things up.


My biggest problem right now is to get my wireless working so I can have some connectivity. I suppose this needs a new thread in the post-install section, but it's a TP-Link WN350GD, and I haven't found a lot of success stories about it. I tried editing the Airport kext to add the card identifier, but got a kernel panic and had to reinstall. Anybody got this card working?

Link to comment
Share on other sites


  • Create New...