Jump to content

macOS Catalina 10.15.7 on Dell XPS 17 L702x Optimus

943 posts in this topic

Recommended Posts

macOS Catalina 10.15.7 on Dell XPS 17 L702x Optimus:





1. Restore the image using Transmac. Problem with Transmac is it doesn't restore the image to a partition or volume, it only restores to the entire internal hard drive or an usb drive.


If you don't have an extra internal hard drive, then first restore the image to a 16 GB or more USB drive, then boot from USB and boot into macOS, then download & install Carbon Copy Cloner, Finally restore the image using Carbon Copy Cloner to your destination on your internal hard drive.  


2. Once restoring is done, we need to install clover bootloader to boot macOS.


Now download & install MiniTool Partition Wizard 12.3, open the application now look for your hard rive and locate a 100 MB partition or 50 MB partition named EFI System Partition (Active & System) created by Windows installer at the time of installation.


Now right click on that partition and then click on change Letter and then assign a new Drive Letter, apply the changes & close the application.


Now open This PC or explorer open the newly assigned mounted partition or volume, delete only the existing boot folder now copy paste the Boot Folder & Clover folder from the EFI folder attached.


3. That's it now you are good to go, restart and boot into your macOS partition and will be greeted with a Welcome Screen.





1. Restore the image using Carbon Copy Cloner.


2. Once restoring is done, we need to install clover bootloader to boot macOS. Mount the EFI partition using ESP Mounter Pro app and then copy paste the EFI folder attached. 


Another way is to download & install latest clover bootloader, once after installation is done just make sure to copy paste the EFI Folder attached.


3. That's it now you are good to go, restart and boot into your macOS partition and will be greeted with a Welcome Screen.




If you are on Windows make sure you have installed Windows on GUID Partiton Table or GPT not MBR.


What Works:


Everything works except for Nvidia Optimus, even Intel Wifi is working now a days no need of usb wifi dongle :w00t:.


Known Problems:


On Clover V5.1 r5131 Default Volume: Last Booted Volume not working, you have to manually select the volume and enter, whereas on Clover V5.1 r5123.1 it boots automatically Last Booted Volume. 


Geekbench Score






DELL XPS 17 L702x macOS Catalina 10.15.7.txt

Edited by mackyreddy
  • 3 weeks later...

I would very much like to try your guide; I've been trying to get my XPS "Hackintosh'd" for a couple of months now, but I guess mine is just slightly off. I don't have the 3D screen (much to my chagrin, I didn't find out the difference until after Dell's 21 day return date), and it looks like just about everyone has a 2630qm CPU (mine is 2670QM 2.20 GHz).


Do you think I can adjust/edit some of the instructions or files to work with mine? Here are my specs (if I've left something out, please let me know):



Dell XPS L702X (Oct. 24 2011):

-2nd generation Intel Core i7-2670QM processor 2.20 GHz

-8GB,DDR3,2 DIMM (Hynix 2x4GB PC3-10600S)

-17.3in FHD WLED AG (1920x1080)

-NVIDIA GeForce GT 555M 3GB graphics with Optimus

-Seagate Momentus 500GB 7.2k HDD

-Western Digital Scorpio Black 750GB 7.2k HDD

-Integrated 10/100/1000 Network Card

-Tray Load Blu-ray Triple Writer (reads and writes CDs, DVDs, BDs)

-INTEL6230 Intel Centrino Advanced-N 6230 and Bluetooth 3.0 (I know this won't work, I have a USB Wi-Fi adapter to use)



I have rolled the BIOS back to A12, will try this again. I would still like to know how to handle the different CPU, I think it's the same class, just faster (2.20GHz).

Hey Jszekely,


Sorry mate for a late reply i was on a holiday. Well ur processor 2670 QM will not create any problems, u can use my DSDT even though u have an A.14 bios. Just dont use my SSDT (as its highest p-state will be clocking at 2.00ghz, as we have 2630qm with 2.00ghz but u have 2.2ghz, So u have an extra p-state which will be missing in my SSDT).


Just follow my guide u can easily install hackintosh on xps 17 l702x as rest of the specs are same. well there is no need to backport to A.12 bios. Just copy my DSDT in ur lion partition and lion only picks my DSDT not OEM DSDT.


let me know if u have any problems with the installation.


Update: I just forgot to tell something that i added bustratio of the 2630qm processor (which is 20 ) as default in the org.chameleon.boot.plist, just check ur busratio on the intel website and change it accordingly.


Here u go just use these edited org.chameleon.Boot.plist and smbios.plist ( for ur Intel 2670 QM Processor) and u can use all my kexts & DSDT ( but dont use my SSDT).


That's great! Thanks so much!


My bus ratio is 22, which I've already edited (I have at least figured out how to do that much!).


I am trying to learn as much as I can, but I haven't found any information anywhere on how to interpret or edit a DSDT file. I appreciate those of you who have taken the time to post help for the rest of us (even if we can't appreciate monetarily!)

Hey Jszekely,


Instructions for extracting and creating ur own DSDT from windows 7


download this app DSDTEditor_Linux_Windows from this link






download and install latest Java run time, then run this app DSDTParser



go to file menu run Extract DSDT



go to IASL Menu run compile



fix errors ( some times it doesnt fix errors automatically)



Again go to IASL Menu check whether u can save DSDT.aml ( if yes all done, if not then u need to fix those errors manually so first save ur DSDT.dsl from file menu and then check the errors in the code, for which u need the knowledge of c++ and a bit of previous experiences with DSDT, give it a try. )

Just trying to use the DSDTParser as instructed, have run into the following error:


		    Method (_DSM, 4, NotSerialized)
			    If (LEqual (BRID, One))
				    If (LEqual (Arg0, Buffer (0x10)
							    /* 0000 */    0xF8, 0xD8, 0x86, 0xA4, 0xDA, 0x0B, 0x1B, 0x47,
							    /* 0008 */    0xA7, 0x2B, 0x60, 0x42, 0xA6, 0xB5, 0xBE, 0xE0
					    P8XH (Zero, 0xF5)
					    Return (NVOP)


As you were kind enough to share the previous files with me, I don't see this as a huge problem; I just wanted to give it a try. If you have an idea or suggestion for me it will simply help me learn more about it. (By the way, I LOVE this tool! needed it for awhile!)


-In your original instructions, there is no link for iAtkos L2 (or should I just search for it?)

-Does this guide assume you already have Mac OS X 10.6.x installed, or will this install Lion from scratch?


Sorry for all the questions, but thank you for your help!

We dont need snow leopard all we need is windows 7 to get fully functional hackintosh (iatkos l2 just google it u can find it easily). Download iatkos l2 and burn it to a dvd, then follow my guide.


Regarding ur DSDT error, i think there is no need to declare the arguments arg0 twice, give it a try and rewrite the code as



/* Arg0



Arg3 */



So the final code will be




Method (_DSM, 4, NotSerialized)


If (LEqual (BRID, One))


If (LEqual (Arg0, Buffer (0x10)


/* 0000 */ 0xF8, 0xD8, 0x86, 0xA4, 0xDA, 0x0B, 0x1B, 0x47,

/* 0008 */ 0xA7, 0x2B, 0x60, 0x42, 0xA6, 0xB5, 0xBE, 0xE0



P8XH (Zero, 0xF5)

Return (NVOP)

/* Arg0



Arg3 */



if it still gives error then then delete this section, hopefully either one will be executed




Hi Jszekely,


Nice to hear that error has been fixed.


Regarding uploading it, its ur choice mate if u feel like helping the hackintosh community then just start a new thread stating xps 17 with 2670 qm processor DSDT. Hopefully some other newbie's or starters can get a jump start in installing lion.



<EDIT> : Got it working ! I juste deleted all the kexts from the windows side (read closely which ones to delete and which NOT) with macdrive and after installing those from the pack reinstalled chameleon using chameleon wizard.

Now it boots relatively fast and i just have a 1 sec light blue screen before the identification screen !

Still there are some strange bugs, like some glitchy artifacts here and there, once the whole screen froze (with exception of the mouse icon, which could be moved freely) and the sound is all but perfect...

But Hey ! Mac on a laptop working this great is just impressive !

thanks for the Tutorial !



after following your guide on step 7 i have restarted whit out installing cameleon 2.1


And when it boots up after a couple Min on apple logo and spinning wheel all i get is a clean blue-ish screen and nothing happens


any idea?


Same here (but with the latest chameleon), got it working once (the blue screen passed after 2 secs) and had some artifacts and glitchs on youtube videos..., but then tried it like 10 times and nothing but this blue screen :/ i think it's a problem with the AppleIntelSNBGraphicsFB.kext, cause when I delete it from windows (with the caches) everything works (in 1024x768 mode)


Any help or guidance ? still a noob...

Thanks for the tutorial by the way !


@ Neverdie , Deadsmile


Make sure u delete kernelcache and also nvidia geforce & fermi kexts. Make sure u delete them otherwise u will have conflicts between video cards. With nvidia kexts present in s/l/e nvidia card detected in system profiler but its not activated due to the absence of optimus. so i guess blue screen problem mght be isssues from nvidia kexts and kernelcache.


Intel hd 3000 QE/CI works only when installed from lion desktop with the help of kextutility.app. so if u cant boot go to windows and move the AppleIntelSNBGraphicsFB.kext to safe location, delete the kenelcache, delete all nvidia kexts also intel gma kexts 950 x3100 HD ( dont delete 4 hd 3000, integratedframebuffer, snvb, snba we need this 7 kexts) restart and login to lion, u will be greeted with a 1024x768 screen resolution, now install the AppleIntelSNBGraphicsFB.kext with kextutilty.app, after successful completion, just run the kextutility.app again it will fix all kext permissions incase if something gone wrong while installing AppleIntelSNBGraphicsFB.kext.


Hope this helps, give it a try.




Nice to hear Deadsmile that its working, those artifact problems i think apple still have poor graphics drivers, they need to optimize them. Hopefully in the future updates of lion.






Hi I have a HP DV7 6140 http://h10025.www1.h...144916&sw_lang=

I have a complete DSDT without errors.

I want to instal Lion with your method.

Will I have a problem with Intel HD 3000 graphic card?



Why not give it a try, lets see whether my guide works on hp laptop or not.

Thanks to your guide, kexts, DSDT and help I have finally been able to get Lion installed on my non-3D XPS! I wasn't able to use iAtkos, but have already purchased Lion anyway. I installed using a UniBeastLE USBInstaller I'd created on my desktop Hackintosh, but since trying this my system always either froze or spontaneously rebooted in the middle of it. I'd read somewhere about using "PCIRoot=0"; since I figured I had nothing to lose I tried it. IT WORKED! I didn't need GraphicsEnabler=0, just -v busratio=22 PCIRoot=0.


I followed the rest of your guide (with the exception of using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] Lion Edition to install FakeSMC and utilities). I also used the Chimera stand-alone installer from TonyMacx86.com. I even have sound now, beautiful! One odd thing: before following your guide I had an external monitor working, now it's not (in the regular install of Lion I configured using your instructions). I boot back into the Lion installer, and it works again! Go figure....


I used a VoodooBattery.kext, but it's got an X on it, and states there's no battery installed. Any ideas? Of course, I'm grateful to have the functionality I do here, anything else is just gravy. Oh, and sleep/wake seem to be working now, too.

@ Mahesh



i have an xps l501x which share the same webcam with the xps l702x and my problem is that the webcam is recognized by the system but doesn't work in photo boot , FaceTime, ichat or Skype.

I know you said it works job with your dsdt, is there anything i should add to my dsdt to make it work.




P.S: i am attaching a screenshot of system information the USB part where you can see the webcam is there.


Thanks for the guide


I have a l702x with 3D


So far I just installed iatkos l2


I did select graphics enabler and nvidia gf100 driver in addition to the ones listed above. Given that Optimus is disabled on mine, most of the stuff works out of the box (including native resolution).


Everything works well except sound and speedstep


Hoping to install the Kexts and make config changes tonight.

Hi Wen1,


U can extract SSDT using aida64 software on win 7. Well there will be SSDT SSDT1 SSDT2 ... just check for cpuPM with APSS code.


Then i compiled it to SSDT.dsl on lion 10.7.2 with the help of iaslMe app.


On windows 7 my 2630 QM SSDT was providing 9 turbo states ( starting from the lowest p state 800mhz).


But i tweaked it so that the turbo states are recognized properly in lion with the help of few hackintosh forums and blogs check these links for assistance http://revogirl.wordpress.com/ http://www.insanelym...howtopic=259090 and also u need to have the knowledge of C language and also in case if u want to manually define changes in the source code then u need to compile to make file in linux, so knowing linux terminal coding will be added support.


Most important thing is check ur p states on lion using MSR dumper ( http://www.insanelym...howtopic=258612 ) and make neccessary changes to ur code in SSDT.dsl and compile and generate SSDT.aml and then patch intelcpupowermanagment with aicpum check this link for instructions http://www.insanelym...howtopic=258611.



Mahesh Kondraju


@ wen1


As u said u have a 3D version laptop and my guide will help people with intel hd 3000, i would recommend u to check the guide from steve on tonymacx86 forum check this link http://tonymacx86.co...pic.php?t=23185 hopefully it helps.

I installed this chameleon version: Chameleon 2.1svn r1801

I am sadly still getting boot0: error messages, this is my Chameleon Installation Log:


Chameleon installer log - Fri Jan 20 17:10:11 CET 2012

Installer version: 2.1svn 1801




0: FDisk_partition_scheme *500.1 GB disk0

1: DOS_FAT_16_Hidden 106.9 MB disk0s1

2: Windows_NTFS RECOVERY 21.0 GB disk0s2

3: Windows_NTFS System 236.2 GB disk0s3

4: Apple_HFS Mac OS X 52.4 GB disk0s5



0: Apple_partition_scheme *4.7 GB disk1

1: Apple_partition_map 32.3 KB disk1s1

2: Apple_HFS iATKOS L2 4.7 GB disk1s3


Backing up Chameleon files

Backing up stage2 file /Volumes/Mac OS X/boot to /Volumes/Mac OS X/Chameleon.Backups/2012-01-20-17h10/boot

Backing up /Volumes/Mac OS X/Extra folder to /Volumes/Mac OS X/Chameleon.Backups/2012-01-20-17h10/Extra


Clearing options...


Running Standard postinstall script

Target volume = /Volumes/Mac OS X on /dev/disk0s5

Target disk already has existing Chameleon stage 0 loader - boot0

Detected a Windows installation on this volume.


Stage 0 loader not written to /dev/disk0.

Written boot1h to /dev/rdisk0s5.

Written boot to /Volumes/Mac OS X on /dev/disk0s5.


Preparing to check target disk for previous installations.

Checking disk0.

Nothing found that could cause any problems.


Disk: /dev/rdisk0 geometry: 60801/255/63 [976773168 sectors]

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec [ start - size]


1: 16 1023 254 63 - 1023 254 63 [ 127 - 208718] OS/2 hidden

2: 07 1023 254 63 - 1023 254 63 [ 212992 - 40945538] HPFS/QNX/AUX

3: 07 1023 254 63 - 1023 254 63 [ 41172992 - 461324143] HPFS/QNX/AUX

4: 05 1023 254 63 - 1023 254 63 [ 502497135 - 102400145] Extended DOS

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec [ start - size]


*1: AF 1023 254 63 - 1023 254 63 [ 502497280 - 102400000] HFS+

2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused


Windows is installed so that can remain the active partition


Standard script complete


Added boot option: UseKernelCache=Yes

Added boot option: GenerateCStates=Yes

Added boot option: GeneratePStates=Yes

Added boot option: Graphics Mode=1600x900x32


Running Post postinstall script

Target volume = /Volumes/Mac OS X


Unmount all volumes named EFI


Post postinstall script complete



Some advice on how to fix that would be great :-)

  • mackyreddy changed the title to macOS Catalina 10.15.7 on Dell XPS 17 L702x Optimus
  • Create New...