Jump to content
barney-geroellheimer

GeForce GTX460 and CUDA

3 posts in this topic

Recommended Posts

Hey,

 

I'm now running my hackintosh for about a year and now I tried to use some CUDA-Software. I installed the CUDA driver shortly after the Lion installation but now I tried some software. CUDA-Z shows the Card correctly as the "GeForce GTX 460", but I tried to use Blender (with Cycles Render Engine using CUDA) and Adobe GPUsniffer, which both didn't found any CUDA device in my system.

 

Then I updated the CUDA driver to the current 4.0.50, but no change. Also I saw now that the card is shown as "Unknown nVidia card" in System Information. OpenCL instead of CUDA seems to work in Apps supporting it.

 

Does anyone have an idea what could go wrong here and what's the best way to tackle with this? What additional information about my system could be helpful?

Share this post


Link to post
Share on other sites
Advertisement

Does CUDA-Z shows benchmark values in the performance TAB?

If yes then CUDA is running in general on your system.

It may a problem of your used apps (Blender / Adobe) , not CUDA itself.

TOAST 11 uses CUDA if you convert an video into h.264.

 

Also some Blender / cycles engine builds may NOT have CUDA aktivated.

perhaps try:

http://graphicall.org/511

Share this post


Link to post
Share on other sites

The GTX 460 doesn't work with the Mercury Engine right away because it's not on the list of supported cards - there's no GTX 460 for Mac.

Here's how to add it: http://www.insanelymac.com/forum/index.php?showtopic=223244

Maybe you have to do something similar to get Blender to work.

 

"Unknown video card" just means your injection method doesn't know the device ID of the GTX 460. It normally does not make any difference as far as performance is concerned.

 

GTX 460 works with Chameleon GraphicsEnabler, if you want to see the info in System Profiler then trash your current injection method and use GraphicsEnabler instead.

 

There is one caveat; If you ever have to boot any Snow Leopard install media, remember to type GraphicsEnabler=n on the bootprompt, otherwise it will boot with no video. This happens because the drivers that ship with Snow Leopard has no support for Fermi architecture cards (no GF100Hal.kext).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      UPDATE 05/17/2018
      new cuda release (thanks to phi777)  New!
      CUDA 396.64
       
      previous releases:
       
       
    • By stauff
      Hey-ho hackintosh scene!
       
      There is a need for us to test a lot of Mac configurations of a really stressful GPU-based app. The app contains cool GFX, tons of metrics, it can crash your GPU, CPU, Mac, etc. Of course if drivers are fine then nothing like this will happen. If not.. then we really want to help Apple fix those drivers by giving them feedback using special channel that's open to us for some time. And we need you guys to help us.
       
      So - the app is called FractalArchitect and you can download it for free from MacAppStore. Also if you want to test CUDA be sure to mail support@fractalarchitect.net for your special exectuable. 
       
      The test cases are pretty easy. Download app. Start it. Click 'Free GPU trial', and try OpenCL/Metal/CUDA rendering with 4 sample fractals. If everything is fine you can capture your performance metrics (when you render fractal second time, as first time it also counts compile time). if not - please leave bug-report in this topic.
       
      For people with iGPU/descrete - do tests of both GPUs. Any cool cases (eGPU) are welcome.
       
      Let the tests begin. 
       
      P.S. You can share any super cool fractals you created here as well.
      P.P.S. Just to clarify. This is _not_ my application. I just serve as a proxy that will channel the bug-reports to the right people inside Apple. The author of the app will keep an eye on this post as well but in _no_ way this is an advertising. The app is a Rosetta stone for compute testing. And that's it.
      P.P.P.S Do not search bugs inside app. You guys are _not_ beta testers of it. You test your GFX/Compute drivers.
    • By arathorn2nd
      Hello there!
       
      I'm considering updating my trusty nVidia GT 640 for a newer pascal card. I've found one that seems to be recommended for its good support with nvidia web drivers:
      GIGABYTE GEFORCE GTX 1050 TI 4GB GDDR5 128BIT, GV-N105TD5-4GD
       
      The question is, does anyone knows if CUDA and cudNN works with the web drivers? I'm currently working on neural networks using TensorFlow and that would be a requirement for me.
       
      Anyone using CUDA with a pascal card?
       
      Thanks a lot!
    • By Vengeance1020
      I have a GT 130M in my notebook and I am running full graphics just fine in native drivers and GeForce drivers (GeForce work better in my system) and I was wondering if there is any CUDA drivers or support for my model GPU? My GPU supports CUDA but in System Settings > CUDA, it shows that the GPU is not supported. I am running my GPU under DSDT (works just fine without the DSDT patch for the GPU, I just added it for better performance, but it seems to work the same either way, just the detected name is different and some data isn't detected [without DSDT patch device comes up as "HP GeForce GT 130M" and with DSDT it comes up as "nVidia GeForce GT 130M" with device ID's and PCI slot connection]). I don't really need the driver YET, but since I am gonna want to do video editing and 3D animation, I'm sure CUDA would help very much. If its not supported or there is no way to get it to work, then please guide me on how to uninstall?
    • By jstancil
      I have a hack up and running, installed 10.10.5 following RampageDev's clover installation...for the most part.  Everything is working except sound, which I get around by using USB.  I installed the NVIDIA drivers from here, used 10.10.5 V1.  Here is the hardware list
       
      ASUS Sabertooth X79
      i7 - 4930k
      GeForce GTX 770
       
      I go to download the CUDA drivers in the link from the same guide, get them installed.  Now every time the machine boots up or I try and go to the CUDA panel in system preferences I get this error, "You can't open CUDA Preferences preferences pane because it doesn't work on an intel-based Mac."  Not sure what gives.  Any ideas?
       
      I boot with nvda_drv=1 and everything else seems to function fine, just can't get CUDA rolling.  It's a problem because I use DaVinci Resolve.
       
      Any help is greatly appreciated.  Let me know if I left out any pertinent info.  Thanks!
       

×