Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

HP 210-3000 Atom N570 mostly running 10.6.7

1 post in this topic

Recommended Posts

I have mostly successfully installed 10.6.7 on a fairly new HP 210-3000 with an Atom N570 (dual core with multithreading). In case anyone wants to do something similar, I'll set out what I did:


For the most part, I followed the same instructions for installing it on a HP 110 at:



Before I did that, however, I used gparted to create a new HFS partition (so I could leave windows installed in case I needed it). I also tried to install various other versions of OSX without success (I'm not saying other versions cannot be installed, just I spent many hours installing and re-installing without success).


I was forced to vary slightly from the above instructions to get things working on the 210:

  • USB in 10.6.3 - unlike in the instructions above, 10.6.3 recognised the 210's USB, which meant I didn't have to fiddle around in windows to download the appropriate drivers and updates;
  • Netbook Installer failed - when I tried to use Netbook Installer on my 10.6.7 system, it inevitably screwed it up. In the end, Netbook Installer wasn't going to provide much, so I avoided that last step.
  • No USB in 10.6.7 - One thing Netbook Installer would have done is to re-enable USB under 10.6.7. Instead I used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]'s USB restore function.
  • My 210 has an Atheros AR9285 wifi card, and drivers exist for it! Unfortunately I went through several before I found one that worked. In the end, the next from this package got me online: http://www.osx86.net/downloads.php?do=file&id=1279. After installing the kext, I had some trouble connecting to my network, the fix was to change my wifi from mixed, to just 802.11G. After that, it has worked fine.


So I now have a HP mini 210 running a (mostly) working 10.6.7. Unfortunately many things are far from perfect. My netbook still experiences the following limitations:

  • No control over sound volume - while I have sound, it is impossible to turn the sound down, or even mute it;
  • No control over screen brightness;
  • No control over power use (this and the previous point mean that my 210 has an OSX battery life of 5 hours, rather than the 10 hours it gets under windows);
  • The trackpad is functional, but overly sensitive, and doesn't support scrolling; and
  • No sleep or hibernate.

I understand that most of these fixes probably require diving into DSDT. I cannot seem to get my head around DSDT at all. I also see that it relates to the computer's BIOS, and get very afraid of causing permanent damage.


I hope this will help someone, and I would appreciate any help or suggestions to resolve the last few limitations.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ericerk
      Basically I need some help.
      What would you reccomend, what do you think is the best cheap laptop to hackintosh?
      The end goal is running 10.6.8 - 10.7 with Logic Pro 9 as the main application running, wifi and everything else is less important to me.
    • By wynntom
      ...it shouldn't be this hard!
      I am trying to clone a functional Hackintosh HDD (OSX 10.6.7) to a new OCZ Vertex 3 120GB SSD on my Dell Mini 10v, using Carbon Copy Cloner and various bootloaders (tried one after another) to properly prepare the new drive. CCC cloned just fine, but when inserted into the Dell, the SSD gets stuck at the Apple logo / icon.
      When loading Mulitbeast w/ Chimera: Apple Logo is stretched, like it's not displaying correctly. No spinning pinwheel. Booting with a -v flag starts verbose mode (with a grey background screen), but then quickly disappears into a black screen and freezes with no verbosity. I think the last several lines that are displayed before blackness starts with "UHCI Controller: ..."
      When loading NetbookInstaller 0.8.5pre, the Apple logo is correctly displayed and I get a pinwheel, but it stays like that indefinitely. I am, however, able to boot in verbose mode. Here is the screenshot where it freezes.
      I have also tried several Chameleon bootloaders, but none work. I was expecting to use some of the great software many of you have written and contributed to, so I'm baffled as to why this won't work. Ideas? Thanks very much in advance, you Gods of Hack.

    • By swparkaust
      I tried to update my machine from 10.6.3 to 10.6.7 by downloading the combo package from Apple website and then running it.
      However, I found out my computer hangs during the progress and shows kernel panic for unknown reason.
      The computer obviously does not boot after this. I was forced to re-install Snow Leopard (I use iATKOS S3) over again.
      There was no SleepEnabler.kext in both /Extra/Extensions and /System/Library/Extensions which others from the web told to remove in order to avoid KP.
      I also tried installing 10.7.0 Legacy Kernel before running the combo installer but the result was the same.
      What could be the reason in this case? I have no idea since the KP does not give any useful information...
      Here is my configuration:
      Manufacturer: DELL
      Model: Vostro 330 AIO
      CPU: Intel P6200 @ 2.13GHz
      Chipset: Intel HM57
      Graphics: Intel HD Graphics (Arrandale) - PCI
      Sound: Realtek HD Audio (ALC272)
      LAN: Realtek RTL8168/8111
      WLAN: Atheros AR9285
      RAM: 2GB DDR3
      the installer says "Registering updated components" when the computer gives KP.

    • By Alien1959
      Hello everyone, first of all, apologies if I have made a duplicate thread regarding this issue, for I have searched this forum (and others) extensively and have not found any proper thread addressing this issue.
      Secondly, I want to thank the awesome osx86 community, especially Nawcom, Kabyl and Mohamed. I don't know how you guys did it, but you guys are brilliant. Genius.
      Back to the topic, I have managed to install Snow Leopard 10.6.7 on my AMD System. Vanilla install used Nawcom BootCD.
      Wrestling with error codes during boot and changing kexts which a tiny change may cause my whole system to not boot and give me a panic attack (I've been trying this for a year. So its no surprise when something goes wrong I start to freak)
      But I've noticed, is there no functioning sleepenabler.kext for AMD Systems? Or has it eluded me from my search?
      I have tried putting it to sleep, and it does, I mean everything powers down, but it never wakes up. XD
      My Specs:
      AMD Phenom II x4 BE 3.2Ghz
      Asus MBA M4A87TD/USB3
      Kingston Value Ram DDR3 1333 - @ GB x2
      WD Desktop SATA 500 GB BLUE
      CoolerMaster ELITE 335
      VANtec ION 2 620Watt PSU
      Coolermaster Hyper TX 3
      AOC E2240VW BLK 21.5 LED
      Also, no powermanagement right?
      Thanks in advance.
      Happy hacking!
    • By blud1337
      I have a 64-bit Amd phenom II x4 b93 cpu, 8GB of DDR3 ram, Gigabyte GA-78LMT-S2P and an NVIDIA GeForce 210.
      I've gotten everything to be working like Audio,network,gpu.
      Now the only problem is whenever I'm on my SL Harddrive It will randomly crash. It happens more frequently when I'm watching a video or something. What happens is, the screen flashes for a little then everything stops. Usually audio will keep playing and I can still move my mouse around but I cant click or do anything. When it happens I usually reboot and get back in then usually after the reboot it will happen again 5-10minutes after. Sometimes I can go for hours without a problem. But then somtimes it happens within the first 20 minutes.
      Any ideas on how to fix this?