Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
blibbler

HP 210-3000 Atom N570 mostly running 10.6.7

1 post in this topic

Recommended Posts

I have mostly successfully installed 10.6.7 on a fairly new HP 210-3000 with an Atom N570 (dual core with multithreading). In case anyone wants to do something similar, I'll set out what I did:

 

For the most part, I followed the same instructions for installing it on a HP 110 at:

http://www.mymacnetbook.com/2011/11/12/mac-os-x-snow-leopard-10-6-7-on-hp-mini-110-3710-guide/

 

Before I did that, however, I used gparted to create a new HFS partition (so I could leave windows installed in case I needed it). I also tried to install various other versions of OSX without success (I'm not saying other versions cannot be installed, just I spent many hours installing and re-installing without success).

 

I was forced to vary slightly from the above instructions to get things working on the 210:

  • USB in 10.6.3 - unlike in the instructions above, 10.6.3 recognised the 210's USB, which meant I didn't have to fiddle around in windows to download the appropriate drivers and updates;
  • Netbook Installer failed - when I tried to use Netbook Installer on my 10.6.7 system, it inevitably screwed it up. In the end, Netbook Installer wasn't going to provide much, so I avoided that last step.
  • No USB in 10.6.7 - One thing Netbook Installer would have done is to re-enable USB under 10.6.7. Instead I used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]'s USB restore function.
  • My 210 has an Atheros AR9285 wifi card, and drivers exist for it! Unfortunately I went through several before I found one that worked. In the end, the next from this package got me online: http://www.osx86.net/downloads.php?do=file&id=1279. After installing the kext, I had some trouble connecting to my network, the fix was to change my wifi from mixed, to just 802.11G. After that, it has worked fine.

 

So I now have a HP mini 210 running a (mostly) working 10.6.7. Unfortunately many things are far from perfect. My netbook still experiences the following limitations:

  • No control over sound volume - while I have sound, it is impossible to turn the sound down, or even mute it;
  • No control over screen brightness;
  • No control over power use (this and the previous point mean that my 210 has an OSX battery life of 5 hours, rather than the 10 hours it gets under windows);
  • The trackpad is functional, but overly sensitive, and doesn't support scrolling; and
  • No sleep or hibernate.

I understand that most of these fixes probably require diving into DSDT. I cannot seem to get my head around DSDT at all. I also see that it relates to the computer's BIOS, and get very afraid of causing permanent damage.

 

I hope this will help someone, and I would appreciate any help or suggestions to resolve the last few limitations.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       


×