Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

Cannot boot in normal mode - USB problem?

4 posts in this topic

Recommended Posts

I've updated a clean install of 10.6.3 to 10.6.8, then done the USB PCI Config Begin fix, and it can boot safe mode fine. However, booting in normal mode just gives me the spinning wheel of death, where the spinning pinwheel spins, then stops, then a new layer of it is added. I can boot into safe mode, but doing so won't let me mount UDF-formatted discs, USB flash drives, etc.


I go into verbose mode, and something like this shows up every freaking second:

AppleUSBEHCI: Async USBCMD and USBSTS not synched OFF


I used the USB EHCI fix on the DVD via the package installer (the disc was iATKOS S3 V2, and the DVD drive works fine.)


I have even downloaded some fixed versions, however I cannot transfer them.


Here were thoughts of how:

- Running the DVD then using terminal to add the files in via a USB drive, I did this before on my memory stick - niether were mounted

- Using Ubuntu to transfer the files over - Told me I didn't have permission.

- USB drive - the problematic driver(?) won't let me use it.

- Installing the USB Rollback via [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to fix the problem - trying.

- Making a DVD (bad idea?) with the kexts I described - Only mounts HFS/+ (Mac OS/Extended file system



- 1GB RAM (Minimum for SL is 512MB and it performs well anyway)

- Intel GMA 950 (I already have kexts prepared for this that will work in SL but they are NOT installed.)

- Mac OS X Snow Leopard 10.6.8 (due to this problem, Mac App Store was untested, however I can confirm a kernel panic when loading some screensavers and Front Row.)

- Realtek ALC888 (using VoodooHDA+AppleHDA on the DVD will work fine compared to Leopard 10.5.6 where I needed a Linux codec dump.)

- Netgear WG111v3 (currently using a 32-bit RTL8187B driver - I found a 64-bit kext on InsanelyMac so maybe the fact I was not on a 64-bit boot screwed up the Front Row/screensaver-related dependencies [Quartz?])

I really need help on this. I'm guessing my problem was not because of the PCI fix. I think I need a new AppleUSBEHCI.kext or similar file.


Share this post

Link to post
Share on other sites

Why is this forum so inactive? I'm not sure if this problem is easy to fix. I also tried a DSDT for my mobo (ASUS P5LP-LE) but it kernel panics.

Share this post

Link to post
Share on other sites



I hope you have e-mail notification of responses to your post, because it's now a couple of years old. I'm having a similar problem with USB ports showing up in System Profiler, but the ports won't recognise any USB devices (eg memory sticks, external drives etc) but USB mouse and trackpad work (and appear under USB in SP). I'm trying to install SL on to a Toshiba Satellite A200, and the USB ports are the only faults on an otherwise perfect install.


So, did you sort out your problem? And if so would you mind sharing the results with me?




Share this post

Link to post
Share on other sites

As the title says my keyboard and mouse stopped working after I updated from 10.6.3 to 10.6.8. After updating with the combo 10.6.8 and replacing AppleACPIPlatform.kext and IOPCIFamily.kext from 10.6.7 mycomputer boots with not problem but the keyboard and mouse don't work, actually the usb doesn't work because if you plug in a usb stick it doesn't recognize it which makes me believe it's not the keyboard and mouse but the USB. Any help will be appreciated. tried using different flags, they all boot fine but keyboard and mouse don't work.


Update my computer won't boot in regular mode now. I don't know why I didn't make any changes or anything. Still boots in safe mode (-x) but keyboard and mouse still don't work


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.