Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Mac OS X Snow Leopard on on HP Pavilion dv2000 (dv2106ea).

9 posts in this topic

Recommended Posts



I have hp pavilion dv2000 notebook. Precise model is dv2106ea.


Specifications of this notebook looks like that:



CPU: Intel Core Duo T2050 @ 1.60GHz / Instructions: MMX, SSE, SSE2, SSE3

RAM: 2GB DDR2 800Mhz

Motherboard: Wistron 30B2 (U1) / BIOS vF.39 / Chipset: Intel i945GM / Southbridge Model: Intel 82801GHM (ICH7-M/U)

Graphics: Mobile Intel® 945 Express Chipset Family

Hard Drive: 117GB Seagate ST9120821AS ATA Device (SATA)

Optical Drive: HL-DT-ST DVDRAM GSA-4084N ATA Device

Audio: Conexant High Definition Audio

Peripherals: Standard 101/102-Key or Microsoft Natural PS/2 Keyboard with HP QLB / HID Keyboard Device / Synaptics PS/2 Port TouchPad / USB Video Device / Ricoh built-in card reader.

Wired Network: Intel PRO/100 VE Network Connection

Wireless Network: Intel® PRO/Wireless 3945ABG Network Connection

Main Operating System: MS Windows 7 32-bit SP1


I am trying to install Mac OS X, because I want to try IPhone Development SDK Xcode.


Today I tried to install iATKOS S3 v2, with minimal customisation during installation.

I was not surprised, when Snow Leopard has not loaded in normal mode.

After several attempts I got it launched only in safe mode,

-v -x -f

flags helped me to do so.


If I try to load Snow Leopard with

-v -f

flags only, loading stops with text

ACPI_SMC_PlatformPlugin::start - waitForService(resoutceMatching(AppleIntelCPUPowerManagement) timed out


Any ideas how to boot Snow Leopard in normal mode?



Share this post

Link to post
Share on other sites

I continue to experiment.


Next I am trying to do is to install Snow Leopard Retail unmodified version with the help of [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] way.


1. First problem what I faced after launching [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.2.0 and Snow Leopard 10.6.7 Retail was error "start unable to initialize UIM".


This can be cured with "USBBusFix=Yes" boot key.


2. Second problem for what I have not still found solution is error "mac os x can't be installed on this computer" what I get after language selection in installer.

[RESOLVED]: Patched OSInstall does the job.

*To copy patched files needed to activate "AppleShowAllFiles" function in Finder. Manual how to do it is located here.


Successfully installed Snow Leopard 10.6.7 Retail, but still it is not usable :thumbsdown_anim:


3. Third problem is keyboard. It is not identified... How do you think, if I will buy USB-Keyboard will it be recognized?

*Why in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] manual nothing was mentioned about this problem???

[RESOLVED]: I have bought USB-Keyboard.


4. Problem number four was screen "Create Your Account". After I have filled all details and clicked "Continue" window got hanged, no response for 5 minutes.

After force restart, beautiful Snow Leopard screen was finally on by laptop's screen.





Share this post

Link to post
Share on other sites

may i advice you to try [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] straight away rather than going through that cascade of upgrades bec. Xcode needs lion to install.

i had used that exact method but someone told me to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] so i can install lion clean then use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] for lion and i did my DSDT.


my prob now is about the sleep issue, still tryin to search for soln.

happy hakintoshing...

Share this post

Link to post
Share on other sites

Hi newstar55a!


1. Mine CPU is not Core 2 Duo, so as I understand Lion is now way..


2. I saw that there is version of Xcode also for Snow Leopard, so I plan to try it.


3. DSDT building for me now is not so easy. What helped you to build DSDT successfully?

Please share some useful links, books.


Thank You

Share this post

Link to post
Share on other sites

i dont know if its possible to post links from diff. site but anyways the main goal is still hackintoshing so i hope there's no competition between diff. methods.

i followed this link from tony... http://tonymacx86.blogspot.com/2010/01/advanced-dsdt-fixes-nvidia-graphics.html

you can find all related links from that site too.


i didnt know that core duo is not supported, sorry. i thought any intel base system would be ok.


about DSDT, it's hard for me also from the start but if you have a bit of knowledge about programming then it would be relatively easy, its just adding or editing methods.

Share this post

Link to post
Share on other sites

Thank you newstar55a for your experience, but it seems to be too hard for me to edit properly my DSDT.


I installed various kexts, so everything what I need is working.


I have also installed Xcode 4.2 for Snow Leopard, so I try to do my first steps in iOS development ;)

Share this post

Link to post
Share on other sites



I have the same laptop but a variation (dv2100CTO) hp part number RM668AV but the hardware is identical. I install with the options you said to get the Video to work properly, which was also my problem (THANK YOU!!).


Have figured out the mouse and keyboard? I installed the 10.5.7 version of iatkos and the keyboard and mouse worked fine, but I want to have the most recent mac os that my computer will support (10.6.8)


I've also had to reinstall the OS several times because I'm trying to get my Belkin adapter(basic wireless usb adapter f7d1101 v1) to work.


I had it working under 10.5.7, wiped, did the new iatkos 10.6.3


When i install the driver and restart, i get the "you need to restart your computer" message in several languages on my screeln. i'm trying to find how to "undo" the .pkg install for that driver by looking in the forum since i'm still new to this. i can boot to safe mode, but its' becoming diffiuclt becuase i need files or drivers to do things. i can't access them because when in safe mode USB is not usable so my flash drive or external hard drive are useless.


I also wish i could do these installs from my USB for 10.6.x like i see you can with ###### with lion, but i don't have a core 2 duo processor.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MateusPT
      Hi there.
      Soo i was trying install mac at 4 days ago and finnaly today i can. I installed the Leopard and all works fin except the keyboard and ps2 mouse. And then i try a lot to put a .kext with transmac on windows xp cause im dual booting it.When i try to use Transmac i have the error"This drive is read only".
      Who i fix this?! This is my first question!
      The second i think is more hard. I have a Amilo Pro V3505 with 2gb ram and Intel GMA 945, a Intel Pentium T2130 idk the motherboard i aleardy try find the name but i couldnt with a Atheros ar5007eg wirless adapter.
      So i instal iAtkos S3 v2 but when i was booting(after installing) it he boots and starts make the sound of the animation video of snow leopard but THE SCREEN WAS GREY WITHOUT THE APPLE LOGO AND WITHOUT THE MOUSE JUST A GREY SCREEM.
      Well i try much flags but when i try GraphicsEnabler=No while the booting appears i recuve the message "you need to restart the computer" and i restart and gives again the same error.
      I think is some missing kext graphical but i cant add/remove kexts cause transmac give error!
      Thanks in advanced!
    • By geekingoff
      Hello everyone, this is my first post here.
      I have a pretty old laptop that I'd like to get Snow Leopard running on. At first, I tried booting Nawcom's ModUSB with a retail DVD image, but I would always get kernel panic, no matter what I tried (I couldn't even get to the installer).
      So I decided to try a distro, after trying many different things with ModUSB. I decided to use Hazard's 10.6.1-10.6.2 SSE2/SSE3 Intel/AMD distro. I was shocked when it booted to the installer with no issues! I formatted the HD as Mac OS Extended (Journaled), GPT. I then installed Snow Leopard. After a while, the installation succeeded, and I was happy. It went ahead with the restart necessary for the installation, and... kernel panic. The same kernel panic I got before when trying ModUSB. I was really disappointed. 
      I've tried many things:
      boot flags, such as: acpi=off arch=i386 GraphicsEnabler=No PCIRootUID=0 -f -s -x (and more, including verbose mode of course)
      booting the installer again after successful installation, and then going to System/Library/Extensions on the HD in terminal, then: "chmod 755 *.*" as well as "kextcache -a i386 -m *.*"
      reinstalling with no customize options selected apart from the boot loader (first installation, things such as the legacy kernel and specific kexts were specified)
      and probably some other things that I can't remember right now
      The thing is, if the installer can load with no issues, then Snow Leopard should work fine too, because they're theoretically (don't know for sure) using the same components (kernel, kexts, etc.). If I boot the installer in verbose mode, it gets right past the part where it kernel panics after installation just fine. This makes me think that something is configured differently after it is installed - something that the installer does not have - which is causing the kernel panic and preventing the boot.
      Here are the specs of the laptop I'm trying to install this on:
      Intel Pentium M 753 ULV @ 1.2GHz
      1GB RAM
      855GME Graphics/Chipset
      I know that this probably isn't the most compatible with SL, and I know the chipset/graphics are unsupported. However, I think I will be able to get it to work eventually, I just need some input on what might be going on. Looking at the kernel panic, it points toward AppleACPIPlatform.kext, but I don't know what's exactly wrong with it that is causing the kernel panic.
      Please take a look at the verbose mode image I have attached. I appreciate any and all help I receive!

    • By dark_hacker
      I am trying to install the snow leopard from the distro to amd iatkos it does well boot but when I go to the disk utility does not detect the disk do not know why someone can help me to solve this?
      There is a photo of the kexts I have in the extra folder

    • By Zaben
      Hello. I've never done VirtualBox for hackintosh, and am having trouble getting my VM to run. I been working on it for day, and still can't get it running. I enabled Virtualization tech in my bios, and still nothing. 
      This time, I tired the guide here: http://www.macbreaker.com/2012/02/snow-leopard-virtualbox.html
      I followed every step, and when I get to the Step 4, I always get this error on VBox:
      cdboot: init
      cdboot: file size: 00042300
      cdboot: reading sectors: 00000085
      cdboot: loading.......................
      cdboot: done
      cdboot: init
      cdboot: BIOS disk read error at sector: 00000011
      cdboot: error_
      I'm not sure what to do anymore, because each guide I've done ended up like this.
      Could it be because I put the .vdi on an external harddrive while VBox is on my internal?
      Could it be hardware related?
      I don't have very much room on my main harddrive, but I'll make room if that's the case!
      This is my first time trying this. 
      Also, if it helps,  I'm running Windows 10 with an i7 4710HQ, Nvidia 860m, and 8 gb RAM. It's a Lenovo y50 from 2014. 
    • By Zaben
      I'm trying to get a VM of OSX 10.6 on my PC. I'm running Windows 10 with an i7 4710HQ and Nvidia 860m. I've been trying  this method here: http://www.insanelymac.com/forum/topic/290949-how-to-install-os-x-10x-snow-leopard-lion-mountain-lion-mavericks-and-yosemite-in-vmware-workstation-1011-or-player-67/
      along with Unlocker 2: http://www.insanelymac.com/forum/files/file/339-unlocker/
      Now, this is the farthest I've made it trying to do this. I'm able to see an Apple Logo, and then it gives me an error saying that the guest OS is not Mac OSX Server 10.6. So I changed my Vmware to Workstation 11, and tried it with again and it gave the same error each time. I don't have the other OS versions, and I'm not sure whether I'm still doing something wrong, or whether it's a win 10 issue?
      I'm really new to this, and have never done OSX on a VM before. 
      I also forgot to mention, but I bought my own Snow leopards CD, and I'm still trying to figure out that guide.