Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

Mac OS X Snow Leopard on on HP Pavilion dv2000 (dv2106ea).

9 posts in this topic

Recommended Posts



I have hp pavilion dv2000 notebook. Precise model is dv2106ea.


Specifications of this notebook looks like that:



CPU: Intel Core Duo T2050 @ 1.60GHz / Instructions: MMX, SSE, SSE2, SSE3

RAM: 2GB DDR2 800Mhz

Motherboard: Wistron 30B2 (U1) / BIOS vF.39 / Chipset: Intel i945GM / Southbridge Model: Intel 82801GHM (ICH7-M/U)

Graphics: Mobile Intel® 945 Express Chipset Family

Hard Drive: 117GB Seagate ST9120821AS ATA Device (SATA)

Optical Drive: HL-DT-ST DVDRAM GSA-4084N ATA Device

Audio: Conexant High Definition Audio

Peripherals: Standard 101/102-Key or Microsoft Natural PS/2 Keyboard with HP QLB / HID Keyboard Device / Synaptics PS/2 Port TouchPad / USB Video Device / Ricoh built-in card reader.

Wired Network: Intel PRO/100 VE Network Connection

Wireless Network: Intel® PRO/Wireless 3945ABG Network Connection

Main Operating System: MS Windows 7 32-bit SP1


I am trying to install Mac OS X, because I want to try IPhone Development SDK Xcode.


Today I tried to install iATKOS S3 v2, with minimal customisation during installation.

I was not surprised, when Snow Leopard has not loaded in normal mode.

After several attempts I got it launched only in safe mode,

-v -x -f

flags helped me to do so.


If I try to load Snow Leopard with

-v -f

flags only, loading stops with text

ACPI_SMC_PlatformPlugin::start - waitForService(resoutceMatching(AppleIntelCPUPowerManagement) timed out


Any ideas how to boot Snow Leopard in normal mode?



Share this post

Link to post
Share on other sites

I continue to experiment.


Next I am trying to do is to install Snow Leopard Retail unmodified version with the help of [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] way.


1. First problem what I faced after launching [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.2.0 and Snow Leopard 10.6.7 Retail was error "start unable to initialize UIM".


This can be cured with "USBBusFix=Yes" boot key.


2. Second problem for what I have not still found solution is error "mac os x can't be installed on this computer" what I get after language selection in installer.

[RESOLVED]: Patched OSInstall does the job.

*To copy patched files needed to activate "AppleShowAllFiles" function in Finder. Manual how to do it is located here.


Successfully installed Snow Leopard 10.6.7 Retail, but still it is not usable :thumbsdown_anim:


3. Third problem is keyboard. It is not identified... How do you think, if I will buy USB-Keyboard will it be recognized?

*Why in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] manual nothing was mentioned about this problem???

[RESOLVED]: I have bought USB-Keyboard.


4. Problem number four was screen "Create Your Account". After I have filled all details and clicked "Continue" window got hanged, no response for 5 minutes.

After force restart, beautiful Snow Leopard screen was finally on by laptop's screen.





Share this post

Link to post
Share on other sites

may i advice you to try [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] straight away rather than going through that cascade of upgrades bec. Xcode needs lion to install.

i had used that exact method but someone told me to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] so i can install lion clean then use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] for lion and i did my DSDT.


my prob now is about the sleep issue, still tryin to search for soln.

happy hakintoshing...

Share this post

Link to post
Share on other sites

Hi newstar55a!


1. Mine CPU is not Core 2 Duo, so as I understand Lion is now way..


2. I saw that there is version of Xcode also for Snow Leopard, so I plan to try it.


3. DSDT building for me now is not so easy. What helped you to build DSDT successfully?

Please share some useful links, books.


Thank You

Share this post

Link to post
Share on other sites

i dont know if its possible to post links from diff. site but anyways the main goal is still hackintoshing so i hope there's no competition between diff. methods.

i followed this link from tony... http://tonymacx86.blogspot.com/2010/01/advanced-dsdt-fixes-nvidia-graphics.html

you can find all related links from that site too.


i didnt know that core duo is not supported, sorry. i thought any intel base system would be ok.


about DSDT, it's hard for me also from the start but if you have a bit of knowledge about programming then it would be relatively easy, its just adding or editing methods.

Share this post

Link to post
Share on other sites

Thank you newstar55a for your experience, but it seems to be too hard for me to edit properly my DSDT.


I installed various kexts, so everything what I need is working.


I have also installed Xcode 4.2 for Snow Leopard, so I try to do my first steps in iOS development ;)

Share this post

Link to post
Share on other sites



I have the same laptop but a variation (dv2100CTO) hp part number RM668AV but the hardware is identical. I install with the options you said to get the Video to work properly, which was also my problem (THANK YOU!!).


Have figured out the mouse and keyboard? I installed the 10.5.7 version of iatkos and the keyboard and mouse worked fine, but I want to have the most recent mac os that my computer will support (10.6.8)


I've also had to reinstall the OS several times because I'm trying to get my Belkin adapter(basic wireless usb adapter f7d1101 v1) to work.


I had it working under 10.5.7, wiped, did the new iatkos 10.6.3


When i install the driver and restart, i get the "you need to restart your computer" message in several languages on my screeln. i'm trying to find how to "undo" the .pkg install for that driver by looking in the forum since i'm still new to this. i can boot to safe mode, but its' becoming diffiuclt becuase i need files or drivers to do things. i can't access them because when in safe mode USB is not usable so my flash drive or external hard drive are useless.


I also wish i could do these installs from my USB for 10.6.x like i see you can with ###### with lion, but i don't have a core 2 duo processor.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.