Jump to content

Slow QuartzExtreme/CoreAnimation Performance?


Zanneth
 Share

6 posts in this topic

Recommended Posts

Hello all!

 

I have a EVGA GTX 580 in my hackintosh (see specs under my profile) and I am generally really happy with it. However, I am having terrible performance with QuartzExtreme and CoreAnimation. Particularly, frame rates with Mission Control, minimizing windows, and even dock magnification are pretty bad. I should mention that I have two 1920x1200 monitors attached to my hackintosh, but Aero performance in Windows is flawless with the same configuration and I've also tried unplugging my second monitor with still poor performance.

 

It is interesting to note that my Cinebench score under OS X is 36.09 fps for the OpenGL test, which seems really good to me compared to some other results from people on this forum. (Correct me if I'm wrong)

 

Currently, my 580 is setup to work by modifying the NVDAGF100Hal.kext Info.plist to include my device ID. My Boot.plist file is also attached below.

 

I have tried the following to try and fix it, but to no avail:

- Deleting AppleGraphicsPowerManagement.kext

- Modifying AppleGraphicsPowerManagement.kext to include my device ID

- Disabling Beam Sync in QuartzDebug (this makes performance much worse, actually)

 

Any tips would be greatly appreciated. Thanks!

org.chameleon.Boot.plist.txt

Link to comment
Share on other sites

Hm, well dropping in the replacement DSDT in your attachment didn't appear to fix the problem. Do you know how I can apply the patch to the DSDT file? It doesn't look like a regular patch file to me.

 

Thanks a lot for your help, by the way.

Link to comment
Share on other sites

I should mention that I discovered a strange workaround that works sometimes. If I go into System Preferences -> Displays and I turn off "Overscan", switch to 1080p resolution, turn on Overscan, then switch back to 1920x1200, mission control and all other animations become smooth again.

 

Furthermore, if I turn on "Mirror Displays" (I use dual 1920x1200 displays), it is smooth also. This was one of the first things that I tried and at first I thought the issue was because my graphics card wasn't able to handle smooth frame rates on two 1920x1200 monitors (even though it is a $500 graphics card...). However, since the workaround above works sometimes, it seems that this cannot be the case.

 

As you can imagine, I'm pretty confused!

Link to comment
Share on other sites

 Share

×
×
  • Create New...